Jump to content

Sign in to follow this  
Guest Robi

EOD object questions

Recommended Posts

Guest Robi

Hello all 1) I'make my own macro with EOD and after create the bgl file when i go into fs2002 i cannot see all textures that i've applied.My textures comes from 2 bmp files. I can see only textures that came from only 1 bmp files and the others appear black.Also into eod after apply texture when i go into texture window for 2 time, I get red crosses for some side of building.(textures Path is OK)How can i solve that problem?2) There's a program that can preview my api macros ?Thanks for your helps...Robi (Ciao)

Share this post


Link to post
Share on other sites

Are you sure that you place all the texture in the texture folder of your scenery? Also converting them to a FS format (DXT1 for example) and adding mipmaps might help.There is a small tool that shows you a wireframe view of your macro, but I don't think that adds much information to the view in EOD. The best viewer there is, is still FS self :).

Share this post


Link to post
Share on other sites
Guest EdrickV

If this is what I think it is, it's a small bug in the program. After you set a texture for any side, you should click on another side. If you don't do that and you hit the OK button then the info for the side you just worked on won't be set and it will think that side has no texture. In other words if you want to make a sign using an object that has just a front and back side, you would do this:Set the texture for the frontClick backSet the texture for the backClick frontNow you can click OK. (So last thing you do, always select a side you're not editing or have already edited. And double check by going back into the texture window before creating the API.) It updates it's texture info when the side you're on is unselected."Let me help you out. You're cleared to taxi any way you can to any runway you see."

Share this post


Link to post
Share on other sites
Guest Robi

Thanks Arno and EdrikV I've solved the problem.I don't know how but now my macro is OK.Maybe ,unintentionally, I've made what EdrickV said.Now i'm ready for my next macro.Ciao

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...