Sign in to follow this  
arno

Wrapped textures.

Recommended Posts

When I open a texture in GMax - either the UVW Editor or the bitmap preview in the Material Navigator - the texture is offset to the right. By that I mean a 20 to 30 pixel column from the right hand side of the bitmap has gone and is now present on the LEFT side of the bitmap.If I compose the mapping based on what GMax shows me then the object ends up with offset textures.An ealier thread suggested this was a PSP problem but I don't see any suggested cure. Could anyone say if a fix has been suggested for this?boneshttp://fsaviation.net

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can it be that just the display of the texture in GMax has an offset and not the real mapping? Do you have the texture correction turned on and also set the texture size (for display in GMax) to the maximum?

Share this post


Link to post
Share on other sites

Hi Arno,I've found the problem.The offset is introduced if you use ImageTool to change a BMP's properties and then view it in GMax.In PSP I created a black 256 x 256 bitmap. On this I painted a vertical red stripe 10 pixels wide and 3 pixels in from the left edge. I put a green stripe on the right side.In GMax I opened the Files.. View Image File and selected this bitmap. It was fine. Then I opened the file in ImageTool and changed the format to 24 bit and saved a copy. I changed back to 8 bit and saved a second copy. Back in GMax I looked at all three..Original 8 bit PSP image was OK.Revised 8 bit ImageTool bitmap - both red and green stripes are now on the left side of the bitmap. The offset must therefore be greater than 13 pixels.Revised 24 bit image - Red stripe is now green and green stripe is blue! Both offset but the green stripe has moved more than the right (image compressed?)Have I missed any warnings about using ImageTool to alter image resolutions?boneshttp://fsaviation.net

Share this post


Link to post
Share on other sites

I have never seen that, but I only use ImageTool to save my images as DXT. I never use the 24 bit option.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this