Sign in to follow this  
arno

Transparent Textures in FS2004 Problem

Recommended Posts

I'm transfering scenery projects from FS2002 to FS2004 and have run into a problem.I have many custom texture files that have one color set to completely transparent. This was done with FSDSV2. They all worked fine in FS2002.In FS2004, these same texture files don't show up at all. If I set the one color to partially transparent, they do show up, but the places where it should be clear, isn't.Does anyone know how to create texture files with one color transparent for FS2004??TIA:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ron... I share your bewilderment at getting texture bmps with transparent portions working in FS9. What's confusing to me is that I can simply copy some mipped DXT1 w/alpha bmps with portions fully transparent from FS8 to FS9 and they work fine with transparent portions same as displayed in FS8. These are some helipad textures I made using DXTbmp and ImageTool. However, when I try the same on a 3D object (bldg made from rectangular-cubical form with large transparent windows) all I get is the 0-255-0 green windows. In FS8, the same windows are perfectly fully transparent.In experimenting with the latter, I went back to an 8 bit bmp of the same object (circa FS7) and processed the 0-255-0 green to fully transparent using BMP2000 and lo and behold, the edges around the windows became fully transparent in FS9 --- but of course edges-only wont do. I suspect that FS9 does some 'converting of it's own', which allowed the mipped 8 bit bmp to show up in the sim -- but without "fully" full-transparent windows.'Sure hope the "TransTexVerter" gurus will step-in here and help us out... :-zhelpJ.R

Share this post


Link to post
Share on other sites

I also noted this problem when I loaded one of my sceneries in Fs2004. I think some formats are not really supported anymore and for me the best fix seems to be to convert all those old textures to DXT1/DXT3.

Share this post


Link to post
Share on other sites

I mentioned this aspect in another discussion about another topic a few days ago. What I found was that by changing the "green" used as the transparency to pure black, as in colour "0" of the pallette, the texture worked fine when processed with BMP2000 and the transparent menu. I don't have an answer as to why this should be, but it works for me!One added observation on this: the texture would need to be in the applicable format to begin with, in order for the transparency menu button to function, if memory serves me.

Share this post


Link to post
Share on other sites

OK Guys --- Thanks to Barney's tip, 'looks like we may be 'on the way' to getting it done... The ScrnShot below is a result of the following process:1. Load an old 8 bit bmp with RGB 0-0-0 (black) color for the desired transparencies into BMP2000, create and save the transparency map and the modified pallet and exit the transparency mode of BMP2000.2. In the BMP 2000 menu bar, select 'Image Tool' to create the Mips and save as a 16 bit image. That's really all I did.http://forums.avsim.net/user_files/28960.jpgThis process ended-up with the 'end walls of the box' seeming to be slightly displaced outward from the intended appearance of the 'bldg object'. 'No idea why -- It doesn't do this in my FS8 version.... BUT the FS9 transparency seems to work OK.BTW, the domed bldg in the background is not part of this test. It is there merely to demonstrate the full-transparency effect.I'm sure some of the graphics experts will be able to tell us a better way to go but for now, this seems to work...J.R

Share this post


Link to post
Share on other sites

JR,I tried your method without success. But I didn't quite understand your step 2. I figured out the "select Image Tool" (locate (path to) it in the FS2002 Gmax directory??) and then "Create image set". But I didn't see a "save in 16 bit" option. I did find another method that worked for me reliabably. (Although not as direct as your method.) Thanks to Arno for the hint, above.1. Load up the old 8-bit bmp with RGB 0-0-0 (black) color 0 as the desired transparent color into BMP2000. 2. In the transparent section of BMP2000, select the "Set Color 0 Transparent" button and change the Transparancy option from 0 to 10. (Any non-zero number may work, but 10 was my first try and worked - zero did NOT work.)3. Save Palette and exit Transparency section4. Save Extended Format Bitmat without any other changes.5. Load up ImageTool and load the above image.6. Convert it to DXT3 (Image/Format/DXT3) and save.This works for my texture files. (Don't know what I did or why it works, but it does!)The downside is that you need to keep a copy of the original 8-bit image for editing - I didn't have any luck in editing the file after the above process.Hope this helps someone!!:

Share this post


Link to post
Share on other sites

Ron... 'Went back and tried the process I described again and it seems to work fine here. After the process to set color 0 (black) to zero opacity (fully transparent), saving the transparency map and the revised pallet, the following pictures show the 'Image Tool' steps I used:http://forums.avsim.net/user_files/29070.jpgThe above picture shows the BMP2000 window with the already process bmp loaded. Note that it says it's a 16 bit 565 format bmp. If this had been the first time I loaded it prior to setting the transparency, it would not state it's a 16 bit image.Next, focus on the BMP2000 menu tabs... Click-on the 'Image Tool' Tab and note that the resulting drop down menu has been 'ticked' to: A) Use 'Image Tool' for Mips and :( Display 'Image Tool' when processing. The below picture shows the next step in that same ('Image Tool') menu tab:http://forums.avsim.net/user_files/29072.jpgThis picture shows a secondary drop-down menu of BMP2000's 'Image Tool' Tab, the "Convert Current Image To" choice. On the first test, I chose "16 bit 565" for the conversion and the resulting conversion was shown in the picture uploaded in the previous message in this thread. In the second test I did, responsive to your latest message, I chose "16 bit 444" and it also worked to provide fully transparent widows in "Andy's Hamburger Stand" :-)..The version of BMP2000.exe I'm using is dated 5/22/2001. 'Don't know if it's the latest version or not. 'Not sure, but I think that since the Image Tool.exe program is already registered in my Win98 sys registry, that it was not necessary to tick the "Find Image Tool" menu tab choice..Finally, I don't understand why you could not set color 0 to fullly transparent (Value of zero) in BMP2000's 'Set Transparency' function. I'm sure there will be a better, easier way developed for doing full transparency portioned bitmaps, but this way does seem to work.Hope this helps and BTW thanks for all the help you gave me years & years ago. I still use your Drive-In Theater while tinkering :-).J.R

Share this post


Link to post
Share on other sites

JR,Thanks for all the help! Still can't get it to work, but I think we may be chasing a different problem. See my next message!:

Share this post


Link to post
Share on other sites

Hi Barney indeed a "greyscale" value is of course the standard inmost real time engines for transparency(alpha) anyway. I for one never understood why green was used anyway. I know green is used by many apps like AVID(think green screen) for compositing images as a mask channel(I will some times use it in Maya for example when I need to composite images together(in AVID) if the job calls for "green screen") but for real time gamming engines the standard isgrey scale the Z buffer is a greyscale value as well so go figure?.Of course Flight Sim is rather arcane is it not? LOL. Dan

Share this post


Link to post
Share on other sites

Why not just make the alpha channel already in your paint program instead of letting BMP2000 (or any other program) create it based on a color you use in your image?I use this all the time now and I think it is much easier. In the paint program you can use white, black or grayscales (just like is standard as Dan says :)) and when you save it then into a format that ImageTool can read (TGA, PSD) then you just load it and the alpha channel is in your texture.

Share this post


Link to post
Share on other sites

Hi Arno yup that's all I do to create a transparent texture and it of course works. Anyway it's nice to "see" you as I've been away for a while. Dan

Share this post


Link to post
Share on other sites

Hi Dan,Maybe it did not write it correct, but it was more meant as a tip for the people with the trouble with their transparant textures. I already assumed you would know this :D.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this