Sign in to follow this  
Guest supergalacticemperor

Thin Black Line

Recommended Posts

Hi guys!I've been messing around with custom photo-real textures and everything has been going great. But for some reason there seems to be a thin black line about 1 pixel in width around the entire border of the area covered by my custom textures. I hope that someone has some ideas about what is going on and if there is a way to fix it. it's not a real big problem, but it would be nice to find a fix for it. My bitmap file is 2048x3072 in size and below is the .INF file I created[Destination] DestDir = "C:Majestic12Top SecretArea 51custom textures" DestBaseFileName = "groom_lake" UseSourceDimensions = 1 BuildSeasons = 1 [source] Type = Custom SourceDir = "C:Majestic12Top SecretArea 51custom textures" SourceFile = "groom_lake.bmp" Lat = 37.320556640625 Lon = -115.8544921875 NumOfCellsPerLine = 2048 NumOfLines = 3072 cellxdimensiondeg = 0.000057220458984375 cellydimensiondeg = 0.00004291534423828125If any has anyone has any answers for me i would appreciate your help. ThanksThe Super Galactic Emperor

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hey SGE...question...did you attempt to position the NW corner of your scenery at the corner of your image? And....did you attempt to use the latest version of resample.exe?I intentionally use the fs2000 resample.exe, which simply cuts off the area beyond the lod13 grid lines. fs2002 version fills in with black any area beyond the grid lines totally filled in. If you missed by even the tiniest bit in calculating the precision of the edge of the image to the grid edge, you'll get this black line.Bob B

Share this post


Link to post
Share on other sites

Hi BobWell I've read all of the other posts about the Black Border problem with the fs2002 version of Resample and I know I could always go back to the fs2000 Resample. But what I'm really doing is an expiriment to see if I can actually get the fs2002 version to work. Sort of a little challenge for myself to help me learn the in's and out's of this custom texture thing. I know sounds stupid, but I like to do things the hard way.The NW corner of my scenery is postioned at the NW corner of my image, which is positioned at N37.320556640625, W115.8544921875 which should be the Lat/Long coordinates of the NW corner of LOD13 area 27.27 of cell 136,149 according to Richard Ludowise's Cellgrid2 and Richard Marklew's LODcalc. I wanted to cover an area that was 12 areas across by 8 areas high. So with the Lat/Long coordinates for my NW corner I was able to calculated the Lat/Long coordinates for the NE, SE, and SW corners of the area that I wanted to cover, with each point falling on the corners of a LOD13 area. I then found those corresponding points on my image and used Photoshop 6.0 to crop and resize my image so that the image corners would match those Lat/Long coordinates as well as the cell grid lines. So i feel that theoretically my image should fit perfectly within the space covering an area that is 8 x 12 LOD13 areas tall and wide. But since it is 1 pixel off I'm guessing that my numbers are probably just a little off somewhere. I sure hope that what I just said made some sort of sense to you guys, If not I'm sorry I'm still kind of new to this stuff. The Super Galactic Emperor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this