Sign in to follow this  
Guest tasnvs

Ground2K - concave VTP2 polygons...

Recommended Posts

Hi there,I've been having a bit of trouble with creating concave VTP2 polygons. This is something I just recently noticed, so perhaps it is a by-product of the most recent update of Ground2K. Basically, the concave part of the poly seems to be getting closed off, which is not what I want. Please refer to my pictures for a better explanation as to my troubles.In the first picture, I have created the polygon. The part circled in black is the problem area - there are others too, but this is the major one.http://forums.avsim.net/user_files/56628.jpgIn the second picture, we see the results as they appear in FS2004. Notice that the concave part is closed up, and does not appear as it should like in the original Ground2K screenshot.http://forums.avsim.net/user_files/56629.jpgFinally, in the third picture, I have loaded the BGL files into LWMViewer (another excellent tool) and the VTP2 poly appears as it should.http://forums.avsim.net/user_files/56630.jpgSo, does anyone have any idea as to what my problem is? I tried searching the forum for related posts, but I couldn't find much. This only seems to affect my VTP2 polys, and not my LWM polys, like the lake in the picture.- Martin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Here's a copy of my LWM file, if that is helpful to anyone. I apreciate the help!- Martin

Share this post


Link to post
Share on other sites

Hi Martin.I wonder what your Ground2K4.Ini file looks like?Here's mine:[Ground2K4]Fl1Fois=1KeepSrce=1Language=US;DerApt1=C:Documents and SettingsDick.LUDOWRDesktopshakashaka.LWMDerApt2=C:Ground2K4shaka.LWMDerApt3=C:Ground2K4Heregoes.LWMDerApt4=C:Documents and SettingsDick.LUDOWRDesktopLandclassTestHP952070fix.LWM;DirFS=C:Program FilesMicrosoft GamesFlight Simulator 9Editor=ShowVTP1L=1DerRefLu=C:Ground2K4ResourceCityStreet.RefCutLod5=0LWMConcave=0VTPConcave=0WaterAreaFnGen=1Note that I have LWMConcave=0 and VTPConcave=0I can make your BGLs without problem with this INI setting.Dickhttp://forums.avsim.net/user_files/56738.jpghttp://forums.avsim.net/user_files/56739.jpg

Share this post


Link to post
Share on other sites

Hi all.This is the first time I've seen actual evidence that concave polys do not work in FS9. Christian had added them to reduce the number of 'splits' G2k4 had to make to insure convex polys ( smaller files and quicker compilation ).Dick

Share this post


Link to post
Share on other sites

yes, this is odd.I had a whole set of concave polygons that worked fine. A few days ago I stunmbled upon a concave poly that didn't work. I wonder what the rules are (ie which ones work and which ones don't)?Cheers, Christian

Share this post


Link to post
Share on other sites

Well I had the same crop up just the otherday also.But after putting the LWMConcave=0VTPConcave=0as Dick had said in a previous post, it fixed the problem.Cheers Norman.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this