Sign in to follow this  
Guest sapper42

Strange interaction of water effects

Recommended Posts

Hi all:I recently managed to set up AI water traffic in FS9, both floatplanes and ships. All works well and looks really neat but I have one persistent issue with the wake effect for the AI ships.I trigger the effect, fx_AI_wake_ship_l, in the aircraft.cfg file, either in the EFFECTS settings, as in "concrete=fx_AI_wake_ship_l" or in the LIGHTS section, as in "light.2=2,-19.0,0.0,-4.0, fx_AI_waterland_ship" This works as intended as long as the ship moves around on its own. However, as soon as another AI aircraft or ship enters my current view, the effect takes off toward the sky, as in the screenshot (the Beaver is an AI aircraft, selected via Ctrl-W). Once the AI ship is back on its own (in the viewshed), the effect returns to normal. Very bizarre!http://forums.avsim.net/user_files/58198.jpgI have tried all parameters of the .fx file I can think of but maybe missed something. Below is my current effect file version. Any advice is greatly appreciated, as I'd like to upload a demo package soon.Cheers, Holger ---fx_AI_waterland_ship.fx{Library Effect}Lifetime=5Version=1.00{Properties}Cockpit=1Virtual Cockpit=1Spot=1Tower=1Map=1{Emitter.0}Lifetime=0.00, 0.00Delay=0.00, 0.00Bounce=0.00Rate=1.00, 1.00X Emitter Velocity=0.00, 0.00Y Emitter Velocity=0.00, 0.00Z Emitter Velocity=0.00, 0.00Drag=0.00, 0.00X Particle Velocity=0.00, 0.00Y Particle Velocity=0.00, 0.00Z Particle Velocity=0.00, 0.00X Offset=0.00, 0.00Y Offset=1.00, 1.00Z Offset=-0.00, -0.00{Particle.0}Lifetime=30.07, 30.07Type=21X Scale=15.50, 15.50Y Scale=15.50, 15.50Z Scale=0.00, 0.00X Scale Rate=0.08, 0.08Y Scale Rate=0.08, 0.08Z Scale Rate=0.00, 0.00Drag=0.00, 0.00Color Rate=0.11, 0.11Fade In=0.10, 0.10Fade Out=0.80, 0.80Ground Normal=1Shade=1Face=1, 0, 1{ParticleAttributes.0}Blend Mode=1Texture=fx_wake_1.bmpBounce=0.00Color Start=255, 255, 255, 100Color End=255, 255, 255, 0Jitter Distance=0.02Jitter Time=1.00TempK=107.00TempRate=-19.00//TempK=109.00//TempRate=0.01uv1=0.00, 0.00uv2=1.00, 1.00X Scale Goal=85.00Y Scale Goal=85.00Z Scale Goal=0.00Extrude Length=70.00Extrude Pitch Max=90.00Extrude Heading Max=10.00

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Holger, i have 2 static default FS9 ships passing with the same FX file and from the Helo im flying and AI AC passing overhead at around 1.5 nm / 1800 Alt the effects work fine. What i have found tho is that some custom placed objects placed with XML dont appear at Dusk thru till Dawn ( didnt try any parrameters for night day etc at this time ) but i doubt its related you your problem. I tend to think that the effect is only for Flying objects and not ground based as i to have tried multiple FX code variations. I allso think that ( ref to the SDK for FS2K2 FX ) that there was still missing info that we might be lucky enough to be privy to in the FS9 version of the Effects SDK.rgds Jeff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this