Sign in to follow this  
Guest sapper42

XML TaxiwayPath commands

Recommended Posts

Gday all.Has anyone been able to get the taxiwayPaths to work without showing the surface or detail ?this is a snippet of the code im using and the taxi surface still shows which is what i dont want. Ive looked into the xsd file for clues as i have noticed that at times there are errors due to the SDK having typo's and the compile error message show where some commands should have certain letters in Uppercase and not lower case etc.If anyone has a clue as to why the drawSurface and drawDetail commands are not working for me or where to edit the xsd file id really appericiate it as ive worked out most things sofar but this now has me really stumped.thks & rgds Jeff

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Check the bglcomp.xsd and compare with bglcomp_sdk.doc when you have errors like this:W. Sieffert

Share this post


Link to post
Share on other sites

Gday mate, thats the area i tried adding the respective attributes but unless i have done it wrong, it didnt work, then again it may be working now but i might need to fiddle around with the XML code as ive noticed it doesnt allways strictly follow the SDK version. ********** ********** this is the edited version i tried but unless there is another part i need to edit its still not working, ill try a good nights sleep and start again. With luck ill get it sorted in the next few days or ill try the taxiways with a Zero width so atleast the path will be there for the AFD.thks & rgds Jeff

Share this post


Link to post
Share on other sites

I think drawSurface and drawDetail may be an error in the BGLCOMP_SDK.doc.If you search the schema, you will find those attributed to aprons only.W. Sieffert

Share this post


Link to post
Share on other sites

These errors that you guys keep finding are a pain to find in the file bglcomp.xsd. Can someone make a corrected version of this for download? Maybe some like Arno at his site? Joe W.

Share this post


Link to post
Share on other sites

Please explain further, i.e., cut n' paste your recommendation for the schema.W. Sieffert

Share this post


Link to post
Share on other sites

Sadly Joe, we all will keep finding these errors untill there are no more left to find, then it would be practical to offer a completed XSD file unless your one that doesnt mind constantly editing to update.I have found that if i set the taxiway width to "0" then my custom taxiways are OK and AI can travel the path, however , at the moment, if one chooses to use the Taxi Assist, the pink line will not dissapear behind you and is annoying aswell as unsightly. Alltho the SDK is not mandatory but an exception from MS, i feel better examples should have been written and a bit more proof reading of both the SDK Doc and the XSD file.However, its far from a perfect world but with all our efforts its hoped we can enlighten and improve such.As my personal knowledge base improves as im only tinkering with XML, i intend to write a basic tutorial with simple steps for a basic Airfield to help others like myself and use the K.I.S.S. method and allso point out the errors i and others have found.regarding the Path= message for the schema, could some clarification please be posted as i to am totally lost as i really dont understand XML.rgds Jeff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this