Sign in to follow this  
Guest C17Chief

I'm lost... going from Gmax to .asm to .xml for bglcomp.exe ?!?!

Recommended Posts

Grrr, I got my night lights put in for the ramps, now I am trying to figgure out how to turn them off during the day. I found a post where you edit the .asm source.. but now I'm lost. How do I get this .asm file to turn into a .bgl so I can put it in Flightsim?I have both the blgc.exe and blgcomp.exe, apparently the bglcomp uses xml? I'm so lost.. Can anyone give me the "dummies guide" on how to do this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

When you export from Max and are in the makemdl.exe interface, be sure you have the Keep Files box checked and the Optimize box is unchecked. Then you should be able to find your *.ASM and *_0.ASM files in the directory you compiled to from makemdl.exe. When you are finished editing the *_0.ASM file, compile to a bgl using BGLC.exe with a command like this:bglc.exe /bgl *.ASMOf course, replace the * with the name of your file. You can even make a little batch file to do this using notepad. Bglc.exe must be in a place where Windows can find it like in your main Windows directory.Lou

Share this post


Link to post
Share on other sites

Ok, I got that far, and BGLC spit out an error, maybe I did something wrong when I edited the .asm file? Does it not like spaces? I just added 2 lines in that I found somewhere else on here, about making the light_land lights go off during the daytime. Guess I'll give it another whirl when I get home.

Share this post


Link to post
Share on other sites

Can you post the errors here? Then we will probably be able to tell you what went wrong :).

Share this post


Link to post
Share on other sites

Ok, I guess I found what was wrong. I was trying to stick these lines into the _0.asm file to make my lights go off during the daytime and it didnt like it. I tried compiling the stock .asm files and it worked.. when adding the lines it gave me some "nondigit.... error". And actually, while writing this somehow I got the modified .asm to compile.. however, the lights didnt turn off during the day. I'm using:; Alphaktcmdog_Alpha label BGLCODEIFIN1 nolight, 28c, 2, 4 <<<<<<<<<<<<<<<<<<<<<<<<< DRAW_TRI_BEGIN 5926, 84 DRAW_TRI 68, 44, 46 ; poly=1 part=1 DRAW_TRI 68, 46, 70 ; poly=2 part=1 DRAW_TRI 42, 22, 25 ; poly=3 part=1 DRAW_TRI 42, 25, 45 ; poly=4 par........and ktcmdog_skip_36 label BGLCODE BGL_TRANSFORM_END ; Transform RotateAroundX nolight label word :)

Share this post


Link to post
Share on other sites

At least put the h behind it :).Normally you would place the IFIN1 command around the BGL_LIGHT commands at the end of the ASM file, when you only want to effect the lights.

Share this post


Link to post
Share on other sites

Ok.. well like you saw in my other post, I got it to compile, but now the lights still wont go off.. sorry, I posted another thread just because I guess I understand how to get from Gmax to edit the asm and back to a bgl file now.. so I just started a new post with a "different" problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this