Jump to content

Sign in to follow this  
Guest btrpilot

Another MDL to BGL problem

Recommended Posts

Guest btrpilot

Hello folks,I wondering if somebody could help me out here. I have a FS2000 B1900 that I converted to API and I'm getting a scasm error message when I try to compile. Error in line 42 -> -> missing "enda" instructionScasm compilation status: error(s) 1So I added "EndA" to the bottom...Error in line 130 -> EndA -> unresolved label :extend in line 89Scasm compilation status: error(s) 1Huh. Shows how bright I am... I was hoping sombody could help me out here.Thanks for your help,Brandon; ------------------------------------------------------------------------; XXXXX.API SCASM macro for Flight Simulator v6.x/7.x; & Airport 2.60; Generated by MDLtoBGL Copyright 2001 Trevor de Stigter; ------------------------------------------------------------------------; Airport Parameter 0 = if used & not Zero means use Parameter 1; Airport Parameter 1 = Replacement Texture File Name (excl extension); Airport Parameter 2 = not used; Airport Parameter 3 = not used; Uses the following bitmap (.bmp) Texture files:; B19C-bar.bmp; B19C-bar_LM.bmp; B19C-bot.bmp; B19C-bot_LM.bmp; b19c-eg1.bmp; B19C-eg1.bmp; b19c-eg1_LL.bmp; b19c-eg1_LL_LM.bmp; B19C-eg1_LM.bmp; b19c-eg1_LM.bmp; b19c-eg2.bmp; B19C-eg2.bmp; b19c-eg2_LL.bmp; b19c-eg2_LL_LM.bmp; B19C-eg2_LM.bmp; b19c-eg2_LM.bmp; B19C-fu1.bmp; B19C-fu1_LM.bmp; B19C-fu2.bmp; B19C-fu2_LM.bmp; B19C-fu3.bmp; B19C-fu3_LM.bmp; B19C-han.bmp; B19C-han_LM.bmp; B19C-hst.bmp; B19C-hst_LM.bmp; B19C-lwg.bmp; B19C-lwg_LM.bmp; B19C-mgd.bmp; B19C-mgd_LM.bmp; B19C-mwg.bmp; B19C-mwg_LM.bmp; B19C-ngd.bmp; B19C-ngd_LM.bmp; B19C-prp.bmp; B19C-prp_LM.bmp; B19C-rwg.bmp; B19C-rwg_LM.bmp; B19C-tst.bmp; B19C-tst_LM.bmp; B19C-vst.bmp; B19C-vst_LM.bmp; B19C-whl.bmp; B19C-whl_LM.bmp;mif( 0 ); this is to draw the airport symbol!Area( 5 %1 %2 1 ) RotatedCall( :symbol@ 0 0 %5 ) Jump( :endsymb@ ):symbol@ RefPoint( 7 : %4 %1 %2 ) Points( 1 -5 0 -10 -2 0 -7 -2 0 -2 -8 0 -2 -2 0 3 -2 0 6 0 0 8 2 0 6 2 0 3 8 0 -2 2 0 -2 2 0 -7 5 0 -10 ) Poly( m 0 32767 0 0 1 2 3 4 5 6 7 8 9 10 11 12 13 1 ) Return:endsymb@EndAmifendmif( $Version > 216 )set( areamx 64 )mifendArea( 5 %1 %2 %3 ) IfVarRange( :extend 346 %12 4 ) ;check complexity PerspectiveCall( :air_1@ ) Jump( :extend ):air_1@ Perspectivemif( %11 ) Refpoint( 2 :ret_1@ 1 %1 %2 v1= %10 v2= 60 E= %11 )melse RefPoint( 7 :ret_1@ 1 %1 %2 v1= %10 v2= 60 )mifend SetScaleX( :ret_1@ 0 0 7 ) TransformCall( :AIRCRAFT 0 408 0 -3.84 0 0 0 %5 0 ):ret_1@ Return:L015D8; **** Logical start of Aircraft drawing code:AIRCRAFT; ifVarRange( :label $H7A xxx xxx )removed; Would Skip to :L00162A if variable not in range 0 to 32016 Call32( :L00162A );;;;;;;; Variable $H7E IfVarAnd( :L0015F8 7E 0x0001 );;;;;;;; Variable $H7E IfVarAnd( :L001628 7E 0x0010 ):L0015F8 Call32( :L006E30 ) Call32( :L007260 ) Call32( :L007590 ) Call32( :L0078C0 ) Call32( :L007BF0 ) Call32( :L008020 ) Call32( :L008350 ) Call32( :L008680 ):L001628 Return:L00162A Jump( :L00168C )ReturnEndA

Share this post


Link to post
Share on other sites

I think if you place[tt]:extend[/tt]in front of the EndA command your error will be gone. This label is used for the scenery complexity check. But you never know which error comes next of course :D.

Share this post


Link to post
Share on other sites
Guest btrpilot

Nope, didn't fix that error either, here's how it looks,Error in line 39 -> -> missing "enda" instructionError in line 129 -> [tt]:extend[/tt] EndA -> unknown commandScasm compilation status: error(s) 2Brandon

Share this post


Link to post
Share on other sites

Oops without the tt, I did not notice the forum was still on plain text mode.And don't forget the EndA as well, this line must be before the EndA command.

Share this post


Link to post
Share on other sites
Guest btrpilot

I tried it and it didn't help. Now it looks like this, Error in line 130 -> EndA -> unresolved label :L006E30 in line 117Scasm compilation status: error(s) 1

Share this post


Link to post
Share on other sites

At least it is a new error :D.Is the code you posted above all you got back of MDL2BGL? In that case I think it could not read the aircraft, as the actual drawing code is completely missing. This is also what is causing this error.

Share this post


Link to post
Share on other sites
Guest btrpilot

Yeah, I thought it looked pretty short compared to the other static API's...

Share this post


Link to post
Share on other sites

Then the conversion stopped, that is also way the EndA was missing in the first place then. Did you not get any error or so while converting?

Share this post


Link to post
Share on other sites
Guest btrpilot

Come to think of it, yes I did. Thats the problem...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...