Sign in to follow this  
misho_TerraBuilder

GMAX Animation Question

Recommended Posts

This is a bit of an advanced animation question, so please bear with me...I have a rotation AND linear motion animation that needs to be timed precisely: When linear motion stops, rotation starts. The Rotation controller, as stated in the SDK, must be "LINEAR" (this means that rotation happens with no rate of change, i.e. linear), while motion has a BEZIER controller (which means you can actually assign how motion behaves from keyframe to keyframe)The problem is, the only setting for a motion key transition that keeps synched with the time line also produces a "dip" around a keyframe: the object overshoots the target position and slowly moves back to it. If I use a setting that works in GMAX (no overshooting), the synchronization is off and the whole animation is wrong in FS (looks fine in GMAX)Is there a better way to control this? I've tried everything I know...Misho

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Misho,The overshoot you are seeing is that in GMax or only in FS?I have had such problems in FS (while GMax worked fine), in that case adding an additional key or rotation key usually solved my problem. For example if I wanted a hangar door to start animating only at frame 100, I would add a position key at 100 (while the door was still in the same position) and then start animating.Not sure if this is the same problem as you have though.

Share this post


Link to post
Share on other sites

Hi Arno,I see overshoot in GMAX, but that is what I expect because I have to use "Smooth" Bezier Tangent controller. I have to use that controller because it seems FS does not work with any other one. If I use "Linear", I see what I want in GMAX (ABRUPT stop to animation) but in FS everything falls apart. Here is what I have:"O" is a keyframe, and R and T are where Rotation and translation happens. "_" are idle frames.+_____________________+______________________+ Time ScaleOTTTTTTTTTTTTTTTTTTTTTO______________________O TranslationO_____________________ORRRRRRRRRRRRRRRRRRRRO RotationEverything works in synchronization as advertised, but in order to keep it that way, I have to use "smooth" Bezier Tangent type which introduces the "dip" I mentioned (the translation goes on for a bit after the "TTTTO_____" portion). If I choose "Linear", the whole animation falls apart in FS (looks good in GMAX) as if some kind of a synchronization system is upset. Animation starts at wrong times and two time tracks become completely independent, one is now ignoring the "idle" time and starting over when it should be idle.I tried to introduce another keyframe in translation track, as in "TTTOO_____". It looks fine in GMAX but everything falls apart in FS.The above animation is a hangar door system that has inner and outer doors. Outer doors slide open left and right (translation), and at the exact moment they stop, inner door flips up (rotation)This must be an "internal" problem to FS because I don't think it was ever intended to work with animations that depend on multi-part systems and synchronization. It must be something hard coded in the animation engine in FS that handles only very specific setups. Any suggestions on this? Misho

Share this post


Link to post
Share on other sites

Hi Misho,Interesting. I have never used those smooth modifiers on animatios. It could very well be that this is a limitation of MakeMDL or FS. GMax has a lot more options then these two support.I made a test scenery and I indeed see your problem with the animation not being synchronized. I think the trick is that you need to move the sliding doors a little bit at the end of well. At the moment the last keyframe at the end time is not written to the source code. So the sliding animation has only 50 frames, while the rotating has 100.

Share this post


Link to post
Share on other sites

Actually, you have used them - if you used translational animation (and of course you have :) ) then the "smooth" controller is the default. You have 6 choices:SmoothLinearStepSlowFastCustomit seems only "Smooth" keeps everything in check. Thanks for the time Arno, I'll poke around some more and see if I can get something else out of it.Misho

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this