Sign in to follow this  
Guest Bluesman

Joining Macros

Recommended Posts

Hi allIs there a way to join API macros? I work with EOD for objects and FSSC for placement.To give an example of what I want to do: I have created something like a torch in EOD. Now I want to put a "fire" on top of it. I converted an effect to a fire-macro using fs-effects. Off course I could place the torch and the fire individually in FSSC. this works fine for flat areas but the fires "float" and don't change their position with the torch if the groundlevel is altered.I do think I could actually just join the two api-text-files, adding the fire-api to the right spot, but I have no clue how to do this.help is appreciated.cheers & thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,If you would copy the commands that actually draw the object from one API to the other it should usually work. But when merging them you need to be carefull to copy the right ones.Another option might be to just append the two sources in one file. This way they will both be placed at the same coordinates at the same time, while staying to scenery objects. This is probably easier to do, as it would not require a deep understanding of the SCASM code.

Share this post


Link to post
Share on other sites

ok, thanks so far.I'll try the first option. didn't quite understand the second one. so if you could put it in another way... ;-)cheers

Share this post


Link to post
Share on other sites

well, here's what I did so far:in EOD:- added a 'cube' to the torch-api where the fire should bewith fsEffect:- created an api from nanji's torch effectwith notepad:- pasted the info out of the torch-effect-api to the torch-api replacing the cube information.result: the torch and the flame show up, but the flame is sticking to the ground.i've attached the api-code because it turned into smilies and stuff here, haha.cheersp.s.: i have to add that i also tried to tweak the altitude inside the fx-file before converting with FSEffects. But no success.http://forums.avsim.net/user_files/149911.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this