Sign in to follow this  
Guest taalspin

Question concerning FSDEM/TmfViewer

Recommended Posts

Hi all, im new at the mesh design, managed to create something up with FSDEM. But when i look at the meshes i created with FSDEM in tmwviewer (see image) there is this area between every mesh block, anyone knows how to get rid of it? And another question, sometimes when trying to export the *.bgl files from FSDEM via resample, i got like 1kB files? Correct size would be something like ~50MB. Im trying to do an area of 5*10 degrees, works fine mostly.Any help would be appreciated, thanks in advance, Hyppe.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi.I'd strongly recommend using an older version of resample - specifically, the one provided with the FS2000 SDK. Yes, that's FS2000. The newer ones (2K2 and 2K4) occasionally produce empty bgls. I've never quite worked out the exact circumstances in which they fail, but it's very rare.I don't believe Microsoft still provide this version of the program. If you don't already have it, it's provided with the freeware version of Slartibartfast [a href=http://www.jimkeir.co.uk/FlightSim]here[/a]. I think a couple of the other design tools also include it, but I can't remember which.Unlike the newer ones, the old version comes with two more programs; "tmfcompress" and "tmf2bgl". Resample creates a .tmf file, then you tmfcompress it, then you tmf2bgl the results. A little more long-winded and the files it creates are usually a little larger than with the newer ones, but it does seem to be able to create files that the new versions fail on.Could be something else entirely, of course :)Regards,Jim Keir

Share this post


Link to post
Share on other sites

Ok, ive managed to fix the mesh gap broblem but still having probs with resample... sometimes it just keeps running and running and produces nothing. However rebooting seem to fix this temporary but i dont want to reboot my machine every few hours :(Anyway, thx for the help :)

Share this post


Link to post
Share on other sites

Hyppe,Be careful of LOD values. Ensure to set LOD9 or lower for SRTM-3, and LOD10 or lower for SRTM-1.An excessive LOD parameter results in a tiny and invalid BGL, because Resample 2002 (1.0.0.2) and 2004 (1.0.0.4) don't like oversampling. Regards,Emerson

Share this post


Link to post
Share on other sites

I've been using SRTM-3 data and LOD9 so that's not the problem but thanks for the hint.

Share this post


Link to post
Share on other sites

So here is another suggestion: had similar results, and then I placed my strm files in the same dir as FSDEM. The bgl files became valid. Taalspin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this