Sign in to follow this  
Guest dajackman

New Fly! user

Recommended Posts

I bought Fly! II some time ago but uninstalled it, I just now installed it because wanted more buttons to push. (Fly! has the best panels) but it seems like the whole sim moves in incredible slow motion, mainly the controls of the aircraft, the movement of the prop, and theres no sense of speed at all. Is there something wrong with it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

We would like to help you, but we need more information concerning your setup:Did you patch Fly2 to the latest patch?What is your hardware setup?

Share this post


Link to post
Share on other sites

No I dont have the latest patch. Heres the hardware specs:Win XP ProAMD 1700+396 RAM20GB 7200 RPM HDGeoforce 2 MX200 w/ 30.82 driversLet me know if theres anything else I should list

Share this post


Link to post
Share on other sites

You should update to the latest patches before trying anyhing else. Then I would check your video drivers, make sure you have the latest version of them...Looks like your machine is OK. I would update that video card soon...thats just me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this