Sign in to follow this  
Guest GalacticCowboy

Why can't I use the keyboard to control the throttle?

Recommended Posts

Hitting F2 or number pad 3 to decrease throttle power doesn't work. Nor does hitting F3 or number pad 9 to increase the power.I've checked the assignments (even resetting the default settings)but with no luck. However the throttle on my joystick works normally.Any suggestioin please?Cliff (In Spain)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Cliff,It is my guess that somewhere in assignments your joystick is overriding the keyboard as the means of control. The problem has to be with your settings and not Flight Simulator since I use mouse and keyboard for all my flying without problems and do not have a joystick. Have you tried unplugging the joystick?Denis (In North Wales)

Share this post


Link to post
Share on other sites

Bingo Denis! As soon as the stick was disconnected the jeys worked perfectly. After connecting again the same problem existed.Any idea where I go from here?Cliff (In sunny Spain...I saw your weather report on Sky today...)_

Share this post


Link to post
Share on other sites

Cliff,Now you have me at a disadvantage. Since I fly in a joystick free zone (yoke and pedal free zone for that matter) and have no software installed for one, the joystick option in Assignments is dimmed. I do recall however when I flew on a friend

Share this post


Link to post
Share on other sites

Thanks for trying Denis. Why not try Spain one day? I retired from London some 14 years ago.............the blue skies make all the difference.Off to bed now, past midnight.Regards,Cliff

Share this post


Link to post
Share on other sites

Well if you're in fs2002, goto assignments and see what keyboard key is assigned to those commands, Then check the same commands for the joystick assignments. There might be a conflict.RD

Share this post


Link to post
Share on other sites

The computer will disregard those keys while reading the joystick.The joystick will override those keys. Unless you tell it to ignore the joystick. The computer cannot guess what inputs to read, it can only read that which has been assigned to be read.When my joystick throttle lever is at the bottom, then F2 does deploy the thrust reversers.

Share this post


Link to post
Share on other sites

Ihor: Can you put Cliff out of his misery by telling him how to instruct Flight Sim to ignore the joystick? I can

Share this post


Link to post
Share on other sites

Thanks for the suggestion Ihor. But, as Denis suggests, can you tell how to do follow your suggestion please?

Share this post


Link to post
Share on other sites

Thanks RD. I tried that and even reset the assignment defaults.They're "Increase the throttle" F3 and 9 "Decrease the throtte" F2 and 3The part that puzzles me is that not too long ago I was able to use either the joystick throttle or the keyboard.And, yes, I'm in FS2002.Cliff

Share this post


Link to post
Share on other sites

Go into FS2002 menu Options - Controls - Assigments.Then select 'joystick axis', and look up the Throttle axis assignment.Select this assignment by clicking on it, and then click button "Delete assignment"Rob

Share this post


Link to post
Share on other sites

If there is a bit of jitter in the throttle axis on your joystick, FS will see this as "movement" and override your keyboard settings to whatever position the throttle is in. Try adding a bit of dead zone on the throttle axis, or calibrate the joystick and see if you can get rid of this jitter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this