Sign in to follow this  
Guest harry3

Fly! 2K Direct X 6 Error and crash!

Recommended Posts

Hi!After long time just flying with Flight unlimited3 and FS2002, I thought I could install Fly!2k(fully patched version of Fly!1).But after just one minute flying, I'm always getting an error message and then Fly! crashes. TITLE:directx6 3d driver errorTEXT3D3ERR_ELINFO: an unknown 3d3 error occured.I'm using a geforce 4 440MX and direct x 9 I think.Is there some way to get around this error or is it impossible to run Fly! on my system???Regards,Harry

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I run fly! with Win xp, which has directx9. It's important that during the installation that you do not install directx 6,which the program expects you to install.tony

Share this post


Link to post
Share on other sites

Of course I didn't install DX6, as I've DX9. (I wasn't even asked)<What is that and how can I do this?Well, I've switched the graphic options from DX6 down to DX5. It seems to work now :-)But I'm going to test this more in detail today.Regards,Harry

Share this post


Link to post
Share on other sites

Harry,In order to run the best (if at all), Fly! needs to be optimized for your card. Since your card and driver came out long after Fly!/Fly!2K were released, none of the VCF (Video Card Files) in the Fly! System directory will be totally compatible with your card. The list of graphics drivers is generated by the VCF files - there are VCFs for the DX6 and DX5 drivers, for instance.I'm getting ready to leave for an appointment right now, so I don't have time to give you the full procedure. Basically, it works like this:1. Generate Video Card Report from within Fly! and obtain Vendor and Device IDs.2. Open the DX6 VCF and edit in your numbers.3. Save the file as a new VCF and give it the identity of your card.4. Restart Fly! and pick the new driver from the graphics setup - everything should run well.I'll check back in tonight and give you the detailed steps, if someone else hasn't been able to fill in the gaps in the meantime.

Share this post


Link to post
Share on other sites

Thanks for your help. But I think I need some more help to get it work!Well, I've found those *.vcf files. There are *.vcf files for the video cards and for the different graphic modes(e.g. DX6AGP.vcf).How can I do a VCF report from within Fly!??? My video card is the GeForce4 MX 440. What is the identity of my card, that Fly! recognizes this vcf file as the one which should be used???Please help me, because Fly! is to good than to be removed from my hard disk. Regards,Harry

Share this post


Link to post
Share on other sites

I've now found some tutorial about those vcf files.I've created a report which looks like this:Video Card Report for FLY!============================================================================================Direct3D (Most hardware) (trid3d.dll)Card #1: Card Name = display Card Desc = Prim

Share this post


Link to post
Share on other sites

Hello Harry,Sorry I couldn't get back to you till now - it looks like you found Elrond Elvish VCF tutorial, which is a great tool. I see at least one error and will also make other recommendations.1. You have an improper video dll listed after your card name. It appears you entered the card name dll instead of the Fly!-compatible dll listed in line one of your section of the report. The information you need from the Video Card Report comes from lines 1, 4, & 5 of the report. You have properly entered your Vendor and Device IDs from lines 4 & 5. Replace the dll under your title with the dll listed in line 1: DirectX6 (Some hardware) (tridx6.dll).Your first 2 lines would be:NVIDIA GeForce4 MX 440tridx6.dll2. Be certain that your VCF file is set to Read-only. This is necessary for them to function properly. Right click the file in Explorer, click Properties, select the Read-only attribute. If you ever need to edit the file, you'll need to turn off the Read-only attribute. When you are finished editing and the file is saved, reset the attribute to Read-only.3. This is just a recommendation - you have no adjustments in your video slot assignments that would allow the textures to diplay at the highest quality and allow for anti-aliasing. I think I based my settings on Elrond's recommendations for a 64MB card and FSAA. I am currently using a 128MB card with great results. Here is my VCF file - you may want to try the settings I use in the texture count lines:GeForce 4 FSAA (AGP)tridx6.dll4318 // Video Card ID #1592 // Video Card ID #22 // AGP Flag (0=no AGP, 1=High Detail, 2=High Detail+Triple Buffer)1 // AGP Must Exist (if AGP is non-zero on previous line)0 // Mip mapping0 // Allow AutoMipMapping (Mip Mapping must be off)0 // Direct Texture Mode0 // Alternate Blend Mode0 // Texture Count 32 (0=default)48 // Texture Count 64 (0=default)224 // Texture Count 128 (0=default)64 // Texture Count 256 (0=default)6 // Video Res Count640 480 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))800 600 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))1024 768 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))640 480 32 0 // Video Resolution (last number is relevance (1=default, 0=normal))800 600 32 0 // Video Resolution (last number is relevance (1=default, 0=normal))1024 768 32 1 // Video Resolution (last number is relevance (1=default, 0=normal))0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // ReservedGood luck!

Share this post


Link to post
Share on other sites

First of all: Thank you very much for your help! :-)But no, the same error came again:(see attachment!!!)Here's my VCF File:////////////////////////////////////////////////////////////////GeForce4 MX440tridx6.dll4318 // Video Card ID #1369 // Video Card ID #20 // AGP Flag (0=no AGP, 1=High Detail, 2=High Detail+Triple Buffer)1 // AGP Must Exist (if AGP is non-zero on previous line)0 // Mip mapping0 // Allow AutoMipMapping (Mip Mapping must be off)0 // Direct Texture Mode0 // Alternate Blend Mode0 // Texture Count 32 (0=default)0 // Texture Count 64 (0=default)999 // Texture Count 128 (0=default)0 // Texture Count 256 (0=default)6 // Video Res Count640 480 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))800 600 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))1024 768 16 0 // Video Resolution (last number is relevance (1=default, 0=normal))640 480 32 0 // Video Resolution (last number is relevance (1=default, 0=normal))800 600 32 1 // Video Resolution (last number is relevance (1=default, 0=normal))1024 768 32 0 // Video Resolution (last number is relevance (1=default, 0=normal))0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // Reserved0 // ReservedMaybe I should switch down to DX5 again!?Regards,Harry

Share this post


Link to post
Share on other sites

Harry,Somehow, you've made some changes in your VCF that may have turned off standard AGP access for your card and also created a conflict. Please change the following lines to at least these settings:1 // AGP Flag (0=no AGP, 1=High Detail, 2=High Detail+Triple Buffer)1 // AGP Must Exist (if AGP is non-zero on previous line)0 // Mip mappingIf you'll note my previously posted VCF, I've taken mine all the way to a setting of 2 on the AGP Flag (triple buffer). You can also set Mip-mapping to 1 if you want to reduce shimmer.I also recommend that you NOT use the 999 setting for texture slots, but try the settings from my VCF, or you may not be able to use FSAA if Fly! takes all of the slots for textures.If none of these things work, I suppose you can change your second line to the DX5 attribute, but even your Video Card Test from Fly! indicates that you tested at DX6.Lastly, what driver set are you using? Some of the newer drivers are not compatible with Fly!2K (or even Fly!II, for that matter). I find that the nVidia 45.23 set do very well.

Share this post


Link to post
Share on other sites

Thanks once again!But it doesn't work.I'm going to switch down to DX5, as it worked fine!I'm using 61.77Works great for all other software, just Fly has it's problems.But as long as DX5 works...Regards,Harry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this