Sign in to follow this  
Guest louis the fly maniac

FlyII crashing with a "ATC stack full" errormessage

Recommended Posts

Hi, it's been a while.Recently I restarted using FlyII again, after using it quite some years ago. While I did a trip from Prudhoe Bay along the Northwest passage down to Frobisher Bay, Canada, my program crashed with a box "ATC stack full" or something similar. Actually I only had used TWR and DEP comms then was handed over to some Center but without a plan filed there was no way of communicating. Around Cornwallis Island the crash happened. This was flying a Mirage.Yesterday evening I filed a plan CYYT-BIRK-EHAM with the Peregrine jet and around 200 nm ahead of BIRK the same #### happened. This time I had been on radios, TWR, DEP, next Center first Gander and shortly before the crash I got handed over to Reykjavik. I recall from a few years back I did a nonstop EHAM-YSSY (which I completed with mebbe 5 mins of fuel in the tanks) in a 747SP, also with a complete greatcircle plan. I kept ATC going all the way down, forced it a few times because of the infamous "service terminated" messages but there was absolutely no crash then.Anyone with a clue perhaps? FWIW, Fly is patched up to 2.5.240

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Louis,There have been issues with the default ATC system - if you activate the ATC and/or file a flight with the default ATC active, then don't respond to a communication, the system will continue to query you until the limit (stack) is reached.I have also experienced this issue with C4TO (Cleared 4 Take Off) installed. When I first began using C4TO (which is better than the default ATC system) I had left the default ATC active. I wasn't listening to the default (had turned off its sound), but it continued to run in the background. As I wasn't responding to its queries, the stack filled and the sim eventually crashed. I simple went into the fly.ini file and disabled the default ATC - that solved the problem.If you have the default ATC active but are not filing a flight plan, don't run any communications at all. If you file, then you should be able to use it without the stack filling, as long as you respond to all communications.I recommend shutting down the default, then install Flyscripts! and C4TO. After you get used to it, you may also want to to try a newer version of C4TO set up in a DLL as a beta program with some new features.

Share this post


Link to post
Share on other sites

Randall,I was suspecting something like that already. Strangely enough, I think I never missed a part in the comms. You can usually find out by hitting the ~-key, when it states "say again" and "confirm" you missed something, but it didn't. Last thing was Gander turning me over to Reykjavik and I both confirmed and retuned. Anyway, I'll give C4TO a try instead (I ran it on the original Fly too and it's loads better and at least sounds like the real thing lol)Thanks for clearing this one up!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this