Sign in to follow this  
Guest

Fly! 2K & OS9.1 woes. Please help!

Recommended Posts

Hi, I hope someone can help me wtih this... This post will be fairly long as I've done extensive testing (aka messing around) so I can provide exact details and I hope it will all make sense.Under OS9.0.4 (or under) Fly!2k works perfect.Under OS9.1 (or higher) Fly!2k always crashes in the GUI.Here's the specifics. Whenever I click a button in the GUI or in the options it crashes with error type 3 (illegal instruction). It's definately a mouse thing because if I use the keyboard I can successfully get into the cockpit and then the mouse works fine (everything works). It's only in the GUI that this happens. Normally I'd just use the keyboard at this stage and forget the mouse but unfortunately I need to be able to set options and it crashes there too. There's only so much you can do through editing ini files manually (you can't specify resolution there, etc.). Anyway, I've tried everything I can think of (changing mouse drivers, changing the mouse, reinstalling 9.1, changing every conceivable option in the ini files, allocating up to 600mb's of physical ram, etc.). No luck. Now I can't believe I'm the only person having this problem? It works fine under older versions of the OS. It's just something about OS9.1 and newer that Fly!2k hates! Others must be having the same problem no? Of course I've emailed God Games support (*LAUGH*) several times with no reply (what a suprise - not). Any suggestions as to fixing this would be greatly appreciated so I can take to the blue skies once again. I'd just play Fly! 2 but of course it can't run on any mac known to man (oddly enough it says it runs on a mac on the box). heh.Here's my system specs:G4/450 DP w/ 640mb's ramStock AGP ATI 128 RageProOS9.1 & 10.1.3Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm looking into a few things regarding this, but will need a little time tonight. As you have the original version, you might, in the meantime, go straight to TRI. I think it's support@terminalreality.comPlease look in your extensions folder and see what version of CarbonLib you have and post it here. That might help point to a solution.

Share this post


Link to post
Share on other sites

Could be an extension conflict? have you tried running Fly! with just the minimal and base extensions? I get Fly! 2K to run, no problem under 9.2.1. so it has to be some software issue outside of Fly! 2K. Keep us informed on your progress,Pete

Share this post


Link to post
Share on other sites

I've suffered through the same problem with Fly!2k and OS 9.1. I've got both a Radeon and a VooDoo5 in my machine. The problem exists only when I'm running the Radeon. Here's what works for me.Like most people I trim down on the number of extensions I typically have running by using the extension manager. The only way I can get Fly!2k to run with OS 9.1 is to turn ALL of my extensions on and reboot. Fly!2k then works just fine. I agree this solution seems ridiculous.I've spent hours systematically trimming extensions one at time and rebooting trying to find out just which extension is the culprit. Never have figured it out. One day it's one extension the next day another. Like I said the only thing that always works is to enable all extensions, reboot, then launch Fly!.

Share this post


Link to post
Share on other sites

I had the same problem getting a copy of the pre-2K version to run under 9.1 on an 8500 tower with a NewerTech G4/450, ATI Nexus 128 & 256 MB RAM; it ran OK under 8.6 on the same hardware. In my case the problem was solved by disabling the Apple Guide extension. I've been running this way for several days & haven't had the problem since, and the only thing in the system I've seen this break so far is the Remote Access control panel, which is easily worked around via the Remote Access Control Strip module. Hope this helps!

Share this post


Link to post
Share on other sites

I used Fly2k on a Mac for a while, and then suddenly I was getting error messages. I found out that in the Graphics settings, my video card setting had changed (by itself) to "software only". Putting it back to "use video card" (or similar) solved the problem. I hope this works for you because Fly2K is great, especially with the USA scenery from flyscenery.com. Best wishes. Barrie Myers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this