Sign in to follow this  
Guest olympic2

Displacement in UK South

Recommended Posts

Greetings all,I seem to recall another post along this line, but try as I might I do not seem able to find it now.I have just reloaded FU3 (Seattle/SanFran/UK South) and all work fine - except for one liitle problem.In UK South, if you choose "Quick Flight" and position the aircraft, when you go into the sim, the aircraft is in fact located some distance fom where it should be. I have also noticed that when you move the pointer to position yourself in "Qucik Flight", the 0 deg of Longitude is actually some distance to the WEST of Heathrow airport - probably as much as 50 to 60 Klms.This discrepancy is not in Seattle or SanFran.Any advice welcomed.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There's a map offset issue that I know of (and I have no idea how to fix it). I think everyone's maps are affected though, so don't feel bad ;)My UKS is still full of water :-eekRegards,**************Jonathan Point**************"I'd rather be down here wishing I was up there than up there wishing I was down here"

Share this post


Link to post
Share on other sites

Thanks for that info.I did come across the following in the region.cfg in UK-SouthQUOTE; UK-Southreg_utm_zone 29;-> utm_offset: Easting Northing bottom left corner -10d07m30 E / 48d41m24 N;reg_utm_offset 417205 5393606 original from computing; corrected to get 0.0w / 51.5n at the correct point in Londonreg_utm_offset 412900 5440920 ; corretti per Goodwood: reg_utm_offset 419700 5436000 ;reg_utm_offset 417205 5393606UNQUOTEUnfortunately I have not had a good look at the FU3 white paper to make a lot of sense of it but it could help explain the discrepancy.The point -10E/48N is some 140 miles West and possibly about 100 miles South of Lands End.

Share this post


Link to post
Share on other sites

You may be onto something here, although I don't know why others haven't sorted it already. I believe that all regions are referenced to the south-western corner. If this is the case, and UKS is improperly referenced, does this suddenly make everything else wrong if we correct the offset?Maybe it's just the map? :-waveRegards,**************Jonathan Point**************"I'd rather be down here wishing I was up there than up there wishing I was down here"

Share this post


Link to post
Share on other sites

Further to previous thoughts.The discrepancy appears to be in the "In-flight Map".Looking at Heathrow in FLED, the airport is actually at 51*28'N/0*25'W (give or take a couple of seconds) which is correct (according to MSFS anyway - I do not have access to UK airport location info).On the "In-flight" map it shows as 51*20'N/-1*5'W, a point some 48klms on a bearing of 251deg from the correct spot.Anyone have any ideas on how to amend the "In-flight" map?For Cristian:Please do not take this as criticism of the UK-South pack as I do think it is great. Its just that I like to do a bit of Quick flight hops and it is hard to locate yourself where you want to be.Keep up the good workcheers

Share this post


Link to post
Share on other sites

Haha, don't worry, I won't take this as criticism... :) I'm well aware of the problem myself, and I spent a lot of time in the early days of UK development, trying to fix this issue, but I didn't succeed. Everytime I fixed the coordinates in one place, the things got worse somewhere else. I tried by trial and error, I tried with some "extrapolation" formulas, but everything failed... :- I honestly gave up on that problem, hoping that someone else could fix it! :)Cristian

Share this post


Link to post
Share on other sites

Hi olympic2,Caution at changes to utm_zone and reg_utm_offset this is for the position of the lower left cornet of the region with the tile name aaaa ! Modification to this values will move all airports and models away for the position synchronized with the texture of the ground. I have set this to get the correct position of the millennium dome as reference. The region itself for UKS is much larger than the map to have enough water around UK till to the horizon. Until now it was not possible to get the correct values for the parameters in the region config file. The parameter concerned are (with older tests commented out):QUOTE; These are the mappings from world; to pixel coords for region map and vice versa;reg_map_col1 0.0057 0.00265 0;reg_map_col1 0.0057 0.00065 0reg_map_col1 0.0045 0.00005 0; ;reg_map_col2 0.0001 -0.00645 0;reg_map_col2 0.0001 -0.00645 0reg_map_col2 0.00003 -0.00450 0; proporz. x,y;reg_map_col3 200.0 1930.0 1;reg_map_col3 165.0 2550.0 1reg_map_col3 -1200.0 2380.0 1; posiz. x,y;reg_imap_col1 150 0.002 0;reg_imap_col1 150 0.0025 0;reg_imap_col1 360 10.01 0 x pos;reg_imap_col1 420 0.001 0 reg_imap_col1 420 5 0;reg_imap_col2 0.0 -155.5 0;reg_imap_col2 0.0025 -150 0;reg_imap_col2 -0.001 -300 0 y posreg_imap_col2 -5 -240 0;reg_imap_col3 -29800.0, 283500.0 1;reg_imap_col3 -29800.0, 283500.0 1;reg_imap_col3 -100.0, 540000.0 1reg_imap_col3 -1000 540000 1UNQUOTEYou can check the settings directly using the quick flight map. Select for this a location in the center and watch the elevation menu. The upper left corner of the menu must collapse with the mouse cursor like thishttp://www.agtim.ch/fu3/images/QFOK.JPGand NOT spaced like thishttp://www.agtim.ch/fu3/images/QFNOK.JPGmodify the parameters and try it out. Hope you find it :-)Another way is to use FLED to get the utm coordination for the center of the current FLED window -> see values in the bottom left corner and click there until utm is shown.Using this values, create entries in POI.TXT.in quick flight mode view POI and select one as starting point - then you will really be there with the plane in the selected altitude. :-wave agtim

Share this post


Link to post
Share on other sites

Are you saying that you now know the correct co-ordinates? I have no objection to rebuilding 'my' scenery to get this correct.Also, you have a different map. Is this the UKS map we should be using? Where do I get it? How do I install it?Also, you have only a few of the airfields. Have you had a chance to install Dave's upgrades and can you get them to work?Sorry for so many questions! I am currently trying to relaunch UKS with help from Jon, and the whole UKS is a mess at present with the new ATC, new tiles, new packages and new models databases all being added at once, with no-one co-ordinating or making a stable version. I suspect that at the moment I am the only person with a stable version, and I am trying to get this across to Jon, then to others. However it has simplified air regions and the 'old' map.RobD.

Share this post


Link to post
Share on other sites

agtim,Thanks for the info.After checking the "quick flight" option, there is one only spot on the map where the menu collapses as you show in image 1. In all other places there is no alignment at all, but I notice that the point of entry into FU3-UK is always at the point of the top left hand corner of the menu irrespective of wher you actually click.Now that I know a way of actually placing the aircraft where I want it, I will not mess about with those co-ordinates.By the way, LOVE that map - how do I get one?Cheers

Share this post


Link to post
Share on other sites

Hi Robert and Olimpic2,This is my testmap from a roadmap ( source as usual, but 1:200000 )The map is very large and inside the resreg.res file. I am not happy with the quality. Name of locations can't be read exept in largest zoom. You have to produce a bitmap for the largest map in resreg.res and resize it twice to get the smaller one. Then load with resource viewer. Source of the map can be any map of the region with good resolution and not too much text.Robert we have to talk by direct mail or in the developer forum for the continuation. I have a second installation with Dave's airport but same problems at high AI density. :-wave agtim

Share this post


Link to post
Share on other sites

OK boss. I'll email you. You're doing a great job here though - I don't know how you manage to get so much done. Congrats on your new Switzerland work too. Is Dulwich going to be uploaded soon?RobD.

Share this post


Link to post
Share on other sites

Hi Robert,Do not forget to put FU3 in the subject of the mail.I use a hard filter to process the 250 spam mails per day.all unregistered user / or without keyword FU3 are trashed on the server. It's the only way, have build a tool for that (LookFirst).see www.agtim.ch/I have also realized that I have lose my membership to the developer group :-(, no idea how to get in back. :-wave agtim

Share this post


Link to post
Share on other sites

I'll have to email you next week now - run out of work time (home computer not hooked up to internet).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this