stephowz

Members
  • Content Count

    4
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

Profile Information

  • Gender
    Male

Flight Sim Profile

  • Commercial Member
    No
  • Online Flight Organization Membership
    none
  • Virtual Airlines
    No

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I ordered the PTA from Simmarket But cannot activate. I tried many times but without success. ERROR: activation failed: Server error . Please help. https://www.234.in.th/images/2019/08/30/8-30-2019-6-41-13-PM.jpg https://www.234.in.th/images/2019/08/30/8-30-2019-6-42-03-PM.jpg
  2. not support p3d v.4 ?
  3. I try to install 777 immersion. When I click direct install I found " You need to have at least one compatible simulator installed to use this product" My sim P3D v.4, I have FSUIPC v.5 full version register complete . help me please