elheroes

Members
  • Content Count

    29
  • Joined

  • Last visited

Community Reputation

2 Neutral

Flight Sim Profile

  • Commercial Member
    No
  • Online Flight Organization Membership
    none
  • Virtual Airlines
    No

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Did a fresh reinstall after major Windows update (1809) Still the same problem........ What do you mean by "Make sure you configure the trainer for the GTN 750" ?
  2. Did you try a few times ? It happens that you get a black screen but eventually it'll work
  3. @Mark : I wouldn't say it's useless ! As far as I'm concerned once all the alert popups have been closed everything is working smoothly
  4. Salut Jean-Luc et très bonne année à toi ! For your information my situation is still the same : I did install the latest RXP release (2.5.11), but the same issue occurs
  5. Since I've got 2 versions of the Garmin Trainer (6.21.0 working OK and 6.50.1 with the loadlibrary issue) I'm using the 2 variables documented in the RXP manual to point to each of one : GTNSIMDATA & GTNSIMPATH
  6. Version 2.5.9 installed with Garmin Trainer 6.50.1 Same issue Here is the rxpGtnSim.dll.log : 18/11/25 08:28:02.803 47824 - ] # rxpGtnSim64.dll version 2.5.9.0 18/11/25 08:28:02.802 47824 INFO ] 18/11/25 08:28:03.975 47824 INFO ] using: D:\Users\web2\Documents\Prepar3D v4 Add-ons\A2A\SimObjects\Airplanes\A2A_C172\checklist.gtn 18/11/25 08:28:04.038 47824 WARN ] not found: C:\ProgramData\Garmin\Trainers 18/11/25 08:28:05.440 22988 INFO ] 18/11/25 08:28:06.118 02960 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_c.dll. GetLastError: 126 18/11/25 08:28:07.714 45064 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_d.dll. GetLastError: 126 18/11/25 08:28:08.494 20244 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_com.dll. GetLastError: 126 18/11/25 08:28:09.532 50424 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_nav.dll. GetLastError: 126 18/11/25 08:28:10.412 13412 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_waas.dll. GetLastError: 126 18/11/25 08:28:11.272 06172 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load nav_main.dll. GetLastError: 126 18/11/25 08:28:12.062 51316 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load prx_main.dll. GetLastError: 126 18/11/25 08:28:12.843 49724 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load dbm_main.dll. GetLastError: 126 18/11/25 08:28:13.689 50736 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load cht_main.dll. GetLastError: 126 18/11/25 08:28:14.434 46536 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load tws.dll. GetLastError: 126 18/11/25 08:28:15.122 50212 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load iop_e.dll. GetLastError: 126 18/11/25 08:28:15.862 02952 INFO ] GTN: 00 ..\..\src\krnl\krnl_lib\sim\tsk_win_prj.c(188) Error: LoadLibrary failed to load apth.dll. GetLastError: 126 18/11/25 08:28:16.196 18148 INFO ] GTN: 00 ..\..\lib\acl\tsk\processors\arm\tsk_usr.c(1970) (null) 18/11/25 08:28:16.575 10580 INFO ] GFX Debug: enabled. The only difference I can see is strangely the fourth line : "not found: C:\ProgramData\Garmin\Trainers", strangely because the path is correct Here is the Trainer log file C:\ProgramData\Garmin\Trainers\Databases\assert_log.txt : 12/31/89 00:00:29 PwrCnt:228 ERR_ASSERT_CONTINUE (47) OnSecs:29.415 PwrHrs:170 SwVer:6.50.0 Rpt:0 Temp:327.67C F:hwm_usr_err.c L:712 MSG:Err log cleared with SW PN 006-B1026-XX -------------------------------------------------------------------- 12/31/89 00:00:09 PwrCnt:230 ERR_ASSERT_CONTINUE TSK_proc_loader OnSecs:9.710 PwrHrs:172 SwVer:6.50.1 Rpt:36 Temp:327.67C F:tsk_win_prj.c L:188 MSG:Error: LoadLibrary failed to load apth.dll. GetLastError: 126 -------------------------------------------------------------------- 12/31/89 00:00:10 PwrCnt:230 ERR_ASSERT_CONTINUE SYS_Integrity OnSecs:10.115 PwrHrs:172 SwVer:6.50.1 Rpt:5 Temp:327.67C F:tsk_usr.c L:1970 MSG:SYS_Integrity -------------------------------------------------------------------- 12/31/89 00:00:05 PwrCnt:230 ERR_ASSERT: UTL_ass IOP_b_main OnSecs:5.025 PwrHrs:172 SwVer:6.50.1 Rpt:1 Temp:327.67C F:sys_init_prj.c L:176 MSG:IOP_b_main -------------------------------------------------------------------- 06/01/17 12:08:46 PwrCnt:228 ERR_ASSERT_CONTINUE IOP_log OnSecs:16.100 PwrHrs:170 SwVer:6.50.1 Rpt:0 Temp:327.67C F:iop_log_circ_ar.c L:399 MSG:Open Err: -24 -------------------------------------------------------------------- 06/01/17 12:08:46 PwrCnt:228 ERR_ASSERT_CONTINUE IOP_log OnSecs:16.100 PwrHrs:170 SwVer:6.50.1 Rpt:0 Temp:327.67C F:iop_log_circ_ar.c L:452 MSG:Open Err: -24 -------------------------------------------------------------------- 06/01/17 12:08:46 PwrCnt:228 ERR_ASSERT_CONTINUE IOP_log OnSecs:16.100 PwrHrs:170 SwVer:6.50.1 Rpt:0 Temp:327.67C F:iop_log_circ_ar.c L:198 MSG:Open Err: -24 -------------------------------------------------------------------- 06/01/17 12:08:46 PwrCnt:228 ERR_ASSERT_CONTINUE IOP_log OnSecs:16.100 PwrHrs:170 SwVer:6.50.1 Rpt:0 Temp:327.67C F:iop_log_flight_data. L:1725 MSG:Flight Data Log corrupt. Resetting... -------------------------------------------------------------------- 06/01/17 12:08:49 PwrCnt:228 ERR_ASSERT_CONTINUE IOP_log OnSecs:19.100 PwrHrs:170 SwVer:6.50.1 Rpt:0 Temp:327.67C F:iop_log_circ_ar.c L:534 MSG:Open Err: -24 -------------------------------------------------------------------- 05/30/17 05:13:16 PwrCnt:229 ERR_ASSERT_CONTINUE CDP OnSecs:7628.410 PwrHrs:172 SwVer:6.50.1 Rpt:1 Temp:327.67C F:adb_appr_utl.c L:1374 MSG:CDP --------------------------------------------------------------------
  7. I've got an integrated intel card but i'm not using it My main card is an NVIDIA GTX 1080. I nevertheless checked the use of the main card in the windows settings Regarding your last post : Windows Defender policy couldn't be an issue here since I use Comodo Internet Security (and I did test the Trainer disabling this one)
  8. @RXP reviewing your 3 messages starting from https://www.avsim.com/forums/topic/544923-error-loadlibrary-failed-when-running-trainer/?page=3&tab=comments#comment-3929748 1/ you already know it's not working correctly standalone 2/ I also installed the full Garmin package (G500/600, TXi, GTNs) 3/ HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\ 0000 OpenGLDriverName = C:\WINDOWS\System32\DriverStore\FileRepository\ki125544.inf_amd64_ff9fa74ec6ebb5eb\ig9icd64.dll OpenGLDriverNameWow = C:\WINDOWS\System32\DriverStore\FileRepository\ki125544.inf_amd64_ff9fa74ec6ebb5eb\ig9icd32.dll 0001 OpenGLDriverName = C:\WINDOWS\System32\DriverStore\FileRepository\nvddi.inf_amd64_2341aac88431d6bf\nvoglv64.dll OpenGLDriverNameWow = C:\WINDOWS\System32\DriverStore\FileRepository\nvddi.inf_amd64_2341aac88431d6bf\nvoglv32.dll 4/ atig6pxx.dll is not present since I've got a NVIDIA card (GTX 1080, last driver 416.94)
  9. Salut Jean-Luc ! Since you mentioned that running from the sim could make some differences, I've downloaded the latest RXP version : 2.5.8 (with Garmin 6.50.1 configured through GTNSIMDATA & GTNSIMPATH) Still the same errors... But as usual, once all the popups are closed, it runs OK
  10. @Jean-Luc : I've just installed the 6.50.1 version : same issue And regarding my windows version : I'm supposed to be up to date even though it's not the latest build available (17134.345) In the Windows Update tab, I can read "You're up to date"...
  11. I've installed the 6.21 version and it works fine
  12. I more like a Linux guy but I'm using windows since....2.0 and always have deactivated UAC without having any trouble (since Vista) In any case, I've enabled UAC, reinstalled both the Trainer and RXP software : no difference standalone or from the sim... Couldn't it be related to 32b / 64b dll's ? Using the Dependency Walker I've noticed the garmin trainer dll's are 32b dll's running on a 64b windows system
  13. UAC is disabled on my system I've just enabled it, did a reboot : no change Should I reinstall the Trainer with UAC enabled ?
  14. The SafeDllSearchMode was not present Following windows documentation "Safe DLL search mode is enabled by default. To disable this feature, create the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\SafeDllSearchMode registry value and set it to 0." Thus I've created the key and tested with both values 0 and 1 after reboot : no change
  15. Sacré Bigard ! Une histoire de nichons c'est toujours plus marrant qu'une histoire de drivers Windows... Just to keep you informed, I've tried to reboot several times disabling most of the non microsoft services through msconfig, but I still get the LoadLibrary error messages 😡