Sign in to follow this  
Guest

3D Display (Anaglyph) - Am I doing it right?

Recommended Posts

To all you 3D display GURUs:Well, I got a good pair of glasses (cyan) and fired up the "stereo" section of the nVidia driver set. The included 3D demo looked FABULOUS! I set the stereo mode to toggle with the hotkey combo of CNLT+T, which was the default.I then started FS2K2 as I normally do in full screen mode. I selected the default flight at Meigs for the initial test. As soon as the flight parameters started to load the sim locked up.Not to be undaunted, I restarted FS2K2 in full screen with stereo mode inhibited. I then changed to run in a window and minimized the sim. Next I turned "on" the stereo and then maximized the sim window to full screen. The 3D seemed to work fine at that point, but it sure seems that something isn't right. Can't believe that you'd have to go through something like this every time you want to run in 3D.Thanks for any guidance & best regards.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,All you should need do is hit the hotkey as soon as your aircraft is loaded into the environment (eg: sitting on Meigs runway). Also remember that some of the hotkeys for the Stereo controls will conflict with the hotkeys that FS has setup by default - FS will always win in that case. So, you may need to reassign either the Stereo hotkeys or FS's hotkeys to fit them all in.Good luck, http://members.rogers.com/eelvish/elrondlogo.gifhttp://members.rogers.com/eelvish/flyurl.gif

Share this post


Link to post
Share on other sites

I had similar problems when I first started using the 3D.I normally ran in Windowed mode but when I enabled 3D and then went full screen I would get lock-ups.The way I found to get round the problem was to reduce the screen res in full screen mode until the 3D would work and then increased the res to what I wanted. Once this procedure was done *once* I can now open FS2k2 without a problem.I should add that I do start in windowed mode first, set up the flight, then switch to full screen and then switch on 3D; I have not tried starting in full screen with or without 3D on.As Elrond said make sure your 3D hot key is not used by FS.Best of luck.

Share this post


Link to post
Share on other sites

Thanks all for the response.It looks like I'm doing it right. When I started in the windowed scenario I had a screen res of 11 X 8 @ 32 bits and it worked OK. I guess that starting in full screen will not be an option. Once I got it working there didn't seem to be a hot key conflict and adjusting the stereo separation worked fine.I understand that some of the first-person shooters really look outstanding. The established games reference that comes with the stereo drivers show less than optimal performance with the older FS2000, so the same probably applies to FS2K2. Also, during the setup and test phase for the stereo I could not see the smaller square in front of the larger square, but but the sample demo worked well.73's, de WB9LSZ

Share this post


Link to post
Share on other sites

I guess, but don't know for sure, that first-person shooters are designed more with 3D in mind unlike FS2k2.There also seems to be a problem with add-on scenery. None of my add-on airport buildings show any 3D info, that is, if you look at the airport without the glasses on the add-on buildings do not have seperate red/blue images but the auto-gen buildings and runway do.

Share this post


Link to post
Share on other sites

After reading so much about anaglyph glasses, I can't help but wonder if I am the only person who hates the effect they produce. Maybe I have not set them up correctly, but when I tried them in FS2002 the sky looked like it was on fire and pretty much everything in the scene was a bright shade of red. If I close my left eye (blocking out the red tint) the scene doesn't look so bad, although of course you can't see the 3D effect with only one eye. Perhaps there is some way to cancel out or at least reduce the red effect produced by the left lens? -Derek D.

Share this post


Link to post
Share on other sites

I suspect it could be the colour of your glasses Derek, although I'm sure Elrond will put me right if I'm wrong ;) I got a pair of anaglyph glasses from a UK web site (as I live in the UK) which had red/cyan filters. These are the default colours in the Nvidia 3D set up.If your glasses are red/blue (a common combination) you need to set the right colour to blue in the Nvidia set up utility.Brain is too tired to work out which colour may be wrong and not filtering out the red :-lol , Elrond...HELP!

Share this post


Link to post
Share on other sites

No if you have the red/blue colour then don't change the default colours in the Nvidia 3D Driver. I have a pair of Red/Blue glasses and keep the standard colour combo which is red/cyan in the Nvidia driver, and this allows all the colours though, even green.If your change it to red/blue this will cut back on your colours, so I leave it where it is and it's perfect.If you try and have your resoultion too high for the 3D your computer will lock up because your framerates are cut by half.And means it's overtaxing your computer, so in this case you need to drop back your resoultion, and maybe the sliders to give your computer enough power to run the simulator.I also received today a pair of E3D Stereo-Spex Super Anaglyph glasses. Red/Cyan, and are slightly better than the red/blue. It maybe due to being a slightly higher quailty pair, but do allow for better 3D. I think it pays to have a spare pair, so now have a RED/BLUE pair, and RED/CYAN pair.So to recap don't change the default colours in the Nvidia 3D driver, as the standard colour comb red/cyan as shown works perfectly with the red/blue also, with the advantage you don't lose colour. I found changing to red/blue it reduced my colours and lost most of the natrual colour.So if you have lockups. It's due to having your resoultions to high, or slides up to high, as 3D is much more taxig on your computer than 2D so must reduce your settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this