Jump to content

Sign in to follow this  
Guest kiwi pilot

b1900c throttle back

Recommended Posts

Guest kiwi pilot

Was coming into land runway 28 eddn landed fine under a/p but when i disengaed a/p pulled throttles back nothing happened the plane kept going at full rpm ..........anyboddy experienced this yet.......robin

Share this post


Link to post

Nope. Did couple of landings with Beech, no such thing. Maybe check your throttle? Calibrate it? Registered FSUIPC - calibrate it inside FSUIPC...

Share this post


Link to post

Robin,same here mate, no issues with landing from AP then shutting the throttles down. Tried it with AP on and off, allthough I always hand land these babies.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $540.00 of $25,000.00 Donate Now
×
×
  • Create New...