Sign in to follow this  
teropa

GF4 Ti-4200 stutters

Recommended Posts

Hi!I just upgraded to a Gainward GF4 Ti-4200 64(and AXP 2000+ along with a SiS745 chipset mobo).Framerates are "out the roof" even though I haven't tweaked anything yet. :) There's a problem though: stutters. In dense areas, where FPS still stays high (25-30), I get these annoying stutters, like every 2 seconds the display pauses for a tiny moment and "jumps".What could be causing this ? Any help greatly appreciated...Specs: Gainward GF4 Ti-4200 64, ECS K7S6A mobo (SiS745), AXP 2000+ processor, 256MB Spectec PC2100 (266) DDR. Using the v28.32 Detonators.I'm running Win XP Pro, so could it be that the 256MB isn't enough, even though I have nothing running in the background?Thanks!Tero

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I get the same problem with a 64 meg GF4 Ti 4200 card by LeadTek...I dont think RAM is the problem considering I have 512, though I would recommend that if you can get good prices on RAM to go ahead and move up to 512. The more RAM, the better...Hope someone has some suggestions on the stutters.

Share this post


Link to post
Share on other sites

Well I guess the problem is RAM. Not the amount of ram but the speed of it. I have the same prob with my GF4600Ti. Framerates are no prob even with AA 4s + AF2. But I get these stutters and did not find any workaround so far. I also use Lennart's texture which seem to take a little more time to load. My best way to "fix" these is to disable gradual transition in the view options. If u do this the stutters are hardly noticable, as the picture will not jump anymore.By the way, the 30.30s will not solve the prob.Alex

Share this post


Link to post
Share on other sites

Alex,You mean the GF4 RAMs or the 266DDRs are too slow?Seriously?Tero

Share this post


Link to post
Share on other sites

I guess it is a system ram problem not a graphics card problem. Iam running a lot of add-ons in the background usually like FSMeteo, FDC, FSNav. I also have a two monitor setup with FSNav and usually the FMC or GPS or whatever the particular plane has is running on the 2nd monitor. Let's face it our machines are sipmly still too slow to get all the stuff together. By the time FS2004 is here we will have the computers to run FS2002 properly.Alex

Share this post


Link to post
Share on other sites

Same problem here. TI-4600 512Ram MSI with XP1800 (1024x768/32 and 2xAA). However, I did find out that when reducing the cockpit visuals quality of the virtual cockpit (don't remember the correct name - I'm at work right now ;-) the stutters are gone. Of course the visual quality of the gauges in VC are then greatly reduced. But you can overcome this problem when you rise the pixel_size in the panel.cfg of the aircraft to 1024,1024 of each panel. I guess my stutters/jerkyness come from a combination of VC-quality and AA-settings. I don't know. Right now I re-size each pixel_size in each panel to 1024 and leave the VC-quality slider in the low position. Works for me.Daniel

Share this post


Link to post
Share on other sites

That is an interesting suggestion. do you have the same VC panel quality after this? I am asking because I control 95% of the cockpit with the GoFlight Controls and hardly ever fly in the 2D cockpit.I can only change settings later today as I am at work now too :-).Alex

Share this post


Link to post
Share on other sites

Hi AlexHere's what I found out: Some panel.cfg under section (Vcockpit01/02/03 etc.) define the pixel_size at 256 or even less, resulting in a very poor visual quality, even with the general cockpit quality slider at high. Changing the pixel_size to 1024,1024 results in a very crisp visual quality of the gauges in VC, but the sim itself starts stuttering. When selecting low quality (slider left) of the cockpit quality the stutters stop and the quality of the gauges is still 'usable'. In some cases better than with the original panel.cfg AND high cockpit quality settings. I need to do some further research with pixel_size 512 and high quality settings. I only found this out last sunday and been simming ever since with a silky smooth sim. Before that I was constantly tweaking the bios settings, nvidia drivers etc. to no avail, nearly going nuts. (I even went as far as to reinstall WIN98 and all necessary updates after format:c). Of course I forgot to backup some passwords - even some payware addons got lost - stupid me).Try out the VC quality settings. Of course I don't need to remind you to backup the original panel.cfg first, don't I?Daniel

Share this post


Link to post
Share on other sites

Thx fr all that thorough explanation. I will try this evening with the Archer II.Thx,Alex

Share this post


Link to post
Share on other sites

>Hi! >>I just upgraded to a Gainward GF4 Ti-4200 64(and AXP 2000+ >along with a SiS745 chipset mobo). >>Framerates are "out the roof" even though I haven't tweaked >anything yet. :) There's a problem though: stutters. In >dense areas, where FPS still stays high (25-30), I get these >annoying stutters, like every 2 seconds the display pauses >for a tiny moment and "jumps". >>What could be causing this ? Any help greatly appreciated... >>Specs: Gainward GF4 Ti-4200 64, ECS K7S6A mobo (SiS745), AXP >2000+ processor, 256MB Spectec PC2100 (266) DDR. Using the >v28.32 Detonators. >>I'm running Win XP Pro, so could it be that the 256MB isn't >enough, even though I have nothing running in the >background? >>Thanks! >>TeroI will reply to you here as well Tero, SiS has a new AGP driver out for the 745 have you applied that yet? Did you completely remove the old drvers from your system before installing the new ones? Are you sure you don't ave any other programs like Anti-virus running in the backround?Are any other devices sharring an IRQ with it? there should be just one IRQ for the video card and it usualy is 11. Nvidia recommends as one of the last resorts (Gforce faq under "stutters")that you can shrink the AGP aperture size (should be at 128mb right now), you can try this if all else fails, but try it one step at a time, 64 then 32 but no smaller as then it will be disabled.For an XP system it is true that 256mb is on the low side for running FS2k2 but I dont think that is the cause of your constant stutters.

Share this post


Link to post
Share on other sites

Hi Paul,I also found out that the IRQ sharing in WinXP seems to be the problem. However a computer installed as ACPI will not allow for external(BIOS)IRQ setting. Moreover I have graeter problem. I reinstalled the computer as a standard computer and am now able to assign my own IRQs. But now here it comes:IRQ11 is shared with the onboard NEC-USB Controller and that is no PCI card. No way to change this, right?I would really appreciate any help on this.Rgds,Alex

Share this post


Link to post
Share on other sites

I think if you disable AGP fastwrites using a tweak utility, your stutters will go away. I had the same problem and that is how I got rid of it. You can still use AGP 4X, just stop the fastwrites and sidebanding.Robb

Share this post


Link to post
Share on other sites

Guys,I think I located the origin for my stutters: the RAM.The 256 chip I have simply is not enough. I found out that I have 4% physical memory left, when I use FS2002 with all maxed out at 1280*960*32. I have nothing else running in the background...Now I also noticed HDD led flashing quickly everytime there was a stutter (~ 2 sec in dense areas), so it was trying to use HDD swap file as memory.I'm getting another PC2100 256 DDR today after work, and will report later about the outcome with the extra mem.Cheers,Tero

Share this post


Link to post
Share on other sites

Well Tero,I have 512MB, and still the same prob as yourself.Alex

Share this post


Link to post
Share on other sites

Hmm.. XP is more of an ACPI OS and it needs to have compliant ACPI hardware. IRQ sharing isn't a problem as you can set the video card to have it's own IRQ and you'll get the stutters. XP is very problematic with SCSI hard drives as it seems that the XP drivers are poor, whereas running an optical SCSI media device is fine. AGP Aperature settings could be the problem as well as the AGP settings. But let's not forget dX8.1 on this installed on XP. Or a busmastering hogging device such as a sound card could be the culprit. There are too many solutions and fixes to go about this as the size of the textures used in FS can choke a vid card. I would do the following: (try one setting at time and go into FS or another game. I know this is going to take up a lot of time but in order for you to find the culprit, this is the only way I can think of)1. replace the video drivers that came with xP as they are problematic - there was a bug when it a released that hurt performance. Be sure to get the latest core-chipset drivers for your mobo and that your BIOS is up to date. 1b. disable all TSR programs like AV, task scheduler, etc.2. Goto Administration and disable services that you don't need. Your goal here is to give as much resources available. 3. Set AGP Aperature to 64MB and then turn off fast writes, sideband addressing and finally, drop down to aGP 2x. Bascially detune the system and try each setting one at a time. 4. If you have a sound card or busmastering peripherial using a PCI solt - not onboard sound, "walk the card". Try start moving the sound card closer/farther in relation to the AGP slot. I'd rather just take the sound card out or any PCI hardware and see how things are first. 5. IF all else fails and you still get stuttering, you might have to do some hardware editing =>wcpredit.jd

Share this post


Link to post
Share on other sites

Alex,Is your HDD led flashing at the same time you get the stutters?Tero

Share this post


Link to post
Share on other sites

Hi jd,>XP is more of an ACPI OS and it needs to have compliant ACPI >hardware. IRQ sharing isn't a problem as you can set the video card >to have it's own IRQ Where can I set the video card to have its own IRQ? Mine ahares its IRQ with the onboard NEC USB host controller.Thx,Alex

Share this post


Link to post
Share on other sites

Alex, It's really BIOS dependent. But be sure to tell the BIOS that the OS is not PNP so you can set it and hopefully XP will take note of it. The reason why I say that is because XP has it's own rules in controlling hardware resources. Nevertheless, my vidcard is sharing with my NIC. If you think you have bad memory.. search for "memtest" and install on a floppy and test your memory. When I had a bad chip go bad, in FS, the symptoms were CTDs, which occured when using highy polygon aircraft. Just don't don't remove the memory and assume it is just test it w/o physically moving it. One more thing, try turning off all screen savers, monitors going to suspend mode and be sure your Energy saving is set to proper settings in the BIOS. If it isn't, XP won't be happy. Remember, XP wants complete control of the hardware. jd

Share this post


Link to post
Share on other sites

Problem solved!! Problem solved !!!1. The shared IRQ was absolutely positively the problem.2. I obviously have two onboard USB controllers. But only one of them can disabled in the BIOS. I disabled it and was lucky. It was the IRQ sharer. I extended the other one with an external hub.3. Stutters are completely gone. The first time I can acually see how fast that GF4Ti4600 really is.4. This way I can even keep all ACPI functionality.5. I am a real happy camper .-).Cheers and thx fr all the help. Could not have done it without you guys.Alex

Share this post


Link to post
Share on other sites

Just by the way I also gained 500 3DMark2001 points finally bringing me over the 10000 mark. Forget all this ACPI IRQ sharing crap.Alex

Share this post


Link to post
Share on other sites

OK guys,My problem solved as well. The extra 256mb did the trick.Boy, is this GF4 something else !! NO stutters and getting at least 18-20 even in the densest areas with all maxed out ! ;) And what about the picture quality then ?!I'm a very happy camper too!Btw. Alex, what are your computer spects otherwise.I find that I got "only" ~ 9000 3DMarks with:AMD Athlon XP 2000+512MB DDR PC2100 (266)Gainward GF4 Ti-4200ECS K7S6A SiS745 chipset (corresponds VIA KT333)Running all as "stock" 133/133/33, FSB/MEM/PCI

Share this post


Link to post
Share on other sites

I would not worry too much about the 3DMark score, because it is heavily depending on your driver settings, and does not mean a lot for FS2002 anyway. My 10380 were reached with no AF and no AA. My rig:MSI KT7-266 Pro Ru-2 (Via KT266)Athlon XP2100+ (133 MHz, stock)512MB Apacer DDR Ram (all timings and other settings set for max Spd, stable)MSI GF4Ti4600 (no o/c so far), running on 30.30sThe MSI GF4 ram is a little o/ced by default (660Mhz). This could make a little difference. I do not think that the little difference in the processor would add much.However when you feel your score is too low before I o/c the card I would check on memory timings, burst length, 4-way overleave etc. of your Ram. That is where most if the time you can gain a little.Alex

Share this post


Link to post
Share on other sites

Ah, only now I c that you have a Ti4200, that should be the difference.By the way, what are your driver settings for the GF4?Alex

Share this post


Link to post
Share on other sites

Hello Alex,Yes, it's a Ti-4200.I haven't touched my driver settings AT ALL. I mean, I got the 29.42 detos and they're running on the default settings.Is there something in the driver settings that I can change to improve performance in FS2002 (and/or 3DMark) ?Tero

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this