Jump to content

Sign in to follow this  
zap737

Lefteris - Question re Windows 64 Bit etc

Recommended Posts

Hi Lefteris,In another thread you wrote:"......go Vista 64 bit, which, at least to me, felt like moving from a studio apartment to a luxurious six bedroom home (admittedly, I upgraded to 8GB RAM as well)."Can you tell me:1. What has been your experience with Windows Vista 64 bit in terms of performance with FSX and FS9 using the PMDG 747 and/or 737?1a. Do these programs actually use the full 8 GB of ram on a system with Windows Vista 64 bit? (I thought they could only use 4 GB).2. What did you have to do, if anything, to enable FSX and FS9 to use the maximum amount of Ram?3. What did you have to do, if anything, to enable Windows Vista 64 bit to allow FSX and FS9 to use the maximum amount of Ram?Thanks,Pete


Asus Z 370-A | Intel i7 8700 K @ 5 GHz  |  1080TI |  32 GB 3200 DDR4  |SM951 M.2 SSD |  Windows 10 x64  | TIR 5 | TM Warthog H.O.T.A.S  |  4K Monitor @ 30 Hz  |  Orbx Global | Orbx  Vector  |  Orbx OpenLC NA, EU  |  FreeMeshX  |  VRS Superbug

 

Share this post


Link to post

Hi Pete-answers below:1. Compared with XP SP2, Vista (even 64 bit) will lose about 10% fps with similar settings. This is due to several reasons, one of the most important so far being the video drivers which are done in a totally different fashion. This means that a 25fps simulation under XP might give you 22-23 fps under Vista.1a. No. 32-bit applications such as Flight Simulator X and Flight Simulator 2004 are not taking advantage of the full 8GB. They are, however, able to use all the memory they can see (3GB or so) which the operating system will grant them. Under XP or Vista 32, they will share 3GB with the rest of the applications (and system and video). That is significant. What follows from that is that other applications running concurrently on the PC (antivirus, Active Sky, Squawkbox / FSInn etc.) will each use their own full 3GB.2. FSX SP2 does that automatically. Previous versions require some tweaking (as described in Phil Taylor's blog - I don't remember off the top of my head). FS9 will use the same settings.3. Nothing - that's handled by the OS.Regards,


Lefteris Kalamaras - Founder

www.flightsimlabs.com

 

sig_fsldeveloper.jpg

Share this post


Link to post

Hi Lefteris,Thankyou for your clear and concise answers.Perhaps you can answer one more....I have had instant replay problems with the 747X in FSX with the acceleration pack installed.On an autoland or manual landing off an ILS the spoilers deploy perfectly and reverse thrust activates normally - as one would expect. The aircraft is brought to a stop and then instant replayed.The problem:When instant replay is played from a position on short finals, the aircraft is shown flying with the spoilers deployed and the thrust reversers deployed.I then tried stowing the spoilers and thrust reversers after landing and instant replay showed the aircraft flying normally however, after landing, the spoilers and thrust reversers did not deploy when in fact they had.I have also tried setting the parking brake after landing and then instant replay, but the problem persists.The sim seem to remember the state of the spoilers/thrust reversers after landing and doesnt change them for the instant replay.Some observations:Instant replay works perfectly for the PMDG 747-400 for FS9.Instant replay works perfectly for the Microsoft 737-800 in FSX.Also, the problem happens at any airport.I did go back to FSX SP1 and this indeed fixed the problem.I also installed FSX SP2 and this fixed the problem as well but I would like to have it working with the Acceleration pack.Thanks,PeteConditions for the problem:Windows XP Home SP2, FSX with Acceleration Pack, FS 9.1


Asus Z 370-A | Intel i7 8700 K @ 5 GHz  |  1080TI |  32 GB 3200 DDR4  |SM951 M.2 SSD |  Windows 10 x64  | TIR 5 | TM Warthog H.O.T.A.S  |  4K Monitor @ 30 Hz  |  Orbx Global | Orbx  Vector  |  Orbx OpenLC NA, EU  |  FreeMeshX  |  VRS Superbug

 

Share this post


Link to post

Pete-as much as I would like to profess myself expert for all-things-FSX, I am not ;-). This is one of those problems that a) I hadn't noticed before and :( I don't know the answer to.Perhaps a post in the general FSX forum would help?


Lefteris Kalamaras - Founder

www.flightsimlabs.com

 

sig_fsldeveloper.jpg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    2%
    $540.00 of $25,000.00 Donate Now
×
×
  • Create New...