Sign in to follow this  
Guest

Alternative Sound Cards

Recommended Posts

This SB Live! 5.1 is driving me crazy. The WindowsXP drivers for it stink. I get static and crackling sounds in FS2002 and other games. Planes with panels that have sound, the panel sounds don't work. If I disable hardware acceleration it all works fine.The card worked fine when I was running Windows ME. I've been going back and forth with Creative tech support, and I've tried everything they suggested and then some. I went to the point of removing all PCI devices and trying the SB in each slot. I've read other posts here and elsewhere of people having similar problems with the Live! and Audigy cards under XP.Anyway, my question is what are the alternatives to Sound Blaster. I looked at the Turtle Beach card, but it doesn't support true 5.1 surround. I just purchased a 5.1 speaker system before installing XP, but now that I have to disable hardware acceleration they are just paperweights.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Am not a guru, but have been using the Turtle Beach Santa Cruz now for almost a couple of years and have been very please with it overall. It certainly seems to have a 5.1 option on my control panel. Hope that helpsSYSTEM: MSI 694 D Pro2 Twin PIII@1G 1024 RAM VisionTek GeForce3 TI500 64MDDR Turtle Bay Santa Cruz Sound Saitek X-36 USB Windows XP ProfessionalBest Regards,Ed Green, KCLTegreen1@carolina.rr.com

Share this post


Link to post
Share on other sites

I have a Sound Blaster Platinum 5.1 Live. I think i might have heard this myself, try turning off EAX effects, and see if it makes any difference.I normally have my sound on Concert Hall effect and i have heard some abnormal sounds from within FS, due to the effect of the EAX. Turning off the EAX stops it.Hope that helpsWill

Share this post


Link to post
Share on other sites

The Hercules card is supposed to be a great card. Personally, I have the Creative Live! 5.1 X-gamer card and it works flawlessly under WinXP Professional. Hope you figure it out! Oh yeah, have you tried cleaning up the speaker contacts, or trying a new set of speakers?? I had a problem with my Altec Lansing ACS-56's and they crackeled bad. They sent me new ones.

Share this post


Link to post
Share on other sites

I have the Soundblaster Live 5.1 card running under Windows XP Pro and you're right, the Windows drivers for the card are terrible. I also had the crackling that you describe. However, if you downlaod and install the Creative XP drivers for the card from http://www.americas.creative.com/support/f...ntric=168&OS=13you should have no further problems. At least I didn't.Doug

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this