Sign in to follow this  
Guest WorkingStiff

FS2K2 and PC System Date and Time

Recommended Posts

I know this has probably been answered before but.....When I start FS2K2 it appears that FS2K2 is one day earlier than the actual or PC system date. Is there a fix for this? I also reside in the eastern time zone, but when I start at the default Meigs Field, the clock still shows the eastern daylight time when it should roll back one hour. Is there a fix for this also?Thanks for your help!Airbus

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What operating system are you using?You need to check the time and date on your system clock, also select the correct time zone and the "Automatically adjust clock for Daylight Savings changes" option.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this