Sign in to follow this  
Guest Stratus_Fractus

Time Zone problem

Recommended Posts

Hi all,It seems that the timezones for me in FS haven't been adjusted after DST ended. Time in EST is still -4hrs from UTC. What's going on? Date is properly set.Thanks :-)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well, neither worked. Would someone mind sending me their BGLs that work in Standard Time?Thanks,

Share this post


Link to post
Share on other sites

Did you take note that the tz19h has two sets of BGL's - one for Standard Time and one for Daylight Time? The default is Daylight Time, so you need to run the STANDARD.BAT file included in tz19h.zip.

Share this post


Link to post
Share on other sites

The good news...you're not crazy :^) The bad news: it's a legitimate bug - but there's a workaround!Seems that if your default situation (or any saved STN file) was previously saved during Daylight Savings, FS defaults to Daylight Savings mode (even if you start with the Create Flight screen - it pulls the defaults from your default situation). FS remains ignorant of changes you might otherwise make to the date. It's kind of a pain in the butt to force it out of Daylight Savings mode too, but you can.So here's how you can fix it (this took some experimentation). Follow this procedure exactly:First...make sure you're on System Time and not Flight Time (see your Settings | General... tab)Load your default situation normally (make sure you load a situation that has an aircraft with a chronometer in it - one in which you can change the time directly from within the panel. Most default aircraft will suffice here).Open the Time & Season's dialog and verify you are on Daylight Savings time (i.e. EDT = UTC - 4)Next, change the date forward to January 1, 2003.Using the chronometer on the panel, adjust the hour forward or backwards 1 hour. This should cause FS to refresh its internal clock and pick up Daylight Savings.Open the Time & Season's dialog and verify you are on Standard Time (i.e. EDT = UTC - 5).Now, return to the sim AND SAVE the situation (you can save over the old flight if you want). Check the box "Make Default Flight" and choose OK.Press ESC and choose End FlightYou should now be back at the Create Flight screen. Open the Current Date and Time window and verify that you are still on Standard Time. Cancel out of this when you are satisfied all is good and well.Close FSWhen you restart, you should be back in Standard Time from here on out.Good Luck!JPS. The tz19h.zip file is still a good idea ;-) Ignore what I said about running the STANDARD.BAT file - it's for Australia and New Zealand. I think Daylight Savings runs opposite of what it runs here in the Northern Hemisphere.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this