Sign in to follow this  
fbobum

How to stop default King Air ROLLING UNDER OWN STEAM!!

Recommended Posts

How do I stop the default Beech King Air from rolling away under its own steam when I release the breaks? The throttle on my joystick is at zero but the sounds from the engines seems way too high. Do I need to tweak something using FSEdit and if so can anyone recommed settings.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The conditioner levers default to High Idle on the default King Air. You need to move them into Low Idle.Cheers,J

Share this post


Link to post
Share on other sites

Nope, you can keep the props in High RPM. If you calibrate your throttle in FSUIPC, setting it up properly (read the readme), you will have no trouble. Will provide an idle setting around ~10% torque. I regularly taxi with the throttle set for ~15 on torque (use about ~20% to get it moving), never have a problem with fast taxi. Prop in HIGH, condition levers in low idle. Works every time.Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this