Sign in to follow this  
Guest

Can't get the Thrust Reversers to work!

Recommended Posts

I hope I'm not missing this simple task! I shoot the approaches just fine but if I come in a little hot or into a shorter runway, I can't get the reversers to work (on any airplanes). If I'm using the throttle quadrant, the handles seem to want to go into reverser position but they just bounce around a little and don't ever go into reverser mode. F2 is what I'm using. Thrustmaster with a slide throttle, maybe that's the problem? Anyone with any comments or fixes would be greatly appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hy tinmanhave yo turned off the autothrust (autopilot speedcontrol)?or try to engage the reversers with F2.Greets McDaniel

Share this post


Link to post
Share on other sites

Its thrustmaster throttle noise. Disable joystick and you will be able to go into reverse with F2. Best way to solve it is to download FSUIPC and set throttle range therein. Great utility, very easy to set up.Good luck

Share this post


Link to post
Share on other sites

Another way to solve the problem is to buy a new joystick. Had the same issue and when I upgraded to a USB type - solved all my probelms

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this