Jump to content

Sign in to follow this  
vollmey

I have to ask a basic Simconnect question

Recommended Posts

Call me an idiot. The Client machine is what I am having a problem with. I run the SimConnect.msi it seems to install and I assuming from the documentation that it should give me a config file in My Documents folder. I don't have one, I've tried copying the sapmple config over and testing it with the Ai Traffic program with now luck.Where am I going wrong here?? Or, where is it installing the .cfg file.

Share this post


Link to post
Share on other sites

I'll keep working with it, I'm word for word with the documentation though. It's driving me nuts now.

Share this post


Link to post
Share on other sites
Guest Carl Hackman

Hi Dave I told you it was easy and I'll point you in the right direction here buddy.Ok, what you need are 2 files from the following directory.Microsoft Flight Simulator X SDKSDKCore Utilities KitSimConnectSDKconfigIn there you need the simconnect.cfg and simconnect.xmlThe simconnect.xml goes into the fsx application data on your fsx server and the simconnect.cfg goes into your my documents folder on the client.Main things you need to configure are:simconnect.xmlFalseIPv4local

SERVER NAME OR IP ADDRESS
645004096Falsesimconnect.cfg[simConnect]Protocol=IPv4Address=SERVER NAME OR IP ADDRESSPort=500MaxReceiveSize=4096DisableNagle=0You can place the simconnect.ini in your my documents Flight Simulator X Files folder on the server as a sanity check to see if ASX is communicating with the FSX server. Ensure that - console=1 in the ini file for the cmd dialog to come up with details of data passed between ASX and FSX.Set console=0 or delete simconnect.ini to stop the dialog popping up anymore.Also you need to ensure that port 500 is open in your server and client firewallsHope this helpsRegardsCarl Hackmanhttp://www.hifisim.comhttp://www.hifisim.com/banners/hifi-dev-sigbanner.jpg

Share this post


Link to post
Share on other sites

I got it word for word Carl. Just to verify that the Simconnect.cfg does go in the "My Documents" folder on the client machine.When I load up ASX I get a message on the client machine that SimConnect was not able to be loaded.

Share this post


Link to post
Share on other sites

Yes, a couple times now to verify.Edit, On two different machines set up the exact same way per the documentation.

Share this post


Link to post
Share on other sites

10.0.61242.0Edit: I got the SimConnect Diagnostic running now and it seems to be running fine, the client won't connect though.

Share this post


Link to post
Share on other sites
Guest Carl Hackman

ok the version is correct. Now we need to figure out why ASX is not talking to FSXAre the following folders shared on the server?C:Program FilesMicrosoft GamesFlight Simulator X (or your FSX installation folder)C:Documents and Settings[username]Application DataMicrosoftFSX (or if on Vista, C:Users[username]AppDataRoamingMicrosoftFSX)C:Documents and Settings[username]My DocumentsFlight Simulator X Files (or if on Vista, C:Users[username]DocumentsFlight Simulator X Files)What are the paths in the registry for ASX?HKEY_CURRENT_USERSoftwareHiFiXEngineLastPlanPath: Set this to your desired flight plan folder, which should be shared on the FSX computer as fsxcomputernameFlight Simulator X Files HKEY_CURRENT_USERSoftwareHiFiXEngineFSPath: Set this to your desired Flight Simulator X installation path, which should be shared on the FSX computer as fsxcomputernameFlight Simulator X HKEY_CURRENT_USERSoftwareHiFiXEngineAppDataPath: Set this to your desired FSX AppData Path, which should be shared on the FSX computer as fsxcomputernameFSX Have you open port 500 on both client and server (check windows firewall as well if you are running a 3rd party one)Can you ping the server with the setting you put in the cfg and xml filesstart -> run "ping servername or ip address"have you set the server name/ip address in the simconnect.cfg on the client - not the client name/ip addressRegardsCarl Hackmanhttp://www.hifisim.comhttp://www.hifisim.com/banners/hifi-dev-sigbanner.jpg

Share this post


Link to post
Share on other sites

Carl,All firewalls are confirmed off. I can ping the server by IP and name and get reply's back. All folders are set up right, textures have been loaded to the server by X engine. It seems when I start ASX it won't load the Simconnect client part of it, if that makes sense. It does the exact same thing of different machines.I'm baffled now.

Share this post


Link to post
Share on other sites
Guest triangle

Just bought ASX this morning but just wanted to say I am super-impressed with your support on this forum.It's awesome to spend big dollars on software and have this level of support ... I'm going to have a go at using WideFS later today having read all this useful advice :-)Andrew

Share this post


Link to post
Share on other sites

Carl,Got it, both machines I had gone through the documentation and set up Simconnect first, then installed ASX and X engine. I uninstalled the Simconnect.msi on the client machine and re-installed and it worked, same procedure on the other. Strange, but it works and it is more than what I expected.Great job guys, and thanks Carl for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...