Jump to content

Sign in to follow this  
Guest GW Norris

Need help with Xgraphics Error and XEngine Log

Recommended Posts

Guest GW Norris

Hello supportFirst off let me post the contents of my latest XEngine.log file and you can see if the file looks OK. One problem may be the 10th line from the top.There is no file in the described location, only the various sub folders. I don't know if there should be a file 'Downloadstations.dat'in that folder. I hadn't loaded a flight plan yet, even if that makes a difference.Here is the file:22:41:02: Logging Initialized22:41:02: XEngine v1.0.0.325 Copyright

Share this post


Link to post
Share on other sites
Guest GW Norris

HI JimThanks for the link to the file I needed. It worked and that line in the log file is OK now.However I was geeting an exception 14 in the Xengine log and I searched the forum and found a reply to the same problem from Damien and he said it was because ASX was trying to input WX for a station that didn't exist in the wxstationlist.bin file in the AppDataFSX folder so I copied the one from the Weatherbackup folder and pasted it into the Weather folder for FSX and also in the AppDataFSX folder and now I no longer get the, Exception received 14, I don't get any exceptions now and it appears ASX is running fine.However I have a question about XGraphics. I will post the contents of the error.log, and the theme.log I am using the default theme and maybe you can tell me if these files look normalerror_log2:05:49 PM Sunday, July 15, 2007 - Object reference not set to an instance of an object.2:05:56 PM Sunday, July 15, 2007 - Cumulus01.bmp Creation Failed: texture.bmp2:05:56 PM Sunday, July 15, 2007 - Could not find file 'C:Program FilesHiFiXGraphicsDataAirportsairport_clutter136b2su1.bmp'.Please view the error log from the options screen2:05:57 PM Sunday, July 15, 2007 - Could not find file 'C:Program FilesHiFiXGraphicsDataAirportsairport_clutter136b2su1.bmp'.Please view the error log from the options screenInstalltheme.log2:05:56 PM Sunday, July 15, 2007 - Installing Texture Theme Custom2:05:56 PM Sunday, July 15, 2007 - Creating Cumulus01.bmp2:05:56 PM Sunday, July 15, 2007 - Cumulus01.bmp Creation Failed: texture.bmp2:05:56 PM Sunday, July 15, 2007 - Install Failed at C:Program FilesHiFiXGraphicsDataAirportsairport_clutter136b2su1.bmpXgraphics.log2:05:49 PM Sunday, July 15, 2007 - Loading Application Data Path2:05:49 PM Sunday, July 15, 2007 - Application Data Path = C:Documents and SettingsGary W. NorrisApplication DataHiFiXGraphics2:05:49 PM Sunday, July 15, 2007 - Loading Application Executable Path2:05:49 PM Sunday, July 15, 2007 - Application Executable Path = C:Program FilesHiFiXGraphics2:05:49 PM Sunday, July 15, 2007 - launched from ASX2:05:49 PM Sunday, July 15, 2007 - Verifying X Graphics License2:05:49 PM Sunday, July 15, 2007 - Populating FSX Launch After Theme Install Value2:05:49 PM Sunday, July 15, 2007 - Populating Close On FSX Launch Value2:05:49 PM Sunday, July 15, 2007 - Populating Cloud Output Value2:05:49 PM Sunday, July 15, 2007 - Populating Cloud Size Value2:05:49 PM Sunday, July 15, 2007 - Populating FSX Path Value2:05:49 PM Sunday, July 15, 2007 - Populating FSX Application Data Path Value2:05:49 PM Sunday, July 15, 2007 - Populating Current Installed Theme Value2:05:49 PM Sunday, July 15, 2007 - Populating Ignore Save Prompt Value2:05:49 PM Sunday, July 15, 2007 - Populating Slide Show Transistion Value2:05:49 PM Sunday, July 15, 2007 - Populating Slide Show Interval Value2:05:49 PM Sunday, July 15, 2007 - FSX Path Value = Gary1Microsoft Flight Simulator XThanks for any words of wisdom, Oh yes and by the way I am running on a network and in the sim I do get the ASX depiction message complete in the sim and no errors in the simconnect diagnostics window, so I believe everything with ASX and simconnect are working as advertised, It's just those errors I get when Xgraphics tries to load the textures based on my flight plan route.

Share this post


Link to post
Share on other sites
Guest GW Norris

Hi CarlAttached is the contents of the files you requestedRandomize.log is2:05:49 PM Sunday, July 15, 2007 - Airport Variantsconfig.xml is<?xml version="1.0" encoding="utf-8"?>The first Add key line seemed suspicious to me since it says CurrInstalledSet. Curr is not a complete word so I changed it to CurrentInstalledSet and then I got a .net2.0 error stating the same thing that "the instance of an object not set to an object" the same verbage as in the one log file, I think it's the error.logAny way Hope we can figure it out. The files it says it can't find are in the location described.Thanks

Share this post


Link to post
Share on other sites
Guest GW Norris

HI CarlWhile waiting for your response I was comparing the config.xml file with the XGraphics.log file and this is what I noticed, may not mean anything.1. the word Path is missing from the last add key line2. the word Current not spelled correctly in the first add key line.3. the word Prompt missing from the second add key line.That all may mean nothing but in the Xgraphics log the words are there. Also just curious but in the current installed set line of the config.xml should it just reference "X Graphics Default" or should it have the path to the folder? maybe that's why error.log says it can't find the files.ThanksGary

Share this post


Link to post
Share on other sites
Guest Carl Hackman

Hi GaryCurrInstalledSet is correct as it is a variable used by X Graphics. The application specifically looks for that value, also X Graphics Default is correct as it is the currently installed theme name that goes there.Have you previously installed a set using the X Graphics interface prior to using ASX to install a Wx Influenced set?Can you change the config.xml to read CurrInstalledSet as it was before then use the X Graphics interface to install a theme. Once that is done try and install a Wx Influenced set via ASX as before.ThanksCarl Hackmanhttp://www.hifisim.comhttp://www.hifisim.com/banners/hifi-dev-sigbanner.jpg

Share this post


Link to post
Share on other sites
Guest GW Norris

Carl,I know I installed the textures originally, and it said X Graphics Default in the selection box at the top right portion of the page. I was on the main page that shows the 4 tabs for the different texture catagories. and the dialog box came up saying installing textures. I don't know what happened but I did as you suggested and opened X Graphics, then went to the Options Screen and in the drop down box at the top right of the screen I selected X Graphics Default and pressed the install theme button. The dialog box came up and showed the progress of the install procedure. when it finished, I minimized X Graphics to the Task Bar and openend ASX, loaded my flight plan and it asked me if I wanted to install textures to match my route conditions, I clicked yes, and lo and behold "no errors". did my flight and the weather was depicted correctly and the textures looked great. Experienced some pretty erratic upper wind shifts, but I see there is a sticky at the top of the forum for that problem.I checked all the logs after my flight and they look great, no errors and everything looks like it's functioning correctly.Just out of curiosity, does it matter if XGraphics is open or not after you install the theme you want, when you open ASX and process your weather. Because originally I closed XGraphics after the theme install, then started ASX. The way I understood the Documentation was that XGraphics didn't have to be running to install WxInfluenced textures.I appreciate the Help Jim and yourself have given me. Thanks again

Share this post


Link to post
Share on other sites
Guest GW Norris

Hi CarlWell, ASX does not launch Xgraphics when I choose OK to install WX Influenced textures. I tried it today and got the same errors as before.So I closed ASX, Started Xgraphics and just left it running minimized on the task bar and then started ASX and clicked ok to load WX Influenced textures and all was fine, no errors and weather in FSX was as it should be according to the metar for my location.It seems that ASX is not launching XGraphics automatically like you said it should. I believe that is why I was having the problem originally, because as I stated in my reply above, I knew I had previously installed the XGraphics Default textures. It was because ASX is not seeing XGraphics unless it is running, or else the command used to start it automatically is not there. Both programs are on the same PCThanks in advance for any help offered

Share this post


Link to post
Share on other sites
Guest Carl Hackman

Hi ASX doesn't launch the full X Graphics application it just launches it in Wx Influenced mode. X Graphics then retrieves the weather data from ASX and makes a selection of textures based on those values, it then creates a custom set which it installs into FSX. The set is then saved as a custom theme which you can see when you next open X Graphics.Can you check that you have a file called WxVariants.xml in your application data folder please.I am looking into this for you at the moment.ThanksCarl Hackmanhttp://www.hifisim.comhttp://www.hifisim.com/banners/hifi-dev-sigbanner.jpg

Share this post


Link to post
Share on other sites
Guest GW Norris

CarlYes there is a WxVariants.xml file in Application DataHiFiXGraphics folder. It is 188KB and the last modified date is 5/22/07.Does XGraphics build a custom set of wxinfluenced textures based on the current installed XGraphics Default theme ? or is it looking for a Custom theme? There is no custom theme folder in any of the Set folders. I tried to select Custom from the drop down list of themes and got errors for all the different categories. I suppose thats because I haven't made any custom themes. Am I correct in assuming that's why I got the errors. The contents of the InstallThemeLog is the same as posted above after I tried to install wxinfluenced textures from ASX yesterday and got the error again ( with XGraphics closed ). The installthemelog is always the same if XGraphics is closed when clicking OK to install wxinfluenced textures from ASX.Thanks for any help.

Share this post


Link to post
Share on other sites
Guest GW Norris

CarlYes there is a App DataHiFiXGraphicsSetsCustom folder and it has the data.xml file in it and it is 20.4 KB in size and the last modification date is 7/20/07 at 7:34 pm.Gary

Share this post


Link to post
Share on other sites
Guest GW Norris

CarlHere are the contents of the WXInfluencedlog that was last modified at the same time as the data.xml file in the SetsCustom folder.wondering why there is only entries for runway12. even though the data.xml file has alot of different info in it that sets the various custom texture, locations , names etc.7:33:58 PM Friday, July 20, 2007 - Wx Influenced Vals For runway127:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Bright-Hued7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 37:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Could Be Concrete7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 67:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Hardcore Blacktop7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 87:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Needs Repair7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 77:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Old N Dirty7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 87:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: Traditional7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:58 PM Friday, July 20, 2007 - Visibility Val: 57:33:58 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:58 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:58 PM Friday, July 20, 2007 - Rain Intensity Val: 47:33:58 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:58 PM Friday, July 20, 2007 - --------------------------------------------------------7:33:58 PM Friday, July 20, 2007 - Variant Name: X Graphics Default7:33:58 PM Friday, July 20, 2007 - Cloud Val: 57:33:59 PM Friday, July 20, 2007 - Visibility Val: 57:33:59 PM Friday, July 20, 2007 - Surface Wind Val: 57:33:59 PM Friday, July 20, 2007 - Snow Intensity Val: 57:33:59 PM Friday, July 20, 2007 - Rain Intensity Val: 77:33:59 PM Friday, July 20, 2007 - Aloft Wind Val: 57:33:59 PM Friday, July 20, 2007 - --------------------------------------------------------don't know if that means anything or not.Gary

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...