Sign in to follow this  
Guest kiwi pilot

Re install sp2

Recommended Posts

Jim i have problem installed sp2 got the following error report exception has occured Index was outside the bounds of the array. I uninstalled active sky reinstalled then installed sp1 activated active sky program worked fine.Theni installed sp2 as soon as i imported flight plan the above error ocurred.Can u helps please................Regards robin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Please share the flightplan file that causes this error so we can investigate through the debugger.Thanks!Best,

Share this post


Link to post
Share on other sites

Have attached files as requested .I did a manual flight plan worked ok.Started a new flight plan with in fsx .Closed fsx opened activesky tried to import same error ocurred.I have also noticed in the fsx files that the flight plan files are coming up as a plug in for instantVFR Auckland int to palmerston northAbode photoshop album start This seams strange what would be causing this may i will have to uninstall Abode and reinstall what do u think...........Regards robin

Share this post


Link to post
Share on other sites

I have now uninstalled abode correct file type is coming up in fsx files have installed a new flight plan still the same problem i will know uninstall asx and try again will let u know result.......Regards robin

Share this post


Link to post
Share on other sites

oK JIM OF HAVE UNINSTALLED FOR THE THIRD TIME eVERY THING WORKS FINE UP TO SP1 INSTALL EVEN THE IMPORTED FLIGHT PLANS WORK OK.aS SOON AS I INSTALL SP2 THE ERROR OCURRS.............REGARDS ROBIN

Share this post


Link to post
Share on other sites

Here is a copy of the error report..............regards robin may helpSee the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.************** Exception Text **************System.IndexOutOfRangeException: Index was outside the bounds of the array. at User_FlightPlan.Main_UI.btn_Process_Click(Object sender, EventArgs e) at System.Windows.Forms.Control.OnClick(EventArgs e) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)************** Loaded Assemblies **************mscorlib Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll----------------------------------------XEngine Assembly Version: 1.0.0.329 Win32 Version: 1.0.0.329 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/XEngine.exe----------------------------------------Microsoft.VisualBasic Assembly Version: 8.0.0.0 Win32 Version: 8.0.50727.42 (RTM.050727-4200) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll----------------------------------------System Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll----------------------------------------System.Windows.Forms Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll----------------------------------------System.Drawing Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll----------------------------------------System.Runtime.Remoting Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll----------------------------------------System.Configuration Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll----------------------------------------System.Xml Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll----------------------------------------XEngine_Module_Interface Assembly Version: 1.1.1.824 Win32 Version: 1.1.1.824 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/XEngine_Module_Interface.DLL----------------------------------------XEngine_UI Assembly Version: 1.0.0.238 Win32 Version: 1.0.0.238 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/XEngine_UI.DLL----------------------------------------Utility Assembly Version: 1.0.0.6 Win32 Version: 1.0.0.6 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/Utility.DLL----------------------------------------WorldData Assembly Version: 1.0.0.4 Win32 Version: 1.0.0.4 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/WorldData.DLL----------------------------------------FSInterface Assembly Version: 1.0.0.8 Win32 Version: 1.0.0.8 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/FSInterface.DLL----------------------------------------AvMath Assembly Version: 1.0.0.2 Win32 Version: 1.0.0.2 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/AvMath.DLL----------------------------------------Microsoft.FlightSimulator.SimConnect Assembly Version: 10.0.61242.0 Win32 Version: 10.0.61355.0 (fsx-sp1.20070510-2038) CodeBase: file:///C:/WINDOWS/assembly/GAC_32/Microsoft.FlightSimulator.SimConnect/10.0.61242.0__31bf3856ad364e35/Microsoft.FlightSimulator.SimConnect.dll----------------------------------------ASX Assembly Version: 1.0.0.1106 Win32 Version: 1.0.0.1106 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/Modules/ASX.DLL----------------------------------------HiFiSimControls Assembly Version: 1.1.0.1 Win32 Version: 1.1.0.1 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/HiFiSimControls.DLL----------------------------------------User_FlightPlan Assembly Version: 1.0.0.7 Win32 Version: 1.0.0.7 CodeBase: file:///C:/Program%20Files/HiFi/XEngine/User_FlightPlan.DLL----------------------------------------msvcm80 Assembly Version: 8.0.50727.762 Win32 Version: 8.00.50727.762 CodeBase: file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_6b128700/msvcm80.dll----------------------------------------System.Data Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.832 (QFE.050727-8300) CodeBase: file:///C:/WINDOWS/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll----------------------------------------************** JIT Debugging **************To enable just-in-time (JIT) debugging, the .config file for thisapplication or computer (machine.config) must have thejitDebugging value set in the system.windows.forms section.The application must also be compiled with debuggingenabled.For example:When JIT debugging is enabled, any unhandled exceptionwill be sent to the JIT debugger registered on the computerrather than be handled by this dialog box.

Share this post


Link to post
Share on other sites

jim reinstalled .net 2 no change in the mean time i can imput flight plan manually untill this problem is sorted.............Robin

Share this post


Link to post
Share on other sites

Hi Robin,I believe I have identified this issue, caused only when using an IMPORTED flight plan that has NO intermediate waypoints (only departure and destination) and then an alternate is manually specified.Email me at damianc AT hifisim.com if you'd like to try the fix.Best,

Share this post


Link to post
Share on other sites

Damian thru fsx input flight plan eddh to eddm there was no waypoints showing in flght plan That is not correct.Is my flight sim corrupted...........robin

Share this post


Link to post
Share on other sites

solved the problem helps to select routing every thing works fine now interesting though that if there is no waypoints that particular error crops up..............Regards robin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this