Sign in to follow this  
trisager

Networked simconnect problem

Recommended Posts

Hi,I have installed and run ASX on the computer where FSX is installed without any problems. FSX and FSX SDK are updated to SP2.I am now trying to install ASX in a networked configuration. I've followed your instructions in the documentation and tested the connection successfully using AI Traffic.exe. I am getting multiple "AI object added" and "AI object removed" messages so communication seems to be happening.But whenever I try to start ASX on the client, I get the "Simconnect SP1 managed version was not found to be correctly installed ..." message. I have done several uninstalls / reinstalls of the simconnect client, but the problem persists. Unloading anti-virus software (AVG free edition) and disabling the Windows firewall does not have any effect..NET 2.0 may not have been installed on the client computer initially, so I tried uninstalling the Simconnect client, installing .NET 2.0 SP1 and reinstalling Simconnect. This did not solve the problem.Any suggestions what I should try next? I did not uninstall/reinstall FSX SP1 and SP2 on the server side since ASX works fine in a local install.Thanks,Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Tom,Sorry for the problem. I would try these things:Once you have the shares and SimConnect configuration complete, you can configure ASX to properly work in networked configuration.ASX needs to know the location of the main Flight Simulator X installation path as well as the FSX Appdata path. In addition, you may want to load FSX flight plans on the FSX computer into ASX on the client. Since your shares are already configured you simply need to point ASX to these locations. To do this, simply run ASX. ASX will identify that FSX is not installed on the client machine and automatically ask for and save the correct network share locations.If you need to manually specify these locations, you can edit the registry key values (on the client machine) as follows:HKEY_CURRENT_USERSoftwareHiFiXEngineLastPlanPath: Set this to your desired flight plan folder, which should be shared on the FSX computer as fsxcomputernameFlight Simulator X Files HKEY_CURRENT_USERSoftwareHiFiXEngineFSPath: Set this to your desired Flight Simulator X installation path, which should be shared on the FSX computer as fsxcomputernameFlight Simulator X HKEY_CURRENT_USERSoftwareHiFiXEngineAppDataPath: Set this to your desired FSX AppData Path, which should be shared on the FSX computer as fsxcomputernameFSXPlease let us know.Thanks,Jimhttp://www.hifisim.com/banners/hifi-community-sigbanner.jpghttp://www.hifisim.com/

Share this post


Link to post
Share on other sites

Hi again,The FSPath and AppDataPath entries were in the registry and correct. I've added the LastPlanPath key (which did not exist), but unfortunately this didn't solve the problem.Tom

Share this post


Link to post
Share on other sites

Hi Tom,had the same problem this week : searched for it for 2 days :=)what I did was on the client machine :uninstall all simconnect clients (add/remove programs)1)install the SDK form the DVD 1 FSX de luxe SDK folderRUN Simconnect.msi (double click)2)install SDK SP1ARUN Simconnect.msi (double click)I found it is needed to RUN the Simconnect.msi file after each SDK install, without that for me it was also a NO GO.Now I have in the add/remove programs :Microsoft Flightsimulator SimConnect Client v10.0.61242.0Microsoft Flightsimulator SimConnect Client v10.0.61259.0Microsoft Flight Simulator X SDK SP1AI did't dare to install the FSX SDK SP2 update on the client, but it is installed on the server (FSX machine), because all worked well after installing and running the SP1A.Hope this helpspatrickhttp://www.hifisim.com/banners/hifi-beta-sigbanner.jpgPatrick/EBBR

Share this post


Link to post
Share on other sites

Thanks, Patrick - that did it.I forgot to run the Simconnect.msi after the first install, but after installing SDK SP1A and installing the client everything is fine anyway.Like you I'll leave well enough alone at SP1A :)Tom

Share this post


Link to post
Share on other sites

LOL about running the Simconnect.msi everytime. That shows how BETA all the M$ stuff seems to be. Thank you anyway. I

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this