Sign in to follow this  
Guest Don Hoare

PSS757 Comm and Nav problem.

Recommended Posts

Hi All,I have installed V 1.3 and have flown a few flights now and really like it. One problem which has occurred is after about 1.5 hrs flying I cannot switch Comm or Nav frequencies. This is very strange. Short flights are OK. I can click on any knob but the digits do not respond.RegardsDon

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi DonThe two most common reasons for this are as follows, so do these first then see if you have a more complex problem to resolve.1. Start with the defaulty Cessna with engines running and ensure that the Avionics switch is on, then switch to the 7572. Flat battery syndrom. If you have a registered version of FSUIPC then there is a box to tick or set to solve the flat battery syndrom.If you are doing both of these then the problem may be a little more complex than I can help with, but sure someone will help on here, but knowing the above is being done will help whoever can help you further.also just to say that after upgrading I also had the same problem as you and after re-starting fs9 and completing number 1 it solved my problem.best regardsJohn Calleja

Share this post


Link to post
Share on other sites

Thanks JC 150. I will try later today and leave a note. Good advice.Don

Share this post


Link to post
Share on other sites

JC 150, your advice worked very well. I don't know exactly which one worked but I now have full Comm and Nav on a long leg.ThanksDon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this