Sign in to follow this  
Guest GamePlayer

Throttling down not happening immediately

Recommended Posts

I have the Aerosim Vol. 2 and the L1011 and DC10 don't throttle down immediately after I cut back on the throttle after turning off autopilot. It takes around 2 minutes for the engines to respond to the throttle in this situation. Is there something I have to do to make the engine power respond immediately to the throttle after turning off the autopilot?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Interesting - I had this experience recently using the 747SP. After cruising for some time at 35000 feet on autopilot, I commenced descent, and decided to disengage the autothrottle and throttle back (using CH Yoke throttle control) ...nothing happened, and the engines continued to operate at about 90% power!After about 5 minutes of switching off/on autopilot & autothrottle, I was about to give up and hit CTRL-C when the engines suddenly dropped to idle. Everything retuned to normal and I was able to manually land.Very weird, and it has only happened once.So, sorry I cannot help, but at least you are not totally alone :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this