Archived

This topic is now archived and is closed to further replies.

Guest Radioman

Active Sky X simconnect problem

Recommended Posts

Hi,I have the following problem as with ASX solution.Q. I am getting an error that SP1 SimConnect cannot be foundA. When .NET 2.0 is not installed on the system when FSX or SP1 is installed, the proper managed SimConnect files may not be installed. To correct this situtation, uninstall SP1 via add/remove programs (check the box at top to show updates). Do not remove FSX, just the SP1 update. Then reinstall SP1. SimConnect should now be installed with the proper configuration.I do have .net 2.0 installed. I could not find SP1 for FSX in my add/remove programs. SP2 for FSX was there. Since Microsoft warns about re-installing SP1 if SP2 is already installed what I did was un-install SP2. I then downloaded SP1 and re-installed it followed by a SP2 re-install.I am still getting a SimConnect error when I try to run the Active Sky Software and it will not load any weather data into the program.Thanks for any help.SteveIntel 2.4 Qcore4 gig ramgeforce 8600 256meg500 gig HD

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I read your question correctly, I'm assuming the error is within ASX and the SP1 you mention is FSX SP1? It's not clear if you have removed .NET or not. If you have a problem with .NET itself, the best thing would probably be to install .NET 3.5 SP1, the latest, which will also re-install 2.0 as that's needed under the hood as well. I had to do this on my box and remind me NEVER to uninstall .NET versions I no longer use.There are several versions of simconnect depending on what version of FS you use. They can be installed concurrently. The simconnect client exists in the side by side (SxS) folder in your windows folder. The manifest embedded in the ASX software specifies which version of simconnect to load. The operating system loads the right version automatically, provided it can find it in the side by side folder. It's likely given your error that the side by side library is not found, or corrupt. Reinstalling the simconnect client provided with the ASX software is the first thing I would do. Look for a file called SimConnect.msi in the ASX install folder, that will re-install the client on your machine. That should work on the FSX machine, or a remote machine.I would also post your questions in the ActiveSky support forum below as Jim or one of the ASX gurus can help you down there.Etienne

Share this post


Link to post
Share on other sites

Yesterday I did this. First of all you have to install SDK (you can find this on the disk 1 of your copy of MSFX) at the harddrive you will find simconnect - run it. After this I found the SP1A instead of SP1. I run it, afterwords I reinstall Acitive Sky X, run the simconnect from the folder on the harddrive again and all data was received from the datacenter.

Share this post


Link to post
Share on other sites

Hi,I had the same problem and fixed it by simply running the Simconnect.exe for FSX Sp1 installer package from the SDK folder installed on the harddrive:Microsoft Flight Simulator X SDKSDKCore Utilities KitSimConnect SDKLegacyInterfacesFSX-SP1Not sure if this works based on the installation method used, but here is my FSX Installation methodThis installation was done 3 months ago 1 Installed FSX Deluxe Edition, FSX SDK,2 Installed FSX Sp1a, FSX SDK for sp1a,3 Installed FSX Accelerated pack followed by the FSX Accelerated SDK.hope this helpsRegards,Mario Intel Q6600 QCore 1066FSB 2.40GhzCorsair Dominator TWIN 2x2048 - 8500 C5DF 1066 FSBGigabyte GA-EX38-DQ6ASUS EN9800GX2 1GB DDR3 PCIe 2.0 16x

Share this post


Link to post
Share on other sites