Archived

This topic is now archived and is closed to further replies.

Guest Brunch

FSX CTD when i want to start a mission

Recommended Posts

Hello,i have a serious problem here. Everytime i want to start a mission FSX crashes to desktop.This happens when i choose a mission and klick on "mission briefing". It starts too load and crash after some sec. to the desktop.The error message tells me something is wrong with my mfc80.dll.So i tried to put different Versions of this file into my system32 folder. I reinstalled this c++ 2005 runtime. installed framework.net.Nothing worked.Everything else runs good in fsx, can do free fly and multiplayer but this error is getting me mad.Im using windows xp prof. with sp2.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same problem.Can fly as much as i want in free flight, but trying to do any mission i get an error report a few seconds after i click Briefing Room.mfc80.dll is listed as culprit in error rep.tried vanilla FSX , with sp1 then sp2 . Same result.Any help would be greatly appreciated.xp pro & sp2nvidia 8800gt 1gig ram , latest beta drivers2 gig ram

Share this post


Link to post
Share on other sites

I too have a similiar problem free flight ok. Missions CTD or send to Microsoft. the thing is everything was OK. I have not used Simulator for some time and was surprised when it crashed. I was getting referenced memory errors and installed it with 512mb stick twice using different stick each time. No luck. I reinstalled from external disk using Isos including Accelerator pack. No luck. I tried reinstalling Winxp. No luck. Tried g2d.dll mentioned elsewhere in this forum. No luck.Have also tried installing off DVD discs and it still fails.

Share this post


Link to post
Share on other sites

I don't have any solution but you're not alone. I have same problem on Vista (with SP1) and FSX with SP1 and SP2, I have 2 x 8800GTX cards and have tried different drivers etc.

Share this post


Link to post
Share on other sites

An update to my problem was that it ended up normal flights ok but missions failed after pressing Briefing button. Still could not get this to work after successive reinstalls. I did make it work by running missions by clicking on .FLT within each mission. Any comments welcome

Share this post


Link to post
Share on other sites

I have a similar problem. I can fly all the regular FSX missions and all but 2 of the acceleration missions. If I try to fly the Keys Kayakers or the Customs Intercept missions, all the rest work fine. I don't even get an error message it just shuts down FSX and sends me to the desktop.

Share this post


Link to post
Share on other sites

Hi, Sorry I am another one with the same problem but.My system was ok until I installed Autodesk Inventor 2009 software.then MSX Missions wouldnt work.Tried uninstalling both and reinstalling MSX but still no luck.

Share this post


Link to post
Share on other sites

I finally got mine to work. I had to completely remove FSX and FSX acceleration from the computer. Then reinstall FSX, and then reinstall acceleration. Everything works well after that.

Share this post


Link to post
Share on other sites

Hello,I have exactly the same problem and i have a solution but it would be fine to know if it works for all:1/ make a search of mfc80.dll on your C: partition2/ i find three dll:8.0.50727.428.0.50727.7628.0.50727.8323/ i open the folder containing the third one: C:WINDOWSWinSxSx86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.832_x-ww_3c7408c9create a new folder and drop in it the four dll found in it4/ i open the folder containig the second oneC:WINDOWSWinSxSx86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_3bf8fa05and copy the four dll in the folder find in point 3I suppose that .42 is the original dll, .762 is coming from a service pack of FSX and .832 is coming from a microsoft update.I am aware that this solution could have some side efects but did not find any other one.Could you try and report especialy for those having this problem after installing a new software?

Share this post


Link to post
Share on other sites

I tried this but I don't see any mfc80.dll on my system, quite a few mfc70.dll and mfc71.dll thoughThanks for trying to help though.

Share this post


Link to post
Share on other sites

Ok, sorry, i am running XP pro SP2 and use the deluxe FSX edition.When i make a fresh install, i have a CTD when i start a mission.After installing FSX SP1 and SP2, i have a microsoft error box indicating that the fault comes from the mfc80.dll.Did you have similar behavior indicating a faulty dll?

Share this post


Link to post
Share on other sites

Thanks!... finally sorted this thanks to you.I spent a while on this only to find I did indeed have version .922 of mfc80u.dll on my system, after struggling with Vista permissions to create folders and move files etc, I eventually copied .762 over in place of .922 and all is fine again.Also fixed Corel X4 which stopped working for the same reason!Many thanks for your help....fantastic!Cheers

Share this post


Link to post
Share on other sites

Hi,I'm new to the forum. I logged in with an identical problem. I too am an CAD AutoDesk Inventor Pro 2009 user.Just returned to thank all for their input & darefx for the solution. I carried out the changes as suggested & now I too am working fine.I would never have found a solution like that, boy that was deep.Just a quick question on this subject. I get an update from AutoDesk about every 6 months is this likely to happen when I reinstall my next CAD update?Thanks Again.:-)

Share this post


Link to post
Share on other sites

>Hello,>>I have exactly the same problem and i have a solution but it>would be fine to know if it works for all:>>1/ make a search of mfc80.dll on your C: partition>>2/ i find three dll:>8.0.50727.42>8.0.50727.762>8.0.50727.832>>3/ i open the folder containing the third one:>C:WINDOWSWinSxSx86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.832_x-ww_3c7408c9>create a new folder and drop in it the four dll found in it>>4/ i open the folder containig the second one>C:WINDOWSWinSxSx86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww_3bf8fa05>and copy the four dll in the folder find in point 3>>I suppose that .42 is the original dll, .762 is coming from a>service pack of FSX and .832 is coming from a microsoft>update.>>I am aware that this solution could have some side efects but>did not find any other one.>>>Could you try and report especialy for those having this>problem after installing a new software?Thanks.This worked for me. I had a different version of mfc80.dll, but worked all the same.I suspect it was either SQL Server Express, or OnTime 2008 that installed the new version, as these were the only 2 applications I installed recently.I only replaced mfc80.dll rather than all 4 as the other 3 were in use, i suspect by SQL server running as a service.Everything I need for my daily routine runs without any problems after replacing the file.Thanks again.

Share this post


Link to post
Share on other sites

>>Hello,>>>>I have exactly the same problem and i have a solution but it>>would be fine to know if it works for all:>>>>1/ make a search of mfc80.dll on your C: partition>>>>2/ i find three dll:>>8.0.50727.42>>8.0.50727.762>>8.0.50727.832>>>>3/ i open the folder containing the third one:>>C:WINDOWSWinSxSx86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.832_x-ww_3c7408c9>>create a new folder and drop in it the four dll found in itHi,where is to create the new folder? I have to cut and paste the .dll`s?thx for helpDave

Share this post


Link to post
Share on other sites

Hellojust create the new folder in the third found; it is just to make a backup of the .dll's.

Share this post


Link to post
Share on other sites

>Hello>>just create the new folder in the third found; it is just to>make a backup of the .dll's.But there is a problem, I work under Vista 64bit and can't create folders and move files. Any solution?thxDave

Share this post


Link to post
Share on other sites

helloI do'nt have Vista, but i think that plakey could help you, send him a private message

Share this post


Link to post
Share on other sites

Hi,I have the same question, I created a new folder in the second and third folders and copied the files in each directory to the new folder I'd created in it. I then copied the files from the third folder to the second.Having done that MS Flightsim didn't run at all nor some of my other applications.I read this post one day after installing SQL express and before the flightsim worked fine.I'm suing Vista Home Premium 32 bit and the hoops that I've had to go to to be able to even change the dll directories have really round me up as under XP life was much easier.You might like to read this before changing the files...http://www.neowin.net/forum/index.php?showtopic=537806You will have to turn User Account Control off first and then change the ownership of the files before moving/deleting them.I hope this is of use to anyone who has this problem.Regards,Paul

Share this post


Link to post
Share on other sites

It's caused by conflicting versions of the mfc80.dll. Microsoft have a fix described here http://support.microsoft.com/kb/961894. I've just tried it (and a reboot is not required Big%20Grin.gif ) and I can confirm that FSX Missions are now working for me.Regards,GuitarHead

Share this post


Link to post
Share on other sites