Sign in to follow this  
Guest jwight

AI Traffic Problem North Island and Miramar

Recommended Posts

I have traffic that work fine at other military fields when I change the airports to the two in San Diego the traffic doesn't show up. I have tried to create my own AFCAD files and used some I downloaded and no luck for KNKX and KNZY. Fault finder finds no problems in the AFCAD files and if I change the airports in the traffic files to KSAN I see my military traffic there. Has to be something I am missing in the AFCAD files. All of my other downloaded AFCAD files seem to work.ANy suggestions? Anyone have KNKX and KNZY that they know work? Would you be willing to e-mail them to me? jwight@communityblood.orgThanks,Jim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm not a "brain" when it comes to AFCADs and positioning traffic, Jim, but recently I tried to plonk my MAAM B25 at Flight Scenery's FZ02 - Pearson KVUO - and *nothing*. After half-an-hour (and some reading) I changed one of the small GA spaces to medium, with a diameter of 55 feet or so - and it worked. Maybe the same at North Island?

Share this post


Link to post
Share on other sites

Having just had a similar problem of my own with another afcad/airplane combo, all I can say is that you have to pull out a magnifying glass and check these things again and again...My examples below come from what I was working on, but they apply equally to civilian aircraft parking I am sure.Aircraft wingspan vs parking radius(AFCAD) - the radius must be larger than the wingspan. While I have always assumed that that referred to the wing_span entry in aircraft.cfg file, someone else has said this is not the case. So, I'm not absolutely certain where the wing_span data comes from. I simply found some afcads that worked for the planes I wanted to park/use and have written those values down and reused them time and time again.aircraft.cfg file and aircraft.txt entry matchupstitle="aaaaaaaaaaaaaaaaaaaaaaaaaa" must match the AC#xxx,xxx,"aaaaaaaaaaaaaaaaaaaaaaaaaa" entry exactly including ensuring there's no extra/unnecessary spaces between the quotation marks.aircraft.cfg and AFCAD matchupsatc_parking_types=aircraft_parking_codes=Reading some archived posts over on the PAI forums, I (re)learned that I had been doing some things incorrectly and/or inconsistently --- while AFCAD can utilize 3 entries in the atc_parking_codes line (ex., atc_parking_codes=560s,T38,M000), only one entry should be in the similarly titled line in the aircraft.cfg file (ex., atc_parking_codes=T38 but not atc_parking_codes=560S,T38). If there is more than one entry in the aircraft.cfg line, then only the first entry is used. In my example, the aircraft would look for a spot coded for its squadron -- if it doesn't find that AND there are no open transient or overflow spots, then you (might) have an error condition and the plane may not show up.This is why transient and overflow spaces exist and should be coded atc_parking_type=MIL_COMBAT, MIL_CARGO or totally blank -- at least in the case of militar aircraft (obviously).I am sure you know all of this... (re)learning it took me a couple days of hair pulling. I finally solved my problem but it took me a while (bad eyes) -- I had an extra space in a title AND the multiple entries in the aircraft.cfg atc_parking_codes issue to resolve.If I have explained or stated anything incorrectly, PLEASE someone correct me.Good luck.

Share this post


Link to post
Share on other sites

I have my skies full of real aircraft and was very happy with that. But I recently found a new love, a V-22 Osprey and it is more fun to land and take off than anything else I've tried. So since it's a Marines bird, I was trying to fly from NAS to NAS but it's not the same with no other aircraft at these bases. KNKX and KPNY??? Miramar and North Island and the one down south at Imperial Valley???So I tried downloading some AFCADS for these bases and they didn't do anything of course without a lot of work adding flightplans and that. For the last two nights I have been trying to do just that.I cannot get anything to show up at a NAS base but me. Just to make sure I understood what I was doing, I made one flightplan of a C-130 from KSAN to KLAX and back. The C-130 was there on time and took off and did what it was supposed to do.I don't know what Im doing wrong but am surfing today to try and find an answer.

Share this post


Link to post
Share on other sites

OK, I got it to work.I tried adding my own parking spaces with AFCAD2 and it was alot of work to do the taxi lines etc. so for now I borrowed somebody elses work. Dave O'Brien's files did the trick for me. Thanks, Dave!Look for wc_nas.zip and wcnas_fix.zip for the west coast bases. A lot of other bases are available as well. All the work adding parking spaces is done for you. You just need to tweak his flight plans to suit your aircraft inventory and VIOLA! it works.Heres what to do to get it to work:1. Make a new directory called "FS2004Addon SceneryMilitary_Basesscenery". Just adding it to "FS2004Addon Sceneryscenery" doesn't seem to work. (I must have missed this step or something, I don't remember reading it)2. Dump Daves .bgls there. 3. Add them to the list in FS9's "Settings/Scenery" menu. (don't forget to restart FS9)4. Creat your flight plans (directions for this is out of scope, that's for sure)Thanks again Dave, and good luck Jim. I'm off to make a boatload of military flight plans. What a hobby...dolph

Share this post


Link to post
Share on other sites

Did you get it working? I am flying short trips in an Osprey between KNKX, KNZY, and Pt. Mugu. All of it's working. Thanks to freeware, I'm a very satisfied simmer!dolph

Share this post


Link to post
Share on other sites

The problem is solved for me. All I had to do was create a new scenery folder, place the AFCAD files for my California Naval Air Stations in it and place it high on the scenery.cfg list. For some reason having these new AFCAD files in the Addon Sceneryscenery folder didn't do the trick for me anymore. That did work before my latest re-install of FS9 after dumping FSX. I do have Megascenery for Southern California, maybe that was the problem? I had it with my last install and didn't have to do it.Traffic is all over North Island...now I can set up traffic files to fly to the Big "E" off of San Diego. Life is good again. I think I put more that a week of many hours into trying to solve this with lots of frustration. Thanks to everyone who tried to help.Jim

Share this post


Link to post
Share on other sites

Jim,Yep, same here. I have a week in this. I don't know why it won't work just placing it into the addon/scenery folder either. NEways, I now have 510 custom flights with 2 or more legs in addition to the GA traffic and the default traffic. I have so much traffic I can hardly get a word in edgewise with ATC and I have to wait in a line to take off and go around to land. Pretty cool. Definitely adds to the pilot workload...I have the F16 radar working in my cockpit and the skys are pretty realistically busy. dolph

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this