Sign in to follow this  
rhodges

fsautostart Problems???

Recommended Posts

After installing FSX, I made an attempt at implementing autostart for that program.I edited my "path" to be "Program FilesMicrosoft GamesMicrosoft Flight Simulator Xfsx.exe"No luck. It did not work.I edited my "path" back to be "Program FilesMicrosoft GamesFlight Simulator 9fs9.exe".Now I cannot get FS9 to come up under autostart. NO, I am not absolutely sure that the path for FS9 is exactly what I had before, but I have tried all kinds of combinations and cannot get fsautostart to work now. It goes into phase 6, and nothing ever happens past that point. It continues "Waiting for Main Application to finish" in either FS9 or FSX.I have tried saving either as a profile, leaving them as the main application, etc. with no luck.I have tried deleting FSAutostart completely including the folder "%appdata%" and reinstallation of the latest version as recommended by another post with no luck.Has anyone else had a similar problem and know what I am doing wrong.I guess I need a COMPLETE step by step tutorial, but the link for Ken's FSStartup forum seems to be under new construction now.This program has worked for some time for me after multiple installations thus far, but I cannot for the life of me figure out what I am doing wrong this time. Seems like I saw this once before and figured it out, but I am presently stumped for either FS program.Mr. Monitor I am posting this in both the FS9 and FSX forum being that I cannot get autostart to work in either and hope someone has been down this road. If I have erred, I stand corrected when I see your verbal spanking.Any ideas sure would be appreciated:Respectfully:RTH

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

RTHI had a similar problem like that. I would configure the path to FS9,FSX, Combat Sim 2&3, but couldn't launch AutoStart after doing so.I found out that after configuring the paths you have to exit AutoStart and restart it. Then all was well.Daryll

Share this post


Link to post
Share on other sites

Thanks for the reply Daryll:I have tried exiting and restarting multiple times in both FS9 and FSX with no success. Even tried restarting the computer after every effort.Per chance, are you still running FS9 also?Thanks again:RTH

Share this post


Link to post
Share on other sites

RTH Yes I am still using FS9. Just to be clear, I'm talking about exiting AutoStart. Configure your path and don't attempt to launch AutoStart from the sim icon in the AutoStart box. "X" out of the window and go to your desktop AutoStart shortcut and start AutoStart again. This is what solved my problem that gave me the error messages when I was at the point you are at.That's the extent of my problem solving after the error messages I was getting after trying to reconfiguring AutoStart.Daryll

Share this post


Link to post
Share on other sites

I forgot to add that I don't have the full version of FSX installed. I do have the FSX demo installed. That was when I encountered the configuration problem with AutoStart when I wanted to use it with the FSX demo.Daryll

Share this post


Link to post
Share on other sites

Ummm. Interesting.I have tried numerous times. Not only have I tried exiting autostart after configuration and then restarting fsautostart, but I have even tried restarting the computer after configuring my path, but no luck thus far.I really never get an error message. She just never does come out of Phase 6 with a startup of FS. It just continues definetely "waiting".Thanks for the advice.RTH

Share this post


Link to post
Share on other sites

SUCCESS!!! (finally, for both FS9 and FSX. Either will FSAutostart)Rather than go through all of the scenarios that did not work, I will simply go through the steps that did as follows for my preferences:1. Install FSAutostart.2. Double click on the fsautostart shortcut to start the program3. Click on Configure4. Click on Browse5. Double Click "FSAutoStart.exe"6. Click on Save7. Click on ok8. Click on X to close the FSAutoStart - fsautostart Window9 Click on the fsautostart shortcut to restart the program10 Click on File11 Click on New12 Click on Blank13 Type FS9 in the New Profile Name: option14 Type Flight Simulator 2004 in the the Description: option15 Click Save16 Click on the FS9 Icon (Highlight)17 Click Configure (Highlight will dim which is ok. Your Profile Description should be "Flight Simulator 2004")18. Click "This is not the Main App". (There should now be a box around this option.)19. Click OK20. Double click FSAutoStart.exe21.In "Path to app:" type C:Program FilesMicrosoft GamesFlight Simulator 9FS9.exe22 Click Save23 Click the X to close the FSAutoStart-FS9 window.24.Double click on the fsautostart shortcut to start the program25. Click on File26. Click on New27. Click on Blank28. In the New Profile Name: Option type FSX29. In the Description: Option type Microsoft Flight Simulator X30. Click Save31. Click on the FSX Icon (Highlight)32. Click Configure33. Click This is not the Main App.34. Click OK35. Double Click FSAutoStart.exe36. In "Path to app:" type C:Program FilesMicrosoft GamesMicrosoft Flight Simulator XFSX.exe37. In "Delay before auto starting other programs type 60.38. Click Save.39. Click the X to close the FSAutoStart-FSX Window.Now, when you double click your FSAutoStart shortcut, you should have three choices. The default fsautostart Icon, the FS9 Icon which when double clicked will fsautostart FS9, and an FSX Icon which will do likewise for FSX.If you are useing only one simulator, or if that is your preference, one of them can be configured under the fsautostart main program in like manner (You will not click the "This is not the Main App" option). However, the only Icon you will have is the fsautostart default. I personally prefer the above arrangement.For what is might be worth to anyone setting up the Services and Programs, the following are the line items which gave me error messages on my system (Yours may not have some, have others, or be differrent. They seem to come and go so they may change over time). In addition to those recommended by the program, if you will leave these with the "No Action" option, the applicable error messages will no longer appear.Programs as follow:ati2evxxexplorer.exeMSOFFICE.EXEServices as follow:ATI HOTKEY PollerCom+ Event SystemNetwork ConnectionsRemote RegistrySSDP Discovery ServicesTCP/IP NetBios HelperTerminal ServicesWebClientWindows Media Connect (WMC)In the event that anyone is running the Zone Alarm Firewall, you will need to also leave the following with the "No Action" option:TrueVector Internet MonitorHope something here is of help to somebody. I realize that it is long and drawn out, but if you go over it a bit, I think it explains itself for anyone who is new to FSAutostart and might be having trouble. My problem was thinking something had to be entered in the "Command Line". IT DOES NOT. Just a senior moment I guess in not remembering how I had it set up from many months ago (I'm sure nobody else has that problem).Happy Flying:Respectfully:RTHEdit: Do notice step 37 above. This is the only difference with the exception of text in configuring the two flight simulator programs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this