Sign in to follow this  
Guest kencr

Aircraft veering

Recommended Posts

Using FS2004, I find that aircraft (I mean every aircraft) veer either left or right without any control input. This happens even in calm conditions (no wind), and with the aircraft perfectly lined up with the centreline of the runway. I've reloaded Fs2004 entirely, hoping the fault would fix itself, but it keeps on happening regardless.Is there some way of correcting this, or could it be an inbuilt fault in the system ??

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Usually caused by a defective (read that: self induced maintenance problem -- worn out) joy stick; time to get rid of that old SubLogic and replace it with a new Logitech's Digital 3D [/font size]

Share this post


Link to post
Share on other sites

What device are you using to control your rudder (yaw)? Joystick, pedals, yoke, mouse, keyboard? Have I missed any? R-

Share this post


Link to post
Share on other sites

The aircraft is controlled by a Top Gun Afterburner joystick, with twist grip rudder.

Share this post


Link to post
Share on other sites

Have you tried enabling the yaw damper in Aircraft/Realism. Just a thought.Russell.

Share this post


Link to post
Share on other sites

>The aircraft is controlled by a Top Gun Afterburner joystick,>with twist grip rudder.I would try to eliminate the joystick as a problem. Line up on the runway, then disable the joystick (Ctrl+k, I believe). Use the Numpad 0 key (left rudder), Numpad Enter key (right rudder), and Numpad 5 key (center ailerons and rudder) to steer the plane during takeoff. If the plane stays reasonably straight, then you have a joystick problem. Try increasing the null zone and reducing the sensitivity of the rudder axis before replacing the joystick. R-

Share this post


Link to post
Share on other sites

Yaw damper in Aircraft realism????Are you sure? Look again?

Share this post


Link to post
Share on other sites

I have had similar problems from time to time and then I realize that the Auto Pilot is engaged at start up even though I never set it. I don't know why this happens from time to time but it does? This is fairly obvious once you get going. The other thing it could be is that you have a command conflict between what your contol settings in the FS9 settings and the utility/setup program that came with the stick - if you have that.For example, my Saitek X45 has it's own setting profiler that does not automatically overide the control settings in FS9. So I have at times had to go through and make sure there were matching settings.Good luck :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this