Archived

This topic is now archived and is closed to further replies.

zmanisfireproof

Clouds and FPS - Help!!!

Recommended Posts

I recently re-installed FS2004 like I've done several times before. I loaded the game up and everything worked great - until ActiveSky loaded the weather. Man, as soon as my clouds loaded up, my game came to a screeching stop. This is a simulation, not a powerpoint presentation!I've tried everything known to man from replacing the cumulus01 texture file with a reduced sized one to reconfiguring the FS9.cfg file and nothing works. I've never had this problem before, and, concerning my system, I shouldn't be having it now. System is as follows:Alienware Area-51 7500Processor: Intel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Doesn't work. I have the most current Nvidia driver, but, it doesn't matter. And FS2004 itselfs runs flawlessly - without clouds, the game is extremely smooth and sharp. It just acts up when the clouds are loaded. And, all of my other games work fine.Thanks for the suggestion, but I don't believe it's a video driver issue...

Share this post


Link to post
Share on other sites

i stopped reading after this because i found your problemOperating System: Windows Vista Home Premium

Share this post


Link to post
Share on other sites

I can sympathise as I too have Windows Vista Home Edition and I really really hate it!! My specs are slightly lower than yours but FS9 does work fine even with ActiveSky clouds loaded. The only thing I've found that occasionally towards the end of the flight, it freezes and you have no choice but to reset it.I had to compromise though so I lock my framerate to target 20FPS, I don't have any filtering, although have most other sliders on high to max. Autogen on normal. But even if I did everything on max the worst FPS i get is around 8-10, so no sure why yours is like a powerpoint presentation.It can't be FS9 itself as your specs should easily match it. Have you tried your video card settings or some display panel outside FS9?Maybe try Fs Sky World and try their alternate clouds that is framerate friendly. Try that and if that is fine, maybe slowly build it up. Maybe it's Active sky itself?

Share this post


Link to post
Share on other sites

lol, right. Nobody has any problems with clouds under XP....:-roll

Share this post


Link to post
Share on other sites

Well I run Vista and have only had this problem once, which was fixed by toggling between windowed mode and full screen and back again. I don't think you can generalise and call it a vista problem.Gary

Share this post


Link to post
Share on other sites

Double check your anti alias settings in your video card setup. I don't have the same setup you do but found that letting the application control the AA settings cured the problem that you are experiencing.

Share this post


Link to post
Share on other sites

I am using Vista Home PremiumMy comp spec.E67503G DDR2BFG 8800GT OCI was using the Aero layout and it gave me all kind of trouble.When I switch back to the Vista normal layout I can play FS2004 in window mode smooth at everything to the right, but not full screenI haven't tried the classic layout because I some what like the Vista layout more than the blocky classic.You may try and see if it helps.Vincent

Share this post


Link to post
Share on other sites

You don't have to turn off Aero completely to achieve the same effect. Just make a shortcut to FS9 and check the "disable visual themes" checkbox on the compatibility tab. That way FS9 does what FSX does and only disables Aero when running that specific application.Gary

Share this post


Link to post
Share on other sites

Guys, I think I figured it out!Thanks so much for all of your suggestions and input. I have nHancer, a utility to 'help' nVidia get along with Vista for the most part, and it seems that after messing around with it and doing some tweaking, I have finally got FS2004 back up and running like she use to. Ah, it sure is nice to finally fly through some massive cloud coverage and have my computer not even flinch.Thanks again everyone for your suggestions. It made me start thinking and tinkering some more and I've solved the problem. Later.

Share this post


Link to post
Share on other sites

So what settings in nHancer cured your slide show?

Share this post


Link to post
Share on other sites

Well, I don't know really. I didn't really change any settings. Basically, with the new nVidia drivers 163 and above, game profiles that come with the driver cannot be changed, even by nHancer. So, in order to get FS2004 to have decent AA within the game, you have to duplicate it's profile from nVidia's one within nHancer. This disables nVidia's faulty profile (AA will not work in FS2004 with default nVidia settings) and allow you to set FS2004's duplicated nHancer profile to your liking.Well, all I did was go into nHancer and delete the duplicated profile I had originally made for FS2004 and create a new one. I didn't change the settings from one to the other - I just deleted it, then remade it. And somehow, this worked.Hope this explanation isn't too confusing...

Share this post


Link to post
Share on other sites

Oh yes i can! The only other thing besides ditching it or buying a new computer is to reduce the number of cloud layers AS will render. default is 5 and that will kill most computers, except mine, as i am on XP and dont even feel them.Try 3.

Share this post


Link to post
Share on other sites

Gotch ya Stephen, been using nHancer for a while now since reading a few threads on it. Good troubleshooting on your part!

Share this post


Link to post
Share on other sites