Sign in to follow this  
Guest PauloCruz

G****e lowered the number of files before adding IP to ...

Recommended Posts

Does anyone know if G****e lowered the number of files we can download with TP before adding the IP to the blacklist ? Since last night I can only download about 300 files before I start receiving the usual message.I reset my modem to obtain a new IP, but after downloading more 300 files or less, the new IP's are blocked, too.Before last night I rarely got blocked and I used to download thousands of files at each time.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It could be that they lowered their thresholds for detecting "robots" and "viruses" a bit.I would go down to a really low conn= setting, e.g. 4 and the bulk_extend value should also be set much lower, e.g. 10 or 20

Share this post


Link to post
Share on other sites

Christian, thanks for you settings.They work fine for the first 30 minutes, but after that, the IP's my provider assigned to me, were blocked after a few downloads. At this time I believe that G****e put the range of IP's my provider usually gives me in the black list.Can you tell me the minimum values you advise to use for "conn" and "bulk_extend" ?My settings are conn=4 and bulk_extended=10About TileProxy, what can I say, it is what I always wondered for FS.Excelent work. Keep going.

Share this post


Link to post
Share on other sites

I don't use stupid google anymore. I get blacklisted after 1 minute.

Share this post


Link to post
Share on other sites

I might have to give TP access to Internet Explorer's cookie cache. On the first 302 redirect I could open an IE window to let you enter the kaptcha.

Share this post


Link to post
Share on other sites

G****e is practically useless for me too. What does conn and bulk_extended mean?

Share this post


Link to post
Share on other sites

I also had serious problems with GE recently. I don't care much for that service any more.I find VE gives me the best performance, and they seem to have extended the coverage of color photography recently. The area around 39P used to be B&W for example, but recently they added a large chunk of colour photography. This seems to be true elsewhere as well, most of WA, OR and CA are fully coloured now, with only a few chunks of BW photography.When there are a lot of b&w tiles, I tend to swtich to the service that was introduced in Beta5. They seem to use colourized b&w tiles, meaning that I don't have to use the "on the fly" colourization of TP, which tends to cause some stutters with my single-core CPU. Unfortunately, they don't seem to have the same large-area coverage of full colouried tiles, making those areas not as detailed as VE.

Share this post


Link to post
Share on other sites

I may have a solution ready soon.A window with embedded web browser will pop up once every 20 minutes or so, you enter the captcha and everything will be humming along nicely until the next nag screen.Still much better than no data at all.

Share this post


Link to post
Share on other sites

Excuse me for blunt ignorance, but what is captcha?

Share this post


Link to post
Share on other sites

Would really appreciate if you did Christian.For Eastern Australia GE has best coverage once you get outside metro areas.Haven't much flying time recently. About to get in and give TP Beta 6 a go.Rob

Share this post


Link to post
Share on other sites

The latest preview version on sourceforge has it!This goes into the service specific section of ProxyUser.INIfor the particular service to enable captchas withcaptcha_module=captchaformcaptcha_config="cookieurl=nameofprovider.com|cookieurl=http://www.nameofprovider.com"replace the obvious ;)Christian

Share this post


Link to post
Share on other sites

I haven't been able to get this to work Christian. Can see redirect errors and TP triggering the capthca module - bit Internet Explorer doesn't open. Suspect syntax problem - under GE part of my config file have:captcha_module=captchaformcaptcha_config="cookieurl=kh3.g####e.com|cookieurl=http://kh3.g####e.com.com"Seems funny to have cookieurl before and after the pipe character?Rob

Share this post


Link to post
Share on other sites

RobYou're right. The correct syntax should be:captcha_config="cookiedomain=g####e.com|cookieurl=http://www.g####e.com"But the IE window only opens once. The second time doesn't open. Chris already noticed this bug and I hope he will correct it in next release.Paulo

Share this post


Link to post
Share on other sites

Many thanks Paulo.Managed to get going but only for first prompt as you said.GE has definitely got stingier. 2-3 months ago could fly for hrs, but as already described only getting minutes now before blacklisting (20-30).Would still persevere with GE for Aust if Christian finds time to catch follow-up prompts though for better coverage.Regards,Rob

Share this post


Link to post
Share on other sites

First, special thanks to Christian for this great program. In my opinion the best Flightsim add-on I've ever seen!. And yes I have a "poor" system: P4 2.4 Ghz,512Mb, Geforce FX5200 but I'm very satisfied with Tileproxy Beta6 preview2 in FS9.My question is: Like other people I have blocked out problems using G****e like this (they are getting worse and worse when flying):Error was 47 for transfer #1(http://kh0.google.com/kh?t=tqstqrqtsrtrqsq&n=404&v=17),cleaning up...Transfer #1 resulted in redirect, retrying (1)...Error was 47 for transfer #3(http://kh0.google.com/kh?t=tqstqrqtsrtrrtq&n=404&v=17),cleaning up...Transfer #3 resulted in redirect, retrying (1)...Error was 47 for transfer #2(http://kh1.google.com/kh?t=tqstqrqtsrtrqsr&n=404&v=17),cleaning up...Transfer #2 resulted in redirect, retrying (1)...Transfer #1 problem - giving up!Transfer #3 problem - giving up!Transfer #2 problem - giving up!Transfer #0 problem - giving up!(0) - Done!I added captchamodule=captchaformcaptcha_config="cookiedomain=google.com|cookieurl=http://www.google.com"to my proxyuser.ini file, but I never get a pop up to enter a captcha to continue flying. And, when working, will this solve the problem?? Has someone experience??Here are my settings: see service example 2, maybe it's wrong?Thank you in advance,Louis## Start a line with # to comment it out.# Turn your text editor's Word Wrapping OFF for editing this document.## Read the manual for help with configuration. Do not contact the# author about the configuration for particular services. Thank you.#[TileProxy]# Enable or disable worldwide photographic scenery coverage (Yes/True/On to enable)master_enable=On# Offline Mode - No network access will occur (Yes/True/On to enable)offline_mode=No# The distance up to which LOD 15 (1.1m/pixel) would be loaded (only applies to FS9 and FSX RTM)lod_distance=1000# Resolution limiter: 15 = 1.1m/pixel, 14 = 2.3m/pixel, 13 = 4.75m/pixel# Lower resolutions load faster, but are visually less appealing.max_lod=13# Number of Tiles to read-ahead. Speeds up communication between proxyUser and tileproxy.syspreload=15# Generate Water Mask. This brings back shader-rendered water and allows# for the use of planes with floats (Goose, Beaver, etc...). If you turn this# option off, you get the Tileproxy behavior of Beta 5 and earlier versions.water_mask=On# Recommendation: FSX users: Use water_blending=on, water_smoothing=off# to get soft land/water transitions## FS9 users: Use water_blending=off, water_smoothing=on# to get hard land/water transitions which# Tileproxy tries to match pixel-exact against coast-lines## Combining water_smoothing and water_blending is discouraged.# It's slow and gives weird results.# Use blending techniques to create a soft land/water transition with some# transparency effect near the shoreline. Compatible with FSX only.water_blending=Off# The distance in meters that you want land/water blending to extend from the# shore line. Larger values require more processing. You should not currently# specify values much larger than 500 meters because it can create visual artifacts.blend_distance=500.0# Try to smooth land/water boundaries by trying to match the water mask to the image content.# This is a a somewhat experimental algorithm.water_smoothing=Off# The decision threshold for water/land when water_smoothing is enabled. 0 means everything# will be turned to land, 1 means everything turns to water. Chose some value inbetweenwater_threshold=0.33# Maximum number of bytes allocated to BMP graphics tiles in RAM at any time.cache_bytes_limit=200000000# Maximum number of BMP tiles to cache in RAM at any timecache_tiles_limit=100000# The currently active service is configured here. Only ONE active source please.# The other source statements should be commented out.#source=Acme Globe Service#source=Service Example 1source=Service Example 2#source=Service Example 3#source=Service Example 4# The sources you want to be able to switch from the GUI menu.# Separate the list entries with | and enclose in quotes. Make sure the# names specified here are valid services which are defined below.# You may want to rename the services according to your preference,# but make sure you replace all occurences of the strings.menu_sources="Service Example 1|Service Example 2|Service Example 3|Service Example 4"## Here begin the service specific configurations## This is new when you specify captcha_module## On encountering HTTP 302 redirects the captcha module will send Internet Explorer's cookies# stored for the specified service domain to the web server. It will also display whatever web# page the service redirects you to. This could be a page requiring you to enter a so-called# captcha. After entering the captcha correctly, the resulting session cookie will be stored as# a permanent cookie (expiration 1 day) in your IE Cookies folder and sent to the service on# subsequent requests. You will then be able to use the service as long as you wish, given that# you correctly enter the captcha dialog which may nag you once every 20 minutes or so.# # Explaining the captcha_config arguments:## cookiedomain from captcha_config specifies the domain name for which cookies are stored.# This might be the service name plus a top level domain like ".com"## cookieurl specifies a HTTP url from which an identifying cookie will be retrieved first, if# no existing identifying cookie is found. This may be required sometimes to make the captcha# dialog appear in the first place. This could be the service's front page URL (e.g. a search# engine)[Acme Globe Service]cache_folder=cache.acmenetwork_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://server*.acmeglobe.com|path=/terraintile?pos=%s&v=%v|quad=ABCD|balance=0123|agent=Mozilla/4.0 (compatible; The TileProxy Project)"captcha_module=captchaformcaptcha_config="cookiedomain=acmeglobe.com|cookieurl=http://www.acmeglobe.com"min_level=9max_level=17map_version=1color_hack=Nocolor_level=0bulk_extend=25[service Example 1]cache_folder=cache.service1network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.figurethisoutyourself|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"captcha_module=captchaformcaptcha_config="cookiedomain=figurethisoutyourself|cookieurl=http://www.figurethisoutyourself"min_level=9max_level=17map_version=52level_mapping=9,10,11,12,14,14,15,16,17#level_mapping=9,10,11,14,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50[service Example 2]cache_folder=....cache.service2network_module=libnettilemodule_config="conn=10|rate=2.0|verbose=1|server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=%v|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"captchamodule=captchaformcaptcha_config="cookiedomain=google.com|cookieurl=http://www.google.com"min_level=9max_level=15map_version=20color_hack=Nocolor_level=0bulk_extend=20[service Example 3]cache_folder=....cache.service3network_module=libnettilemodule_config="conn=15|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=9max_level=15map_version=1.5color_hack=Nocolor_level=0bulk_extend=25[service Example 4]cache_folder=....cache.service4network_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://mapcache*.figurethisoutyourself|path=/sat/%Z/%X/%Y?partner=|balance=1234|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=17map_version=1color_hack=Yescolor_level=12bulk_extend=50

Share this post


Link to post
Share on other sites

No, it doesn't work. When I change it to captcha_module, I get the message "press a key to proceed" and when I press a key the whole load filter driver and run proxyuser window disappears and the program ends....Maybe it has to do with an install problem: a failing Exe Path registry key?This is my load filter driver and run proxyuser window:Directory is C:Program FilesMicrosoft GamesFlight Simulator 9TileProxy on drive C:Load failed with error: 0x80070420De service is al gestart.Attach failed with error: 0x801f0012An instance already exists with this name on the volume specified.proxyUser: will operate on drive C:proxyUser: DeviceHarddiskVolume1 ===> C:proxyUser: Configuration summary master_enable=1 offline_mode=0 menu_sources=Service Example 1|Service Example 2|Service Example 3|Service Example 4 source=Service Example 2 lod_distance=1000.000000 preload=15 network module=libnettile module configuration=conn=10|rate=2.0|verbose=1|server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=%v|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322) max_lod=13 (256x256 tiles) min_level=9 max_level=15 color_hack=0 color_level=0 bulk_extend=20 level_mapping=Not activated map_version=20 water_mask=On water_smoothing=Off water_threshold=0.330000 water_blending=Off blend_distance=500.000000proxyUser: Connecting to the filter ...TileAPI: Using network module 'libnettile'TileAPI: Network configuration 'conn=10|rate=2.0|verbose=1|server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=%v|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)'nettile: Using captcha module 'captchaform.dll'nettile: server is http://kh*.google.comDruk op een toets om door te gaan. . .

Share this post


Link to post
Share on other sites

It appears that the captchaform component is crashing for you. I wasn't aware that you are using FS9 (I should read more carefully).When I have some time, I will investigate the reason for the crash.Christian

Share this post


Link to post
Share on other sites

Christian,I've the same problem with FSX on my system. All virusscanners are disabled.Is it possible to enter a captcha manually???

Share this post


Link to post
Share on other sites

The captcha can be entered if you access one of the service's tile URLs directly in Internet Explorer. BUT, and here's the problem: These cookies are pure session cookies and they don't get saved to disk.Without some additional JavaScript hacks you won't get these cookies stored permanently. And that's required for Tileproxy to be able to access the cookies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this