Sign in to follow this  
hilton

Copy Error window

Recommended Posts

Hi Christian,I am getting the following error message:An error occured while copying file tileproxy.sysCannot copy file to destination directory - tileproxy.sys to C:windowssystem32drivers.This is a new computer therefore a virgin installation. Windows vista 32 home premium. The tileproxy executable is on my second drive with FSX and all data has been directed to a third drive.Is this a UAC issue?ThanksBernard

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OK I think it was Vista's UACNew problem - the world is now jet black apart from the airports and water. Real spooky.The tileproxy window displays "synchronous ------- problem. No Cache".Any ideasBernard

Share this post


Link to post
Share on other sites

Can you post a screen shot of the Tileproxy DOS box loading the tiles?

Share this post


Link to post
Share on other sites

Christian,Forget the black world issue I had two sources specified. See post by another user.The world is no longer black just very fuzzy.The DOS tp window keeps scrolling the following lines over and over:tileproxy.sys : Read with IRP_SYNCHRONOUS_PAGING_IO!tileproxy.sys : Read with IRP_NO CACHE!tileproxy.sys : Read with IRP_PAGING IO!Sometimes (briefly) the window will show correct recognisable text and the world is there but very fuzzy in low definition.Bernard

Share this post


Link to post
Share on other sites

I am also using Vista on a laptop of mine and I am not getting these messages. ;)It appears that your tiles are being read with paging I/O. This is a bit unexpected and the driver loudly complains about it. Is there anything unusual about your system configuration?

Share this post


Link to post
Share on other sites

>>It appears that your tiles are being read with paging I/O.>This is a new computer with a fresh install of FSX and Tileproxy.My system is configured as follows: C: drive Windows Vista 32 Home Premium.D: DVD ROME: Second drive containing FSX and Horizon VFR Photographic SceneryF: DVD RW DriveG: Tileproxy data in G:Microsoft GamesCache Service 1 and Tileproxy Photoreal World.I have cleaned out all tileproxy data - no changeI have stopped AVG Antivirus - no changeI have turned off UAC in Vista - as much as it will let you.I am stumped. Is paging I/O something to do with the way my pc connects to the internet?My Proxtuser ini is as follows. I have only tried the GE service so far.## Start a line with # to comment it out.# Turn your text editor's Word Wrapping OFF for editing this document.## Read the manual for help with configuration. Do not contact the# author about the configuration for particular services. Thank you.#[TileProxy]# Enable or disable worldwide photographic scenery coverage (Yes/True/On to enable)master_enable=On# Offline Mode - No network access will occur (Yes/True/On to enable)offline_mode=No# The distance up to which LOD 15 (1.1m/pixel) would be loaded (only applies to FS9 and FSX RTM)lod_distance=1000# Resolution limiter: 15 = 1.1m/pixel, 14 = 2.3m/pixel, 13 = 4.75m/pixel# Lower resolutions load faster, but are visually less appealing.max_lod=15# Number of Tiles to read-ahead. Speeds up communication between proxyUser and tileproxy.syspreload=15# Generate Water Mask. This brings back shader-rendered water and allows# for the use of planes with floats (Goose, Beaver, etc...). If you turn this# option off, you get the Tileproxy behavior of Beta 5 and earlier versions.water_mask=On# Recommendation: FSX users: Use water_blending=on, water_smoothing=off# to get soft land/water transitions## FS9 users: Use water_blending=off, water_smoothing=on# to get hard land/water transitions which# Tileproxy tries to match pixel-exact against coast-lines## Combining water_smoothing and water_blending is discouraged.# It's slow and gives weird results.# Use blending techniques to create a soft land/water transition with some# transparency effect near the shoreline. Compatible with FSX only.water_blending=On# The distance in meters that you want land/water blending to extend from the# shore line. Larger values require more processing. You should not currently# specify values much larger than 500 meters because it can create visual artifacts.blend_distance=500.0# Try to smooth land/water boundaries by trying to match the water mask to the image content.# This is a a somewhat experimental algorithm.water_smoothing=Off# The decision threshold for water/land when water_smoothing is enabled. 0 means everything# will be turned to land, 1 means everything turns to water. Chose some value inbetweenwater_threshold=0.33# Maximum number of bytes allocated to BMP graphics tiles in RAM at any time (0 for unlimited)cache_bytes_limit=64000000# Maximum number of BMP tiles to cache in RAM at any time (0 for no limit)cache_tiles_limit=50000# The currently active service is configured here. Only ONE active source please.# The other source statements should be commented out.#source=Acme Globe Servicesource=VirtualEarth#source=Google#source=Yahoo#source=Service Example 4# The sources you want to be able to switch from the GUI menu.# Separate the list entries with | and enclose in quotes. Make sure the# names specified here are valid services which are defined below.# You may want to rename the services according to your preference,# but make sure you replace all occurences of the strings.menu_sources="Acme Globe Service|VirtualEarth|Google|yahoo"## Here begin the service specific configurations## This is new when you specify captcha_module## On encountering HTTP 302 redirects the captcha module will send Internet Explorer's cookies# stored for the specified service domain to the web server. It will also display whatever web# page the service redirects you to. This could be a page requiring you to enter a so-called# captcha. After entering the captcha correctly, the resulting session cookie will be stored as# a permanent cookie (expiration 1 day) in your IE Cookies folder and sent to the service on# subsequent requests. You will then be able to use the service as long as you wish, given that# you correctly enter the captcha dialog which may nag you once every 20 minutes or so.# # Explaining the captcha_config arguments:## cookiedomain from captcha_config specifies the domain name for which cookies are stored.# This might be the service name plus a top level domain like ".com"## cookieurl specifies a HTTP url from which an identifying cookie will be retrieved first, if# no existing identifying cookie is found. This may be required sometimes to make the captcha# dialog appear in the first place. This could be the service's front page URL (e.g. a search# engine)[Acme Globe Service]cache_folder=G:Microsoft Gamescache.acmenetwork_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://server*.acmeglobe.com|path=/terraintile?pos=%s&v=%v|quad=ABCD|balance=0123|agent=Mozilla/4.0 (compatible; The TileProxy Project)"captcha_module=captchaformcaptcha_config="cookiedomain=acmeglobe.com|cookieurl=http://www.acmeglobe.com"min_level=9max_level=17map_version=1color_hack=Nocolor_level=0bulk_extend=25[VirtualEarth]cache_folder=G:Microsoft Gamescache.service1network_module=libnettilemodule_config="conn=10|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=9max_level=17map_version=55level_mapping=9,10,11,12,14,14,15,16,17#level_mapping=9,10,11,14,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50[Google]cache_folder=G:Microsoft Gamescache.service2network_module=libnettilemodule_config="conn=10|rate=2.0|verbose=0|server=http://kh*.google.com|path=/kh?t=t%s&n=404&v=%v|quad=qrts|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"captcha_module=captchaformcaptcha_config="cookiedomain=figurethisoutyourself|cookieurl=http://www.figurethisoutyourself"min_level=5max_level=17map_version=20color_hack=Nocolor_level=0bulk_extend=50[yahoo]cache_folder=G:Microsoft Gamescache.service3network_module=libnettilemodule_config="conn=10|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=17map_version=1.5color_hack=Nocolor_level=0bulk_extend=50[service Example 4]cache_folder=G:Microsoft Gamescache.service4network_module=libnettilemodule_config="conn=10|rate=2.0|verbose=0|server=http://mapcache*.figurethisoutyourself|path=/sat/%Z/%X/%Y?partner=|balance=1234|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=5max_level=17map_version=1color_hack=Yescolor_level=12bulk_extend=50Thanks for your timeBernard

Share this post


Link to post
Share on other sites

Paging I/O is related to Virtual Memory. Virtual Memory is used when the system kernel is caching files.You could try to disable the SuperFetch and ReadyBoost services, somewhere in the Control Panel under "Administrative Tools", "Services".

Share this post


Link to post
Share on other sites

>>You could try to disable the SuperFetch and ReadyBoost>services, somewhere in the Control Panel under "Administrative>Tools", "Services".>No that did not work.I will try uninstalling and reinstalling onto the same drive as FSX tomorrow.I think Vista's UAC is something to do with this.Tileproxy behaves normally up until it starts to load files.The previous version of TP worked fine on my old (very slow) pc.Bernard

Share this post


Link to post
Share on other sites

>I will try uninstalling and reinstalling onto the same drive>as FSX tomorrow.>>I have reinstalled onto the same drive as FSX but it has made no difference. UAC is turned off and the user permissions look good to me but what do I know about Vista.There are no new error messages as such, it just scrolls through the same three lines as above.Any assistance would be appreciated.Bernard

Share this post


Link to post
Share on other sites

I have now installed the latest drivers for my mobo and video card. Vista's UAC is turned off and I have an ADSL wired router which connects to the internet automatically through btinternet.My system consists of an Intel Quad core QX9650 processor in an Asus Maximus Extreme mobo. I am running Vista 32 home premium. FSX goes like the clappers but if I have started Tileproxy the window displays the errors mentioned above as soon as downloading takes place. Any downloaded tiles are corrupt and or of low definition.Dis-abling the services you suggested makes no difference. This is a standard set up with equipment and software straight out of the box. My old system (AMD xp3400) was too slow but it did work.Help urgently required.Bernard

Share this post


Link to post
Share on other sites

I am at a loss here.I have never seen this problem before. I cannot reproduce it. Therefore it is nearly impossible for me to fix.I have to recommend that you stop using Tileproxy on Vista for the time being.

Share this post


Link to post
Share on other sites

We are going up to Scotland to chill out for a few days so thought I would just spell out what was happening in total in the hope that someone may be able to shed some light.Tileproxy will not work - see above.Sky Anytime on pc will not work. This uses Kontiki a peer to peer service. Sky say that their software is ok for Vista.I have tried to reinstall Vista (upgrade) and windows refuses to do it.It gets as far as "Starting windows for the first time" and then says" Windows could not configure one or more system components. Upgrade not sucessful. Previous version being restored" Whereupon it restores Vista.I have visited the microsoft website and run the Upgrade Advisor - not very useful. There are no compatibility issues and according to Control Panel - Device Manager, there are no problems. All drivers are bang up to date.The computer works very well otherwise. Large internet downloads are no problem as are streaming video clips. FSX goes like the clappers and is as smooth as silk. I have not tried my TomTom software yet.The pc has crashed to a blank screen once. I am putting this down to the components bedding down the first time they got hot.I am not overclocking - no need. Benchmarks seem to be where they should be for this installation.Any ideas anyone?If you are reading this best wishes for Christmas and the new year. I am going north to chill out. LOL!Bernard

Share this post


Link to post
Share on other sites

Christian,What exactly is meant by "NO CACHE"What can TP not see?Bernard>tileproxy.sys : Read with IRP_SYNCHRONOUS_PAGING_IO!>tileproxy.sys : Read with IRP_NO CACHE!>tileproxy.sys : Read with IRP_PAGING IO!>

Share this post


Link to post
Share on other sites

Christian,>tileproxy.sys : Read with IRP_SYNCHRONOUS_PAGING_IO!>tileproxy.sys : Read with IRP_NO CACHE!>tileproxy.sys : Read with IRP_PAGING IO!>I think I have finally got this sorted. The above error messages have gone thanks to me turning off all non-microsoft services. I am sure that I did not have to do that with the other pc.Before starting to load thousands of tiles I got this message"Preload Algorithm does not seem to work for you, turning it off"What is that about?Individual tile accesses can be anything between 1 and 1900 using VE above Scotland. I have got some water where there should be land. This happened when I turned off the water mask to try to relieve the pressure on the processor and sharpen up the tiles. This QX9650 processor was running at 100% all cores with serious heat comming out of the case.Is it better to run at a fixed frame rate or unlimited?fsconfig has the mods generated by tileproxy and no others.Cheers Bernard

Share this post


Link to post
Share on other sites

> I have got some water where there should be land.Would you have a lat/lon coordinate for me where this occurs with water_mask set to off?Cool that you get 1900 tiles/sec. My quad manages at most 1000-1200, but I got the Q6600 and 2 Gigs of DDR1 RAM only and a mainboard with a VIA chipset.Fixed or unlimited frames should make no difference really. The Quad uses 1 core for rendering and 3 for tile loading, no matter what the frame rate is set to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this