Archived

This topic is now archived and is closed to further replies.

Guest karstele

Preloading stops while flying . . . ??

Recommended Posts

Me again . . .After about 20 hours of searching for the reason why tileproxy isn't willing to work properly for me - I need some advice.Starting Tileproxy, everything seems to be fine: "ready for take off"As I start FSX the "Diamonds" begin to fill rapidly. Using G****le as service 2, I'm getting a message that I have to fill in some letters and click okay, then loading is resumed correctly.What I don't understand is that except "preloaded 91.675" and "messages 471" (numbers only examples) everything else stays at 0.0 ??That doesn't change from then on . . .Starting my flight, the landscape is indeed photoreal made by Tileproxy.Close around the starting point of the flight the resolution is impressive, but moving away from there everything gets blurry (moving with 50knots) and it stays like this.All the while the diamonds and the text messages in Tileproxy haven't changed in any way (like "preloaded 91.675" and "messages 471").I used Filemon to check what Tileproxy is doing and what I noticed is that in the moment I fly away from the "entrypoint" there Filemon shows that Tileproxy cannot open file XXXX.XXXXXXXXXX.XXXX.bmp.Flying back to the entrypoint these messages disappear and the clear view is as in the beginning.After this flight the message lines in Tileproxy haven't changed all are 0.0 except "preloaded 91.675" and "messages 471" same numbers (!)THEN, after having closed the flight the preload and messages nunbers are rising again - tileproxy is downloading more files.What is going on here ??By the way, I had to deinstall my defragprogram to get Tileproxy to work . . . maybe that discovery helps someone else. Greetings Karsten

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi KarstenPerhaps you have found something here - regarding what you have found in Filemon. I will do some experimentation in that area today. First things first - I have no idea why your defrag program was interfering with TP - except to say that some defrags can be set up to run in the background automatically, and this may have been a problem for you. I have a third party defrag programme (JKDEFRAG) and I have it set so that it only defrags when I want it to. :-) AS for the "preloaded" messages and statistics - my understanding is that, having already flown in an area, when you start up again at that same place, the preloading system in TP loads all the tiles for that area - they are already existing on your harddrive. When you fly away from that area, TP should then go looking for new texture files. On my system , this works fine most times - textures get downloaded and everything looks good. But sometimes , the texture download can be slow - you can see in the TP DOS box that something is happening , just slowly. On these occasions, pressing the "pause" key allows everything to catch up - but at other times, after seeing blurry textures, the TP DOS box will show empty places where higher res textures should be - but nothing is happening to download those textures. Hitting "refresh scenery" in the sim causes it to go away and download the missing textures - this seems to happen OK, but is a nuisance. Obviously something is not right in this regard.I will play around with FILEMON today and see if it leads me anywhere.Regards Barry

Share this post


Link to post
Share on other sites

Thank you for your reply BarryYes, it is interesting: my defrag program (Raxco's Perfect Disk) wasn't running - it is running only if I ask it to do so. But in Filemon there could be seen hundreds and hundreds of accesses by Perfect Disk - it just didn't end, as if the gerag prog was indexing files or something like that. There is indeed a defrag function meant to put the defragmented files in an order so that the most accessed files are those who are placed unto the quickest accessable places on the HDD . . . So maybe that is a reason for this strange behaviour.Going back to Tileproxy: what got my attention is, that Tileproxy isn't loading any new files from the service (G****le) when I'm flying away from the startingpoint of the flight into whatever direction. The messages like "preloaded 91.675" and "messages 471" in the DOS box do NOT change during flight.I paused a flight for about 30 min to check, but there is nothing loaded in addition to the files that Tileproxy already has stored . . .When I quit the flight Tileproxy begins to show activity again resulting in for example 10.000 additional "preloads" and 80 new "messages".Going back on a new flight again, nothing changes during the flight: the number of "preloads " and "mesages" stays exactly the same during the flight - until I quit, then it is rising again.The flight itself is very smooth, without any interruptions, so obviously no new files are loaded during flight . . . the resolution doesn't change: images in close proximity to the airport remain crispy and those farer away stay blurry no matter how close I move towards them . . .Strange isn't it - as if only one program is willing to work at the same time - but not simultaniously.Greetings Karsten

Share this post


Link to post
Share on other sites

I dont think that the number of preloads shown at the top of the TP DOS box will change after you have initially loaded up. But - TP should update your textures as you fly along.Mine does update textures as I fly - for a while, and then it seems to stop. If I "refresh memory" , the cycle starts all over again. I have just been experimenting with this and changing all sorts of things - scenery settings ( even CPU priority and affinity) - but the cycle seems consistent to me. Load up at a previously saved spot - TP boxes are all full and textures are clear and crisp. Fly away slowly and TP downloads additional textures on the fly, everything going nicely for a while - then all of a sudden, further downloading stops - until I refresh memory and cycle starts all over againI was not able to duplicate the situation that you reported of BMP files no being able to ne read.I am convinced now that the best way to use TP is to fly around in a small area only - preferably by helo and build up the textures. I have been flying around the island of Oahu and just about have it completely covered. Nice place to fly by helo - good freeware mesh available (10meter) - good textures available on both G** and Y***.I use Y**** while flying in the US States - because G*** annoys me with Captcha.Barry

Share this post


Link to post
Share on other sites

My Godness . . . that is soooo beautyful !!My Tileproxy finally works !!!I noticed Christians post on the new map versions and so I changed the numbers in the ini to the actual ones - it works !!!I have no idea why, to be honest, but now there is a lot of activity shown in the DOS-box during flight numbers are increasing rapidely where previously there were only zeros all the time.Marvelous!I started to fly around Fuerteventura (Canary Islands) and it as beautyful as it can be . . . much better than the photoreal scenery I have for FS2004 - which of course was 4.7m/pix.Now, with 1.2m/pix you can recognize everything . . literaly everything. And the way that the beach blends into the water etc. great!Many thanks to you Christian for this Masterpiece of software!You are a hero for the FS Community!And many thanks to you Barry for caring about my problems.I'm off now . . . flying around the island for a while . . .Gorgeous!Greetings to all Karsten

Share this post


Link to post
Share on other sites

The Canary Islands is one place that I want to visit in TP - after seeing some excellent screenshots There is some scenery ( with 19M mesh) for the Canary islands here -http://library.avsim.net/esearch.php?DLID=82166To remove the mesh out of this scenery, Christian has posted this elsewhere "The download consists of three parts:http://library.avsim.net/esearch.php?DLID=82166The CanarySim package will look for FS 2004 to install itself - if youdon't have FS2004 the scenery manager tool that comes with it will spewout a lot of error messages. Ignore theseAfter installation of the CanarySim 2006 package, you may want tolook for these 5 BGL files in the CanarySim folder. These containthe highest resolution elevation meshes for each respective island.gcgm.bglgchi.bglgcladem2.bglgclpdem_11.bglgcxodemlod11.bglAfter placing these in your Flight Simulator XAddon ScenerySceneryfolder you should have a terrain mesh on 5 out of 7 major islands.UPDATE: I get a bit of an unnatural popup of elevation data in front of the plane. Maybe I should have copied the lod10, 9 and 8 versions as well. Only having the highest LOD data seems to confuse the sim.The authors are planning to release an update of their Canaryisland photoscenery in June this year, compatible with FSX withcoverage for all major islands."Haven't tried it myself yetBarry

Share this post


Link to post
Share on other sites

Looks like these files should be copied GCGM.bglGCHI.bglgcladem2.BGLGCLAdem_9.bglGCLAdem_10.bglgclpdem_9.bglgclpdem_10.bglgclpdem_11.bglgcxodem9.BGLgcxodem10.BGLgcxodemlod8.BGLgcxodemlod11.BGLBarry

Share this post


Link to post
Share on other sites

> My Godness . . . that is soooo beautyful !!> My Tileproxy finally works !!!Ah, the sound of success. ;-) I'm glad you overcame the technical issues.

Share this post


Link to post
Share on other sites

Thanks Barry for your infos regarding the 19m mesh for the Canary Islands.The photoreal covering that Tileproxy gives is impressive!The pudding like hills made by MS aren't . . .So - much appreciated!Thanks Christian!Yep ! You are breathing new life into this sim . . .Greetings Karsten

Share this post


Link to post
Share on other sites