Sign in to follow this  
Guest dkukla

"Safe Mode" start up ????

Recommended Posts

FS 2002 PRO. Been working fine for over a year. Updated Windows 98 last week from Microsoft Web site and now getting this error as soon as I start FS. I can go around the error but display is not what it used to be. Any ideas?SOFTWARE 3D ENABLEDSafe mode has been enabled because your system is currently unable to use hardware acceleration. ..........I have not changed any graphics cards or any hardware.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Obviously, something has changed so that FS "thinks" you've changed your graphics system or hardware. You've left a fair bit out. What updates from MS did you apply?My immediate suggestions--first make sure your desktop is running at 16 bit color res. or better....If it is, locate a copy of your video drivers, and reinstall.Last, reinstall Direct X....Very hard to suggest more without knowing details, especially related to your graphics card and updates that you might have applied....-John

Share this post


Link to post
Share on other sites

Hi DonI had this exact same problem the other day after I had installed some new drivers for my graphics card.I was not happy with the result and reinstalled the original drivers and FS2002 went into safe mode.Ended up uninstalling the original drivers again, then reinstalling them.Then went into settings on FS2002 and then was able to click on hardware acceleration.No further problems.Hope that helps.CheersMike

Share this post


Link to post
Share on other sites

Your on Windows 98, what else do you expect. DUH. Nuff' said.-Matt

Share this post


Link to post
Share on other sites

Press start, run, type dxdiag, let DirectX Diagnostic stabilize, select the display page. In the middle of the menu, ensure DirectDraw, Direct3d, and AGP Accelerations are enabled. If needed, enable then test each function. While you are at it, open the other tabs and test their functions also.Close DirectX diagnostic, start FS2002 to the Menu page. Select settings, display, hardware tab, and ensure the Hardware acceleration checkbox is enabled, OK, and go FLY!!!BTW, it can happen with Win98,ME,XP so the above vitriolic response is unwarranted.

Share this post


Link to post
Share on other sites

Thanks for the "tips"! I will try them over the weekend and hopefully get around this problem and back to flying. Appreciate the input!The major items that MS told me to update were the "critical" security patches and also major updates to Outlook and Explorer. I do not remember anything about updating drivers etc. unless they were imbedded in some of the other updates. Everything else still works fine as before, just FS giving me this message.The video card I have is ancient (came with the HP) and I think the drivers are still the original. We tried updating them a year or so ago and ran into some problems with updates so went back. I think it is a NVIDIA Vanta with drivers from 4-7-2000 (4.12.01). Maybe time for an upgrade as I did with the sound card a month ago. Your thoughts?The PC is a HP Pavillion 8595c, PIII.

Share this post


Link to post
Share on other sites

Went to "dxdiag" and here is what I saw.Display tab -> All three enable options (draw, direct 3d, and AGP) show "not available" so obviously not candidates to be "enabled".STATSDirectX Version = 8.1 (4.08.01.0881)NVIDIA Driver = 4.12.01.034 (English)Got a feeling here that these may be pretty old eh?

Share this post


Link to post
Share on other sites

OK, updated these ...DirectX to 9.0a (latest)NVIDIA Driver to latest 43.45 (4.14)All installed successfully and went to dxdiag and the three options (Draw, 3D, and AGP) are still listed as "unavailable". Cannot enable. Tried FS again and still getting the same message "Safe Mode" and the Display options do not allow hardware acceleration to be selected.There was some mention at the MS Knowledge base to make sure that hardware acceleration was enabled in BIOS. They did not have any instructions on how to do that. Any ideas how to enable this in BIOS?Thanks for all your help, appreciate it!!

Share this post


Link to post
Share on other sites

SOLVED!!! IT WORKS AGAIN!Thanks for all the "pointers" you all. You got me to the topics and I was able to not only fix the problem but now flying with all the up to date drivers! Ahhhh.BTW - Had to increase Hardware Acceleration in Control Panel, Display, Hardware. Moved it to "full", rebooted, and set the setting in FS (Display) for HE. Works great!Thanks again!Now to get the "Herc" flying missions again over IRAQ.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this