Archived

This topic is now archived and is closed to further replies.

treblesum81

Control Troubles On Short Final

Recommended Posts

Hi All,Lately I've been having a strange control failure on short final. This does not happen all of the time, usually only with more complex aircraft in heavy scenery areas, but the effect is always identical... At about 400ft AGL, the controls pull the plane hard to the right, repeated again at 300ft and 150ft. I understand this most likely has something to do with the heavy load put on my machine by the heavy scenery and heavy aircraft, though the fact that an x64 Quad core 2.83GHz with 4GB of RAM and 2GB of video ram should have any trouble running FS9 doesn't really make sense to me.Can anyone give any ideas on how to stop this loss of control on short final (Its very irritating after flying for 8-10 hours for a VA to need to constantly worry that I'll crash 100ft short of the runway) as well as how to get my computer to fulfill its potential... I bought it to run FSX, but at the moment its not doing much better than my old P4 3GHz with 2GB of ram and 256MB of video ram...Current setup:Intel Q9550 Quad Core 2.83GHz4GB Corsair 1066MHz DDR2Sapphire Radeon HD4870 X2Vista Home x64Any other information you need, please let me know.Thanks,Greg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a thought. Are you running Activesky and running with AI aircraft? If so, wake turbulence springs to mind.

Share this post


Link to post
Share on other sites
Hi All,Lately I've been having a strange control failure on short final. This does not happen all of the time, usually only with more complex aircraft in heavy scenery areas, but the effect is always identical... At about 400ft AGL, the controls pull the plane hard to the right, repeated again at 300ft and 150ft. I understand this most likely has something to do with the heavy load put on my machine by the heavy scenery and heavy aircraft, though the fact that an x64 Quad core 2.83GHz with 4GB of RAM and 2GB of video ram should have any trouble running FS9 doesn't really make sense to me.Can anyone give any ideas on how to stop this loss of control on short final (Its very irritating after flying for 8-10 hours for a VA to need to constantly worry that I'll crash 100ft short of the runway) as well as how to get my computer to fulfill its potential... I bought it to run FSX, but at the moment its not doing much better than my old P4 3GHz with 2GB of ram and 256MB of video ram...Current setup:Intel Q9550 Quad Core 2.83GHz4GB Corsair 1066MHz DDR2Sapphire Radeon HD4870 X2Vista Home x64Any other information you need, please let me know.Thanks,Greg
I can't believe that heavy load caused by scenery,busy airport etc would cause your aircraft to veer to the right.You may well get stutters and poor performance etc but you should continue in the right direction.If you where using Activesky i would suggest you may have the 'Wake turbulence' option checked and this may be causing loss of control on approach.(turbulence caused by the aircraft in front of you landing)cheers AndyPS cant believe your setup is having trouble with FS9 My PC specs are miles less than yours but i don't really have poor perfomance issues.SPECS SIZZLING SYSTEM ONEP4 2.80 single ancient core (probably rusting as i post)1 gb RAMGforce 6600 256mb AGP(AGP WHAT! HORRENDOUS)AskyFSGlobal SEFS Traffic 2005Sim runs fine.(the usual occasional stutters etc but have learnt to live with it and have found simming peace as a result)ANDY

Share this post


Link to post
Share on other sites

I think you guys hit it right on the head with the wake turbulence thing. I tried turning it off and it was gone, and as i think about it, it would only happen when coming in behind another aircraft since FS9 has no concept of seperation. Still wondering why my system is dragging with FS9, it plows through all of my most recent games (R6: Vegas, Company of Heroes) at huge frame rates, so why do I get stuck in the 10s with FS9... Are there any special settings I should use for a high end system to make FS9 use the resources properly?Thanks,Greg

Share this post


Link to post
Share on other sites