Archived

This topic is now archived and is closed to further replies.

nocaltom

Help with new build low fps with core i7 920

Recommended Posts

Hello, I just completed my new build and having low fps issues. here are the specscore i7 920 6gb corsair dominator ramevga mb x58 with newest bios8800gts 512 vid card300 gb sata hard drive580 watt ps waiting for newegg to ship a coolermaster 750dvd drivevista 64bitFSX with accelno anti virus and all firewalls off I only use this for FSX no other software installed or gamesupdated versions of direct x, nvidia drivers I have tried newest and went back to 175.19I installed fsx and accel went to play and had all sliders to the left(min) and could only get 10 fps at lax and 13 fps at krno. I had fsx on xp and was getting 20 fps at lax and 30+ at krno. With amd 5200 and with the 8800 gts and same drive.I have FSX in its own folder and have the UAC off.. I must be missing something here but cant figure it out...any help would be great.Thanks Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You may want to read Nick_N's FSX Install and Tuning Guide located here.From the things you've said so far I'd hazard a guess (from some of Nick's postings I've read) that you're throwing off the FSX priority system by having the sliders at the left, which can perversely cause lower FPS than having sliders set higher.

Share this post


Link to post
Share on other sites
Hello, I just completed my new build and having low fps issues. here are the specscore i7 920 6gb corsair dominator ramevga mb x58 with newest bios8800gts 512 vid card300 gb sata hard drive580 watt ps waiting for newegg to ship a coolermaster 750dvd drivevista 64bitFSX with accelno anti virus and all firewalls off I only use this for FSX no other software installed or gamesupdated versions of direct x, nvidia drivers I have tried newest and went back to 175.19I installed fsx and accel went to play and had all sliders to the left(min) and could only get 10 fps at lax and 13 fps at krno. I had fsx on xp and was getting 20 fps at lax and 30+ at krno. With amd 5200 and with the 8800 gts and same drive.I have FSX in its own folder and have the UAC off.. I must be missing something here but cant figure it out...any help would be great.Thanks Tom
Running zero sliders is not helping. As posted above you do need to tune FSX correctlyYou do need to make sure you have all your OS updates as well as DirectX and also make sure you are properly defragged.. however if you are running a i7920 unclocked your results will be limited. As i7 speed increases the perf result increasesThe 920 is cheaper for a reason and it can be clocked up but it does require the right heatsink solution to get it much above 3GHz safe and stable

Share this post


Link to post
Share on other sites
You may want to read Nick_N's FSX Install and Tuning Guide located here.From the things you've said so far I'd hazard a guess (from some of Nick's postings I've read) that you're throwing off the FSX priority system by having the sliders at the left, which can perversely cause lower FPS than having sliders set higher.
Thanks I will try that now, Will let you know what happens...Tom
Running zero sliders is not helping. As posted above you do need to tune FSX correctlyYou do need to make sure you have all your OS updates as well as DirectX and also make sure you are properly defragged.. however if you are running a i7920 unclocked your results will be limited. As i7 speed increases the perf result increasesThe 920 is cheaper for a reason and it can be clocked up but it does require the right heatsink solution to get it much above 3GHz safe and stable
Thanks nick, I will tune fsx with your guide and I just downloaded nhancer. I have overclocked to 3.8 ghz and its running fine I will let you know the results. D

Share this post


Link to post
Share on other sites

Update on system, It works......Thanks Nick for all of your posts, I have been reading all day. I used Nhancer and followed your guide on FSX. I went to Ksea like you said.l took off only getting 8 fps until I went full screen and whooooooooooooooo 30++ fps at the airport and city with everything on...then went to klax and was getting 25 fps at the airport this is awesome...i overclocked my 920 to 3.5 very stable so far. Thanks for your helpTom

Share this post


Link to post
Share on other sites
Update on system, It works......Thanks Nick for all of your posts, I have been reading all day. I used Nhancer and followed your guide on FSX. I went to Ksea like you said.l took off only getting 8 fps until I went full screen and whooooooooooooooo 30++ fps at the airport and city with everything on...then went to klax and was getting 25 fps at the airport this is awesome...i overclocked my 920 to 3.5 very stable so far. Thanks for your helpTom
There you go!Have fun Tom.. if you run into any problems.. refer back to that guide. Just about everything you need to know to get you in the ballpark is located there

Share this post


Link to post
Share on other sites