Archived

This topic is now archived and is closed to further replies.

Guest Proflig8tor

A fix for most CTD problems

Recommended Posts

Credit to NickN on Simviation Forums who writes - FSX runs fine... the problem is your operating system.I had a CTD any time I would select Leonardo/MadDog's MD80 and sometimes when loading scenery files while flying even the default airplanes. Both were fixed with this modification in Vista.

USING MORE/LESS or EQUAL to 2GIGS OF SYSTEM MEMORY IN WINDOWS XP x32 OR VISTA X32 with OOM-OR-HOW TO PROPERLY TUNE VIRTUAL ADDRESS SPACE IN WINDOWS (x32) FOR OUT OF MEMORY ERRORSx64 operating systems do not need the following changesPLEASE NOTE: This section is for anyone who sees out of memory error while using FSX. It applies to ALL circumstances.to clear up confusion about this change.. the amount reserved for the cache is NOT and DOES NOT have anything to do with the amount of memory in the system or how much memory you are allowing access to the system!!This change only tweaks the address space, relieving the OOM error. The 32bit system will use the physical memory installed up to 4GB regardless!If you have FSX SP2, the exe file is already 2G+ awareIf you have XP or VISTA x32 and more than 2GB you need to MARK the OS for that use or it will ignore the sticks and never use themx64 operating systems do not need the following changesFor XP:disable hidden files and folder, then on the root C:\ you will find a file named: boot.iniOpen it in notepad and add the follwoing to the end of the OS boot line:/3GB/Userva=2560multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows XP Professsional" /fastdetect /3GB /Userva=2560 <---- add it heresave and close the filerebootto set that back to default, simply remove the editIf you are using XP SP2 and are running a dual, quad, OR a single core Intel HYPERTHREAD processor, make sure this update is appliedhttp://www.microsoft.com/downloads/details...240-4934-BBD8...For Vista:WINDOWS VISTA ONLY: 1. Open a command prompt with Administration rights. You find the command prompt box under "Programs-Accessories-Command prompt" 2. Right Click the command prompt and select "run as administrator". 3. Enter in the box at the prompt: (copy/paste if you wish)bcdedit /set IncreaseUserVA 2560 and press enter 4. Reboot TO set that back to default in VISTA just start the command line prompt with Admin right again and type: bcdedit /set IncreaseUserVA 2048 Hit enter and reboot Make sure you have the VISTA updates from Windows Update installed that address out of memory errors too.http://www.simviation.com/cgi-bin/yabb2/Ya...?num=1188591122As long as you have Vista up to date with Windows update... or SP1 for Vista installed, you should already have those patchesFSX RTM or SP1 requres the user mark the exe file manually using special software for 2GB+ use.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Credit to NickN on Simviation Forums who writes - FSX runs fine... the problem is your operating system.I had a CTD any time I would select Leonardo/MadDog's MD80 and sometimes when loading scenery files while flying even the default airplanes. Both were fixed with this modification in Vista.
I tryed the idea for vista, what I got was all my controls were deleted , so I have to reprogram, But anyway it didnt work for me but thanks anyway.

Share this post


Link to post
Share on other sites