Archived

This topic is now archived and is closed to further replies.

Guest voices88

FS9 add on compatibility

Recommended Posts

Hello,New to these forums, so please be easy on me if the question has been asked a gillion bazillion times! I tried to search for it ahead of time, so please forgive me!!! :( So, I got a new rig, with all the bells and whistles, and Vista. Slapped in FSX and I am ok with it. However, I have so many add ons with FS 2004, I am thinking about adding FS 2004 back. I know Vista will work with FS 2004, but I wonder about all my add ons. I have: MegaScenery USA 2004 for Microsoft Flight Simulator Volume 3PMDG Boeing 737 NG 600/700 Flight 1 Ultimate Traffic Iron Knuckles DC-9PC Aviator Mega City USA 2005 San FranciscoPSS Dash 8-300Oh yeah, and PMDG B1900So will any of the above work with a Vista machine, running FS2004?THANKS!!!!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello,New to these forums, so please be easy on me if the question has been asked a gillion bazillion times! I tried to search for it ahead of time, so please forgive me!!! :( So, I got a new rig, with all the bells and whistles, and Vista. Slapped in FSX and I am ok with it. However, I have so many add ons with FS 2004, I am thinking about adding FS 2004 back. I know Vista will work with FS 2004, but I wonder about all my add ons. I have: MegaScenery USA 2004 for Microsoft Flight Simulator Volume 3PMDG Boeing 737 NG 600/700 Flight 1 Ultimate Traffic Iron Knuckles DC-9PC Aviator Mega City USA 2005 San FranciscoPSS Dash 8-300Oh yeah, and PMDG B1900So will any of the above work with a Vista machine, running FS2004?THANKS!!!!!
Im not running vista but it might be helpful to those who are mention whether it is 32bit or 64Mark

Share this post


Link to post
Share on other sites
Im not running vista but it might be helpful to those who are mention whether it is 32bit or 64Mark
Oh yes, it is 64. Thanks!

Share this post


Link to post
Share on other sites

Alright, so I have not installed anything yet. I have a Quad Core processor. I understand you can run XP on another core? I just really don't want to hassle between Vista and XP if I don't have to. I am getting used to Vista now, and I am trying to keep things simple on my new system. Any help regarding the addons would be soooo greatly appreciated. Here are the addons that I am hoping to add to FS 2004... Again, I just wanted to know if these will work or not running on Vista. Thanks guys and gals!!! :( MegaScenery USA 2004 for Microsoft Flight Simulator Volume 3PMDG Boeing 737 NG 600/700 Flight 1 Ultimate Traffic Iron Knuckles DC-9PC Aviator Mega City USA 2005 San FranciscoPSS Dash 8-300PMDG B1900

Share this post


Link to post
Share on other sites
Alright, so I have not installed anything yet. I have a Quad Core processor. I understand you can run XP on another core? I just really don't want to hassle between Vista and XP if I don't have to. I am getting used to Vista now, and I am trying to keep things simple on my new system. Any help regarding the addons would be soooo greatly appreciated. Here are the addons that I am hoping to add to FS 2004... Again, I just wanted to know if these will work or not running on Vista. Thanks guys and gals!!! :( MegaScenery USA 2004 for Microsoft Flight Simulator Volume 3PMDG Boeing 737 NG 600/700 Flight 1 Ultimate Traffic Iron Knuckles DC-9PC Aviator Mega City USA 2005 San FranciscoPSS Dash 8-300PMDG B1900
I think all those titles work under Vista64.

Share this post


Link to post
Share on other sites

Vista 64 does not like RCB guages. Avoid the Flight 1 Commander 112. Had trouble with the FSD Piper Meridian. Both used the RCB guages. Check the RCB page for more in-depth info. You've got to disable all those God forsaken permissions. Vista runs many things with stability and smoothness. Others..... Flight 1 has a good piece on Vista. I suggest checking on individual vendor pages to get an idea of software compatibility. You will have quite a learning process ahead of you. Ahhh....the mysteries of Microsoft.

Share this post


Link to post
Share on other sites
Vista 64 does not like RCB guages. Avoid the Flight 1 Commander 112. Had trouble with the FSD Piper Meridian. Both used the RCB guages. Check the RCB page for more in-depth info. You've got to disable all those God forsaken permissions. Vista runs many things with stability and smoothness. Others..... Flight 1 has a good piece on Vista. I suggest checking on individual vendor pages to get an idea of software compatibility. You will have quite a learning process ahead of you. Ahhh....the mysteries of Microsoft.
Darn it!! I thought I was over the learning stages of Microsoft. Oh well, I guess we live and learn.Thanks Word Not Allowed.

Share this post


Link to post
Share on other sites

Hi voices88.As mentioned, there are many issues with compatibility. I am not sure who is to blame, mostly MS, but there are many aircraft that will run on XP/Vista64 FS9 and FSX, like the TBM 700, and there are others, like most of the Flight1 that seem to be very specific, a pain. You have to start them a certain way, and forget about porting them, like from FS8 to FSX. The 112, Cardinal, Cherokee6 all are in this category. They really need to learn to get these things developed to be more useful, I basically stopped using them. The developers need to make the code work in all the combinations. It can be done, you can see many that are doing it, and there are some that never seem to make them right even for the specific combination / set up that was supposed to work with. TV

Share this post


Link to post
Share on other sites