Sign in to follow this  
Guest A321

Definitive answer to blurry textures?

Recommended Posts

Hi,I hae just started having blurred textures in the distance, which is annoying as I have had FS2002 since release and it has be ok up until now :(I have search through the old threads and I have come up with a lot of conflicting information.So what I would like to know does anybody have a definate way to stop these blurries?.Thanks in advanceDan.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have noticed that aside from the proper mipmapping lod settings, etc., when you use aircraft, like the Beechcraft 400, that have very graphics intensive gauges and interior textures, it eats up a lot of your CPU resources, on top of those needed for the better cloud graphics, etc., and thus your ground textures will load slower, and hence be blurry until they catch up. I think 2k2 gives the gauges priority so that they will move as smooth as possible. P4 1.8768 ram 80 gig hardriveVisiontek Ti4 4600CH yoke/pedalsElite Multi quadrant19" inch monitor-Soundblaster PCI 512Win XPInstrument rated ASEL -258 hoursAOPALawyerPilots Bar Association"Men without dreams are never free, twas thus this way and thus will ever be."

Share this post


Link to post
Share on other sites

Hi,Thanks for the reply, what are the "proper" settings for mipmapping?.Also I have looked into this "dynamic" blurring where by the computer has to catch up to load the textures, and it does not seem to be the culprit, I have my framerate locked at 25fps, and it VERY rarely dips below that, so I dont think that it is this dynamic blurring, also if you pause the sim to let the computer catch up, it still stay blurry, it is very annoying.BTW I have a P4 2.4ghz, 512mb ram and a Geforce 4 Ti4200 GFX card, with Win XP.What should the fs2002.cfg file settings be for a system like this?.Thanks in advanceDan.

Share this post


Link to post
Share on other sites

Blurred textures result when your video card is unable to keep up. Simple as that. I'd suggest you set your anistropic filtering and resolution as high as you can. Run it in performance mode. About the only other thing you can do is turn the terrain sliders down. Nothing wrong with the program. Just MS' way of telling you your computer isn't fast enough. Better to blur the textures than to bring the framerate to a screeching halt. I said goodbye to blurry textures when I bought a PIV2.53 with a 9700 Pro card. I run 4xAA & 16xAF Performance anisio and lock the framerate at 22fps. Now, having experimented till the cows came home, I've found that if I run 16x Quality Anisio, I'll see a blurred texture every now and then. A sign that the video card is stuggling to keep up with the textures. 16x Performance anisio looks just as good on FS' old terrain engine anyway and seems to be very fast. No problems with any textures regardless of what aircraft I'm using or how fast I'm flying. The Beechjet and Premier run just as well as the default Cessna on my rig.

Share this post


Link to post
Share on other sites

Hi,Ok, a couple of questions,1) What is performance mode?2) Why has it started now, I have had the same spec machine for at least a year, and it has only just started happening, have not changed anything.Thanks in advanceDan.

Share this post


Link to post
Share on other sites

Hi Dan,Another thing you have to check is about the Video Card drive. There

Share this post


Link to post
Share on other sites

Hi,Well, I had a MASSIVE play about over the last 2 days and came up with this conclusion.1) the blurries seem to be nothing to do with the settings available in FS2002, I tried EVERY setting available and it did not help.2) using the nvidia control panel, I played with various settings and came to this, set image to quality and anistropic to 2x.This cleared up my blurries, so it would seem that my problems were directly linked to my driver settings.I don't know why they changed, maybe something to do with my young daughter :), MUST CHANGE PASSWORD :)Thanks for your helpDan.

Share this post


Link to post
Share on other sites

Use the Omega Drivers, they simply rule, I use them and its like looking at a New game, trust me FS never looked so good.I use quinqux set at 2X, Anistropic Filtering at 2X, I Fly in a window @ 1280 X 1024. Full Scenery settings sliders maxed, 80% AI Traffic, UT Traffice lots of terra mesh and Scenery addons.I get good FPS even with A320 PIC..My System Spec:AMD Athlon XP 2800+1024 Mb RamAsus A7V-x Via KT 400 MoboGeeforce Ti 4400 128 MbJason

Share this post


Link to post
Share on other sites

Jason,Do you take any performance hit for the quality of image the Omega's provide? I was going to try them but heard that they are tuned for image quality at (some) cost to FPS.Best,Joel

Share this post


Link to post
Share on other sites

Hi Joel,I think I can answer that. Quite simply the response would be YES.What I have never understood is the enthusiasm folk have for the omega drivers when used with either a nVidia or ATI card with FS2002. When installed 'out-of-the-box', using the "quality" option, the terrain texture quality is to my eyes very poor and requires tweaking of the anisotropic and mipmapping LOD bias settings before you achieve the clarity you desire.The problem with tweaking the texture anisotropy level is the higher the level forced you go the greater the performance hit, although the ATI 9700 and 9800 Pro (mine :)) cards seem to handle this much better than the GeForce cards. This is not the case with the mipmapping LOD bias setting and you can reduce it to around 0.8 to improve image quality. However, the downside to this is the lower the setting the greater the pixel shimmering and to counteract this you need to employ some antialiasing with consequent hit on performance.It's all a matter of personal preference and compromises dictated by your systems capabilities.For example, I had a PIV 2.4 with a GeForce Ti4400 128MB GPU and, using RivaTuner tweaked the Anisotropy and Mipmapping LOD settings to force level 8 and -0.1 respectively. FSAA was a nono for the reasons above and so I preferred to run at 1280x960x32. You still see the jaggies but the overall image quality was very good.Now, I have upgraded my GPU to the all singing dancing ATI Radeon 9800 Pro 128MB and this now allows me to apply Anisotropic levels of x16 and FSAA of x4 without any significant frame rate hit. However, I have decided to stick with the Catalyst drivers (latest = 3.5) rather than the Omega equivalents and they appear very stable with superb image quality. That's not to say that the Omega drivers are inferior but they do still need some tweaking for FS2002 in my experience. I can only assume that the author is not a FS fan! Also, I have noted that even with Anisotropy and FSAA turned off prior to running 3DMark 2003 the scores are still significantly lower than the Catalyst driver equivalents. Remember, the Omega drivers are merely the nVidia or ATI releases with the tweaks already applied either for performance or quality. Saves you the hassle of doing it yourself as this is a little more tricky with the nVidia Omega variants as patch scripts have to be applied before the changes work properly.The above settings are coupled with the following in the FS2002.cfg file: (TERRAIN) <---------NB square brackets.TERRAIN_ERROR_FACTOR=3.470000TERRAIN_MAX_VERTEX_LEVEL=19TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=3TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=7.500000 <----TERRAIN_EXTENDED_RADIUS=8.000000 <----TERRAIN_EXTENDED_LEVELS=3 <----Mike :-wave

Share this post


Link to post
Share on other sites

>Blurred textures result when your video card is unable to>keep up. Simple as that.Well I can't agree with that. I've recently gone from a AMD 1.2 T-bird 768 PC133 RAM to AMD 2800+ Barton with 1Gig PC3200 RAM and now the blurries are all a distant memory. I kept the same graphics card (GF4-4200), with same drivers (Det 43.51).Cheers,Paulhttp://www.strontiumdog.plus.com/sbird.jpgOfficially licenced by British Airways plc for use of name and logo

Share this post


Link to post
Share on other sites

Most people, including myself, would be very skeptical at my apparent fix for the blurries. About a week ago I started getting the blurries after never experiencing them to much of a degree. These were bad blurries I am referring to. How did I make them go away? I happened to noticed my harddrive working a little more then usual and discovered I had not defragged my harddrive in 139 days. After the defrag, no more blurries. I wouldn't have believed it either.RandallWin98SEAthlon 1.4384mb DDR Radeon 9700Soundblaster X-gamer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this